Kodi Community Forum
[RELEASE] Amazon Prime Instant Video plug-in addon - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Amazon Prime Instant Video plug-in addon (/showthread.php?tid=108124)

- BlueCop - 2012-01-17 20:12

It seems they are implementing flash access. It is DRM.

Nothing to be done if they do it on all servers. The plugin will be gone.

- dmayle - 2012-01-20 07:27

Flash exists on linux platforms. Is calling out to flash out of the question?

- BlueCop - 2012-01-20 19:14

flash won't work on appletv2 or iOS. It could be possible on platforms where you could launch a browser to play a video in flash player.

I don't consider that a solution though. flash runs like crap on everything. The linux version of flash is pile of shit that can't scale anything without inducing stutter. The decoders are also horrible and don't seem to accelerate on platforms that they should.

I can't play flash h264 720p on my htpc. I can decode full bitrate bluray in xbmc on the same htpc though.

I haven't actually experienced any flash access videos myself though. I even looked up the video from the log to check it myself and it doesn't have flash access protection for me. It might be something that are testing in small numbers before doing everywhere.

- jmontana - 2012-01-20 20:15

Having just discovered this add-on, I will be very sad if it goes away. Regarding Flash performance, here is something I simply do not understand: Watching Amazon video in a browser on my HTPC is awful. The video is choppy and unwatchable. But watching via your add-on on the very same PC, performance is fantastic. Does this mean you are not currently using flash to view these videos? How is this possible?

Script fail for Amazon Prime - Treviley - 2012-01-21 19:07

I have an Amazon Prime account but I am getting script failed error whenever I run the Amazon addon. See my log file below.



- BlueCop - 2012-01-21 22:55

Treviley: It doesn't seem to find the log-in form on the page.

It loads the page below to be redirected to the sign-in form. That page will redirect to the log-in form.


The log doesn't have enough information to know why it couldn't find the form or it isn't there.

I just tried logging in a few times and it seems to be working fine for me.

I can add something to help debug it if it is persistent problem.

- Treviley - 2012-01-21 23:49

Thanks BlueCop. I will try again and update the log if necessary

- InsuranceGuy - 2012-01-22 05:54

BlueCop, your plugin is awesome!

I am getting something similar to nchaurdia. Here is my pastebin: http://pastebin.com/S69N7cR0

I am seeing some references to flash. I am guessing that it means that this TV show is now unwatchable with the plugin?

It is sad to see this stop working. Sad

- BlueCop - 2012-01-22 06:21

I have looked up the videos referenced in the logs and they dont have flash access drm for me. it might be having to upgrade them all. I hope they dont do this everywhere.

they treat customers like criminals for using their service.

for those that want to know flash access is a drm scheme to encrypt the video in file container.

they encrypt the video then transfer it to the CDN. they then can distro the key different ways. the drm is designed and implemented by adobe as part of flash itself. one can read all about it on the adobe website.

They will have to encrypt and upload the videos again to the CDN. this proabably takes a little time for it to spread.

- kegobeer - 2012-01-23 03:08

Thanks for the addon, BlueCop. It works for me, at least with the free stuff I get with my Prime account. I haven't tried renting one yet, probably won't since I have Netflix for that already.

- BlueCop - 2012-01-25 00:20

I have found a problem where script and style sheets were causing beautifulsoup to not parse it correctly. It seems to happen randomly. stripping them out solves it though. I will try to commit an update later. I am updating the databases first.

RTMP handshake error - Pointed - 2012-01-25 00:35

hey bluecop

Love your plugin. Recently I have been having a Handshake error. Not sure what the problem is. I have RTMP 2.4, but it still seems to give me an error. I have reinstalled the Amazon plugin twice. I can stream fine while on the amazon website. Don't know if that helps. I included the whole log because I had some problems installing it the last time and noticed that your site showed up as unreachable in the log. I assume this is because of the update. Any thoughts you have would help.


- BlueCop - 2012-01-25 00:38

Pointed: you are using a March 8 2011 build. it has the an older librtmp.

try eden beta 2

from http://mirrors.xbmc.org/releases/win32/

Handshake Again - Pointed - 2012-01-25 01:03


Updated to 11 beta2. I am running Win 7 Prox64. Would that make a difference? Still having same problem. Also getting an Amazon log-in problem randomly (had it before, but it shows up in this log). I am running Amazon 0.4.1 for the plugin. Do i need to update? I can't find the plugin through XBMC's plugins. So I am using the pack I downloaded from this thread about 2 months ago.


- BlueCop - 2012-01-25 02:28

Pointed: I am not sure. I have used that version with amazon before. I don't know why it would be using another librtmp. could you enable debug logging and make another log?