Kodi Community Forum
tvheadend backend - xbmc pvr: Cant watch recorded programs - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: PVR & Live TV Support (https://forum.kodi.tv/forumdisplay.php?fid=167)
+---- Forum: Tvheadend (https://forum.kodi.tv/forumdisplay.php?fid=168)
---- Thread: tvheadend backend - xbmc pvr: Cant watch recorded programs (/showthread.php?tid=110937)



tvheadend backend - xbmc pvr: Cant watch recorded programs - ravedog - 2011-09-25

Hey yall!

Got a nice little setup now and most things works smooth.

However, when i, from with in xbmc, try to watch [LIVE TV - recordings] i get a "Cant play, check logs" and the logs says:


Code:
11:13:38 T:3019200320 M:1825640448  NOTICE: DVDPlayer: finished waiting
11:13:39 T:3019200320 M:1825763328  NOTICE: DVDPlayer: Opening: http://xbmc:[email protected]:9981/dvrfile/2
11:13:39 T:3019200320 M:1825763328 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
11:13:39 T:2921298800 M:1825763328  NOTICE: Creating InputStream
11:13:39 T:2921298800 M:1825763328 WARNING: FillBuffer: curl failed with code 22
11:13:39 T:2921298800 M:1825763328   ERROR: CFileCurl::CReadState::Open, didn't get any data from stream.
11:13:39 T:2921298800 M:1825763328   ERROR: Open - failed to open source <http://xbmc:[email protected]:9981/dvrfile/2>
11:13:39 T:2921298800 M:1825763328   ERROR: CDVDPlayer::OpenInputStream - error opening [http://xbmc:[email protected]:9981/dvrfile/2]
11:13:39 T:2921298800 M:1825763328  NOTICE: CDVDPlayer::OnExit()
11:13:39 T:2921298800 M:1825763328  NOTICE: CDVDPlayer::OnExit() deleting input stream
11:13:39 T:3019200320 M:1825763328  NOTICE: CDVDPlayer::CloseFile()
11:13:39 T:3019200320 M:1825763328 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
11:13:39 T:3019200320 M:1825763328  NOTICE: DVDPlayer: waiting for threads to exit
11:13:39 T:3019200320 M:1825763328  NOTICE: DVDPlayer: finished waiting

However if i try to use the same line as above (http://xbmc:[email protected]:9981/dvrfile/2) but with the actual ip of the machine from another machine with vlc i can get picture (sound is lost but that might be something else).

password, user is correct and the backend is run on localhost from the xbmc's perspective

Any ideas?

Thanks for an awesome branch of an awesome product! Big Grin

/ravee


- ravedog - 2011-09-25

My bad, it was an configuration miss. Sorry about that.


- Graham_Chimp - 2012-01-09

Don't suppose you can let me in on what the configuration miss was ...... driving me nuts !!!!


- Graham_Chimp - 2012-01-09

Not sure how as I went over it several times ..... was a problem with the Access Control. Once I defaulted the PVR add-on settings followed by the removal of my access control settings its all working now. Blush


- ravedog - 2012-01-11

So sorry m8, i missed you first post completely Sad

I actually just reinstalled the backend from oden's repo. I took it from officiall repo before.

/r


- reven - 2012-01-30

i had a similar issue, mine was my xbmc login didnt have webaccess, apparently recordings need webaccess, but live tv doesnt.

just if anyone else runs into this issue.


This forum uses Lukasz Tkacz MyBB addons.