Kodi Community Forum
Can't get vdpau working with pre-eden and ubuntu oneiric - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: Can't get vdpau working with pre-eden and ubuntu oneiric (/showthread.php?tid=116251)



Can't get vdpau working with pre-eden and ubuntu oneiric - neoflex - 2011-12-06

Hi,

I have a lot of trouble recently with pre-eden on ubuntu oneiric (11.10).
I am on git master version.
A lot of crashes, mostly at the end of a video.
So, I tried to install last nvidia driver (290.10) but now I cannot get vdpau working. I installed libvdpau1 from ubuntu repositories but that didn't do it.

http://pastebin.com/f41gc8cp

Code:
23:37:51 T:2663316336  NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(1280x720, 28)
23:37:51 T:2663316336  NOTICE: vdp_device = 0xffffffff vdp_st = 0x00000001
23:37:51 T:2663316336   ERROR: (VDPAU) unable to init VDPAU - vdp_st = 0x1.  Falling back.
23:37:51 T:2663316336  NOTICE: CDVDVideoCodecFFmpeg::Open() Failed to get VDPAU device
23:37:51 T:2663316336  NOTICE:  (VDPAU) Close

from /usr/lib:

Code:
lrwxrwxrwx 1 root root   17 2010-12-13 20:13 /usr/lib/libvdpau.so -> libvdpau.so.1.0.0
lrwxrwxrwx 1 root root   17 2010-12-13 20:13 /usr/lib/libvdpau.so.1 -> libvdpau.so.1.0.0
-rw-r--r-- 1 root root 9596 2010-12-13 20:13 /usr/lib/libvdpau.so.1.0.0

any idea ? I already spent many hours or even days on this, trying different version of the nvidia driver ... can't get vdpau working Sad

xbmc is just configured with --enable-airtunes --enable-vdpau


config: ZBOX ND22 (ION)


- bobo1on1 - 2011-12-14

libvdpau.so is a wrapper lib, it seems like you're missing the vdpau nvidia backend, it's named libvdpau-nvidia.so or something like that.
Sometimes the symlinks get messed up, and then libvdpau can't load the nvidia backend.


- Oktboer - 2011-12-14

Could it also be called 'vdpau-va-driver'? Cause that one wasn't installed on my system. Will check as soon as I'm home...


- bobo1on1 - 2011-12-14

No, that's the vaapi backend that loads the vdpau frontend.


- Oktboer - 2011-12-14

Hmmm... Bummer.Sad


- bobo1on1 - 2011-12-15

What does your /usr/lib/libvdpau_nvidia.so symlink point to?


- Oktboer - 2011-12-16

I'll check this evening...

Edit: actually, there is no libvdpau_nvidia.so. I'm on LMDE, repositories pointing to testing.

These files are prestent: libvdpau.so.1 libvdpau.so.1.0.0

The first file points to the last one.

Best regards,

Stijn

Edit 2: maybe this can help?
Code:
[email protected]:/usr/lib/vdpau$ ls -al
total 120
drwxr-xr-x   2 root root  4096 Nov  7 08:15 .
drwxr-xr-x 220 root root 69632 Dec  8 13:36 ..
lrwxrwxrwx   1 root root    46 Aug  4 06:43 libvdpau_nvidia.so.1 -> ../x86_64-linux-gnu/vdpau/libvdpau_nvidia.so.1
lrwxrwxrwx   1 root root    23 Nov  6 22:29 libvdpau_trace.so.1 -> libvdpau_trace.so.1.0.0
-rw-r--r--   1 root root 47624 Nov 12  2010 libvdpau_trace.so.1.0.0

Also:
Code:
[email protected]:/usr/lib/x86_64-linux-gnu/vdpau$ ls
libvdpau_nvidia.so.1  libvdpau_nvidia.so.280.13
st[email protected]:/usr/lib/x86_64-linux-gnu/vdpau$ ls -al
total 1652
drwxr-xr-x  2 root root    4096 Nov  7 08:15 .
drwxr-xr-x 19 root root   20480 Dec  7 18:35 ..
lrwxrwxrwx  1 root root      25 Aug  4 06:43 libvdpau_nvidia.so.1 -> libvdpau_nvidia.so.280.13
-rw-r--r--  1 root root 1665448 Jul 28 02:15 libvdpau_nvidia.so.280.13

Lots of symlinks, but as far as I can tell there's no dead trace, right?


- neoflex - 2011-12-16

this is solved for me. Sorry for the false alert. It turned out that it was a bad configuration of my bios which prevented vdpau from working. The bios was on failsafe settings and it seems that this disables vdpau somehow.


- Oktboer - 2011-12-19

Bump. My problem isn't solved yet. Let me be clear: mplayer uses vdpau perfectly. XBMC doesn't crash or give any troubles otherwise but from CPU usage I can clearly tell it isn't using vdpau hardware acceleration. Please help. If more info is needed, I will provide it ofcourse.


This forum uses Lukasz Tkacz MyBB addons.