Kodi Community Forum
Ubuntu 10.04 + Skystar USB 2 HD driver problem - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: PVR & Live TV Support (https://forum.kodi.tv/forumdisplay.php?fid=167)
+--- Thread: Ubuntu 10.04 + Skystar USB 2 HD driver problem (/showthread.php?tid=116540)

Ubuntu 10.04 + Skystar USB 2 HD driver problem - Gnaddel - 2011-12-09

Hi there,

I'm trying to get the Skystar USB 2 HD-CI to work with my xbmc setup running on Ubuntu 10.04.

I tried several ways to get it to work but my google skills seem to have abandoned me in this case.

The last tutorials I've followed are this tutorial to setup TVheadend and this one (Sorry it's German, commands are pretty visible though) for the driver.

The current output of dmesg | grep -i dvb:
[email protected]:~$ dmesg | grep -i dvb
[   18.496896]     6740a932882f43056b8545e5b0b85511975d0a7c [media] tm6000: automatically load alsa and dvb modules
[   18.664142]     6740a932882f43056b8545e5b0b85511975d0a7c [media] tm6000: automatically load alsa and dvb modules
[   22.893022] dvb-usb: found a 'Technisat SkyStar USB 2 HD CI' in cold state, will try to load a firmware
[   22.893039] usb 1-4: firmware: requesting dvb-usb-az6027-03.fw
[   23.088540] dvb-usb: did not find the firmware file. (dvb-usb-az6027-03.fw) Please see linux/Documentation/dvb/ for more details on firmware-problems. (-2)
[   23.088568] dvb_usb_az6027: probe of 1-4:1.0 failed with error -2
[   23.088625] usbcore: registered new interface driver dvb_usb_az6027
[   40.404126] Modules linked in: appletalk dm_crypt snd_hda_codec_nvhdmi snd_hda_codec_realtek ir_lirc_codec ir_mce_kbd_decoder ir_sanyo_decoder mantis ir_sony_decoder lirc_dev ir_jvc_decoder dvb_usb_az6027 ir_rc6_decoder stb6100 mantis_core snd_hda_intel stb0899 snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy arc4 snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq dvb_usb snd_timer ir_rc5_decoder ath9k ath9k_common snd_seq_device nvidia(P) ir_nec_decoder dvb_core ath9k_hw ath vga16fb snd lp mac80211 soundcore rc_core vgastate parport psmouse cfg80211 serio_raw led_class snd_page_alloc vesafb fbcon tileblit intel_agp r8169 font bitblit mii softcursor agpgart ramzswap xvmalloc lzo_decompress lzo_compress
The TV-Adapter is not selectable in the TVheadend webinterface.

Thanks for any help you can provide,

- Gnaddel - 2011-12-09

And....solved Smile

Needed to place to dvb-usb-az6027-03.fw (available here, S7) in "/lib/firmware"

RE: Ubuntu 10.04 + Skystar USB 2 HD driver problem - mrdan - 2014-04-28

When you go on : http://linux.terratec.de/tv_en.html
the link is offline.

I need one of these files :


RE: Ubuntu 10.04 + Skystar USB 2 HD driver problem - Nafi - 2014-04-28

you can download it from openelec github: https://github.com/OpenELEC/dvb-firmware/blob/master/firmware/dvb-usb-az6027-03.fw ( right click - save as)