Kodi Community Forum
rtmpdump patch -Weeb TV - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: rtmpdump patch -Weeb TV (/showthread.php?tid=116987)

Pages: 1 2 3 4 5 6

rtmpdump patch -Weeb TV - Strzelec4 - 2011-12-15 15:37

I have an rtmpdump patch file that I would like to apply to my atv2 rtmp library. How do I do that? Thanks in advance

- Jester - 2011-12-15 16:05

Strzelec4 Wrote:I have an rtmpdump patch file that I would like to apply to my atv2 rtmp library. How do I do that? Thanks in advance


pull the source, apply patch, compile, run.

- Strzelec4 - 2011-12-15 17:01

Jester Wrote:https://github.com/xbmc/xbmc

pull the source, apply patch, compile, run.

Is there a way to compile for atv2 even though i don't have a mac. Can I do it on PC?

- newatv2user - 2011-12-15 17:38

Have you tried this?


- Strzelec4 - 2011-12-15 18:10

yeah I tried, doesn't work.
I basically want to get weeb.tv to work. I have the patch that I have to apply to rtmp library, but don't know how. On linux it seems easy, on MAC OS, I'm clueless :confused2:

REQUEST: Rtmp recompile - Strzelec4 - 2011-12-15 18:28

I'm trying to get weebtv streaming to work, but I need to apply a patch to my rtmplibrary on my atv2. The problem is I don't know how, and I cant recompile it on my pc because it is running windows, and I think I need a mac to do that. So my question is if someone could please recompile the rtmp library if I give you the patch file. Thanks.

- Jester - 2011-12-15 20:19

merged, please don't open 2 threads for the same thing.

- Ned Scott - 2011-12-16 00:21

I think you can just drop the file in, assuming the file is what I think it is. Should be called something like "librtmp.0.dylib"?

If so, drop it in:


- Strzelec4 - 2011-12-16 00:43

I basically have "file.patch" that i have to patch the library with

- newatv2user - 2011-12-16 02:03

Try this


- Strzelec4 - 2011-12-16 02:53

you are the best Smile Thank you soooo much

- rbebber - 2011-12-20 15:33

I got the file and am putting it on a second box for an xmas givt, put the file in
and it wouldnt copy, no permission, so i tried, in putty,
chmod mobile /private/var/stash/Applications/XBMC.frappliance/Frameworks/(file name)
and said no permission, what should I be doing? Thanks.

- Ned Scott - 2011-12-20 16:47

Log in as root

- rbebber - 2011-12-20 17:07

as opposed to mobile? thanks.

- Macielle - 2011-12-28 14:27

Still can't get it to work on ATV2 XBMC EDEN.

Pluggin error. Even with the librtmp.0.dylib.

Anyone got it to work?

MORE INFO HERE: http://code.google.com/p/sd-xbmc/downloads/list

happy new year! Smile