Kodi Community Forum
[RELEASE] Random and last items smartplaylist script for Skins - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Skinning (https://forum.kodi.tv/forumdisplay.php?fid=12)
+---- Forum: Skin helper addons (https://forum.kodi.tv/forumdisplay.php?fid=300)
---- Thread: [RELEASE] Random and last items smartplaylist script for Skins (/showthread.php?tid=122448)



RE: [RELEASE] Random and last items smartplaylist script for Skins - mikebzh44 - 2013-11-19

(2013-11-19, 12:49)baijuxavior Wrote: Just an update - there is no error now with the latest build, except that the last added 2d movie is not displayed on the widget, even though the smartplaylist shows this movie. I will try to add new movies and see if the problem exists.
If you browse your smart playlist : Videos > Playlists it's OK ?


RE: [RELEASE] Random and last items smartplaylist script for Skins - mikebzh44 - 2013-11-20

(2013-11-19, 14:17)butchabay Wrote:
(2013-11-19, 00:23)mikebzh44 Wrote: Yes, will have a look but, from what I understand from Martijn post, it should work so may be the issue come from Gotham, not from the skin.

Will do some tests and ask to Montelesse if it's a JSON RPC issue.

Thanx mate.
I think it's a JSON RPC issue :

http://forum.xbmc.org/showthread.php?tid=68263&pid=1554858#pid1554858


RE: [RELEASE] Random and last items smartplaylist script for Skins - ProsjektX - 2013-11-29

Hi,

I'm using the Xperience1080 skin which uses this script but it has never worked for me. Turning on logging I see the following two bugs/issues (I'll add the log in a few hours)

1. The script doesn't like spaces in filenames on SMB shares and causes an error
2. There's a JSON RPC issue that shows up after removing the space in the filename which causes the script to fail anyway

The smart playlists work fine when accessed directly.

Using Frodo 12.2 on both RaspberryPI and Win7 (same issues)


RE: [RELEASE] Random and last items smartplaylist script for Skins - butchabay - 2013-11-30

Hi Mike, just wanna let you know the script is working with today's nightly (30.11.2013) ... thanx for forwarding my problem.
Cheers


RE: [RELEASE] Random and last items smartplaylist script for Skins - Mudislander - 2013-12-29

(2013-11-30, 23:07)butchabay Wrote: Hi Mike, just wanna let you know the script is working with today's nightly (30.11.2013) ... thanx for forwarding my problem.
Cheers

@butchabay - so is calling a playlist from the skin folder working for you? Not for me, can only use playlists from userdata folder.


RE: [RELEASE] Random and last items smartplaylist script for Skins - butchabay - 2013-12-30

(2013-12-29, 23:39)Mudislander Wrote:
(2013-11-30, 23:07)butchabay Wrote: Hi Mike, just wanna let you know the script is working with today's nightly (30.11.2013) ... thanx for forwarding my problem.
Cheers

@butchabay - so is calling a playlist from the skin folder working for you? Not for me, can only use playlists from userdata folder.

Yes it works, even i'm getting a script error and i don't know why Smile


RE: [RELEASE] Random and last items smartplaylist script for Skins - Martijn - 2013-12-30

Debug Log Wink


RE: [RELEASE] Random and last items smartplaylist script for Skins - ProsjektX - 2013-12-30

Ok, I have never got this script working on neither RPI (Openelec) nor Win7 under the Xperience1080 skin. Can anyone shed any light on how to get this working or what is wrong?

I tried now on my win7 pc using both a mysql database and afterwards just scanning some files directly into the library (removing advancedsettings.xml and thus just using defaults), movies, but made no difference. Tried also playlists on both local drive and a share. Tried using Frodo 12.2/3. Have also tried updating to the 2.1.9 version on github..

See here for the two logs (close to the tail of the logs there's json rpc errors, parse error) and nothing is displayed in the skin.

http://www.xbmclogs.com/show.php?id=103680 (using mysql database)

One playlist looks like this:
Code:
<?xml version="1.0"?>
<smartplaylist type="movies">
  <name>Barnefilmer</name>
  <match>all</match>
  <rule field="path" operator="contains">Filmer - Barn</rule>
  <order direction="descending">title</order>
</smartplaylist>



RE: [RELEASE] Random and last items smartplaylist script for Skins - butchabay - 2013-12-30

(2013-12-30, 21:05)Martijn Wrote: debug log Wink

Yeah Martijn i know ... Smile I try to post a log tomorrow, now let's watch a movie first !


RE: [RELEASE] Random and last items smartplaylist script for Skins - butchabay - 2014-01-06

@Martijn

Well mate, nothing's wrong with the script, was my fault.
I called a playlist with the wrong .xsp name Smile

Cheers


RE: [RELEASE] Random and last items smartplaylist script for Skins - Martijn - 2014-01-06

(2014-01-06, 20:21)butchabay Wrote: @Martijn

Well mate, nothing's wrong with the script, was my fault.
I called a playlist with the wrong .xsp name Smile

Cheers

Oh hehe just remembered that I needed to look. Maybe fail graceful instead of error Wink
Can you still give me a log?


RE: [RELEASE] Random and last items smartplaylist script for Skins - butchabay - 2014-01-06

Hi mate, sure here they are:


First one is with the wrong .xsp names

xbmc.log - Script Fail


Second one is with corrected .xsp names

xbmc.log - No Script Fail


RE: [RELEASE] Random and last items smartplaylist script for Skins - Mudislander - 2014-01-07

I'm still having errors running the script on a playlist inside the skin folders.

Log of playlist in skin folder - Fails

or if I move the same playlist to the userdata playlist folder.

Log of playlist in userdata folder - Runs


RE: [RELEASE] Random and last items smartplaylist script for Skins - mikebzh44 - 2014-01-07

Hi Mudislander.

Cannot access pastebin from my office (thanks to the firewall Sad )

Could you paste you logs to xbmclogs.com ?

Thanks.


RE: [RELEASE] Random and last items smartplaylist script for Skins - Mudislander - 2014-01-07

Sure

Playlist in skin folder

Playlist in userdata folder

Just out of interest one (and only one) playlist in the skins folder has just worked - usually means my error. So I'll tear everything down to recheck how the script is run. If you could check the log for me to see if you can see anything , I'd be grateful


This forum uses Lukasz Tkacz MyBB addons.