Kodi Community Forum
[Windows] AudioEngine testers - Windows platform only - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Kodi Application (https://forum.kodi.tv/forumdisplay.php?fid=93)
+--- Thread: [Windows] AudioEngine testers - Windows platform only (/showthread.php?tid=124600)



RE: [Windows] AudioEngine testers - Windows platform only - DDDamian - 2012-04-17

Glad it was helpful Smile

@loekf - always double-check your audio settings in XBMC when switching between versions just to be sure Smile


RE: [Windows] AudioEngine testers - Windows platform only - ix400 - 2012-04-17

Hi Damian,

any news on the switching bug?

You mentioned it might be caused by the framing of the stream. Isn't it possible to just 'copy' the framing Daniela uses for the patched eden version?

Chris


RE: [Windows] AudioEngine testers - Windows platform only - loekf - 2012-04-17

(2012-04-17, 17:02)DDDamian Wrote: Glad it was helpful Smile

@loekf - always double-check your audio settings in XBMC when switching between versions just to be sure Smile

@DDDamian: gave it another try. Removed DanielaE's old version (incl. profile) and reinstalled the AE version. Make sure exclusive mode is on. Still the same result, stuttering for some movies with "vanilla" 5.1 DTS.

I'm back on the latest build from DanielaE.


RE: [Windows] AudioEngine testers - Windows platform only - jayhawk785 - 2012-04-21

Hey DDDamian, All of my stuff plays pretty much without a hitch. The only problem I have is after turning off the receiver, xbmc no longer want's to recover the sound device. I have it running in exclusive mode. In checking the logs I see a lot of:

AUDCLNT_E_DEVICE_INVALIDATED - I have to close and restart xbmc for audio to work again. Is there an easy way around this I'm missing?


RE: [Windows] AudioEngine testers - Windows platform only - CrystalP - 2012-04-25

That's a known error. Will be fixed after AE is merged in master.


RE: [Windows] AudioEngine testers - Windows platform only - DDDamian - 2012-04-25

CrystalP has already worked on code for pre-AE handling of the loss of an HDMI device - as he notes it will be incorporated post-merge. His work makes the logic a little more savvy when a device is invalidated, just it's written for the current XBMC audio sink and will need some touch-up work to merge with AE.

Look forward to that CrystalP.

Bigger update in next post....


RE: [Windows] AudioEngine testers - Windows platform only - DDDamian - 2012-04-25

Well folks - time for an update Smile

Sorry it's been a while. We've been going full tilt on a variety of features, bug-fixes, performance improvements and stability enhancements. A ton of sleep has been lost, spouses ignored and an HDD lost on the process (mine dammit lol).

As a direct result, I'm happy to announce that AE has now been submitted for team review, with an eye to hitting the May merge window for inclusion in the master branch. This is big news, both for users and us working on development. For users who build their own or use nightlies AE will automatically be part of XBMC master. For the devs of AE it will mean no more rebasing code to stay current, worrying about master commits affecting a future merge, or maintaining seperate projects. For everyone on Team XBMC it means that they can more easily fix bugs or add features to AE, making it available for all the Team to enhance, and this is good for everyone.

It also marks a year and a half of work by gnif, the main developer of AE, and he should be very proud of it. It is the single biggest internal project to merge with master yet, and a massive piece of code in it's own right. Other devs have worked on the code including Gimli and Memphiz for OSx, FneuFneu for BSD, and myself for Windows, to name a few, but this has been gnif's baby and it's been a pleasure working with him even though we're on opposite sides of the earth. We've managed to have a few laughs along the way Smile

In the past two weeks we've added automatic enumeration of system device capabilites, fixed a lot of buffering and delay calculation issues, DTS parsing issues for some of the odder formats like 14bit and big-endian encoding, improved performance of CPU usage, got DirectSound fully functional, and numerous other changes.

With the merge submission date approaching it's been a lot of work, and though there's still much more planned, it's finally come to the stage where it was felt "ready" enough to submit to the Team. From there other team members are welcome to review, propose changes, question code methods and make suggestions, but with an eye to inclusion into master.

I'll be putting up a build tomorrow - likely the last or second-last before merging, depending on how the review process goes. The build will be based on the latest pull from master so it includes things added post-Eden like the long-awaited ffmpeg updates and some other nice goodies.

I'll also try answer some of your posts from the last week, including what we found/fixed for some of the samples you guys have been good enough to post!

So check in late tomorrow (North American time) and the latest work with further comments will be uploaded.

Cheers,
Damian


RE: [Windows] AudioEngine testers - Windows platform only - liquidskin76 - 2012-04-25

Cheers for the update dddamian. Really looking forward to the new builds and merge.

Well done guys.


RE: [Windows] AudioEngine testers - Windows platform only - pyrodex - 2012-04-25

Thanks for the update!

Could this mean a DOT release of EDEN could get AE down the road?


RE: [Windows] AudioEngine testers - Windows platform only - jayhawk785 - 2012-04-25

(2012-04-25, 08:07)DDDamian Wrote: CrystalP has already worked on code for pre-AE handling of the loss of an HDMI device - as he notes it will be incorporated post-merge. His work makes the logic a little more savvy when a device is invalidated, just it's written for the current XBMC audio sink and will need some touch-up work to merge with AE.

Look forward to that CrystalP.

Bigger update in next post....

CrystalP/DDDamian, anyway to easily hack this into the AE branch? I read where someone stuck an hdmi splitter in between their box and the receiver and it stopped the issue--not sure I want to mess with that though.

This is already in eden final I assume?--as I had not seen the problem until recently (AE/and patch methods for HD Audio). I think I've pissed off the wife enough with having to restart xbmc each time she goes to watch something that I'll have to try to put eden back Smile--really looking forward to merge, I've been following this thread/news for a long time.


RE: [Windows] AudioEngine testers - Windows platform only - DDDamian - 2012-04-25

@pyrodex - the Team has settled on a different timeline structure - basically each month has a merge window for features and improvements, followed by a bug-fix feature-freeze, on a monthly cycle. We are hoping to pass review and hit the merge cycle for May. If that happens then 11.6 (Release 11-June) will have AE, and be in the nightlies Smile

@Jayhawk - it'll likely be in place at merge, so sometime during May near the end of the month.


RE: [Windows] AudioEngine testers - Windows platform only - DDDamian - 2012-04-25

Also, for anyone who wants to follow the review process in Git, pull request #900 is the pr. You can view it here.

For Windows stuff there's my repo (DDDamian on git) or you can track gnif's (gnif on git) for the complete picture with OSx, Alsa, Pulse, BSD, etc.


Re: [Windows] AudioEngine testers - Windows platform only - Martijn - 2012-04-25

To be clear. Those will still be nightlies and not official releases each month.


RE: [Windows] AudioEngine testers - Windows platform only - T800 - 2012-04-25

Not sure if you now the answer to this guys but how is OSX doing with AE? Can it bitstream HD audio or is it still restricted by the OS?


RE: [Windows] AudioEngine testers - Windows platform only - DDDamian - 2012-04-25

T800 - TrueHD can be decoded, DTS-MA only core. Sorry, just an OS limitation we can't get around.


This forum uses Lukasz Tkacz MyBB addons.