Kodi Community Forum
[RELEASE] XBMC Subtitles - Addon Script - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (/forumdisplay.php?fid=27)
+---- Forum: Subtitle Add-ons (/forumdisplay.php?fid=143)
+---- Thread: [RELEASE] XBMC Subtitles - Addon Script (/showthread.php?tid=126495)

RE: [RELEASE] XBMC Subtitles - Addon Script - rolandb5 - 2012-07-06 06:53

(2012-06-28 20:24)Thakoer Wrote:  Hai amet,

Ondertitel.com does not work any more. No result on any movie. I think there is change in their website?
I have emailed to the scriptmaker.

Same issue...

RE: [RELEASE] XBMC Subtitles - Addon Script - lubitsch_fan - 2012-07-06 07:09

(2012-06-29 06:42)lubitsch_fan Wrote:  (...)
2. Ordering of the list of languages, when localized
The order of the languages, in the add-on settings, is hardcoded in settings.xml, based on alphabetical order for those languages'
names written in english. But once localized, the languages names may change a lot, and then the list can be misordered.
For exemple, in french, "Korean" is written "Coreen", "Dutch" is called "Neerlandais", "Farsi" = "Persan", etc (+accents).
=> About issue 2., I wonder how it can be fixed, as I guess there's no dynamic mecanism for treating that XML file. Do you have an idea ?

Just found where it is handled, in XBMC C++ code. I'll look into it.

RE: [RELEASE] XBMC Subtitles - Addon Script - Scorpius - 2012-07-07 02:47

XBMC Subtitles have been working fine for me until a few days. Now it never finds a match even from movies I have searched before. I get things like that:
20:09:18 T:6020   DEBUG: ### [XBMC Subtitles-services.OpenSubtitles.service] - Search String [ This+Means+War ]
20:09:18 T:6020   DEBUG: ### [XBMC Subtitles-services.OpenSubtitles.service] - xbmc module hash and size
20:09:18 T:6020   DEBUG: ### [XBMC Subtitles-services.OpenSubtitles.service] - File Size [0]
20:09:18 T:6020   DEBUG: ### [XBMC Subtitles-services.OpenSubtitles.service] - File Hash [fa9063d5df2edebe]
20:09:18 T:6020   DEBUG: ### [XBMC Subtitles-services.OpenSubtitles.service] - Search by hash and name this.means.war.2012.unrated.720p.bluray.x264-sparks.mkv
20:09:19 T:6020   DEBUG: ### [XBMC Subtitles-services.OpenSubtitles.os_utilities] - Token:[m7ie1e8csj71eksq66oeng5bt7]

Also it is important to say that I *never* unrar my movies because the only reason I use XBMC is just that: I don't need to unrar them. Subtitles were working fine, now they don't. File Size = 0 might have something to do with the fact I don't unrar the movies.

Another example, Subscene.com:
20:09:52 T:4948   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Search string = This Means War
20:09:52 T:4948   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Getting url:http://subscene.com/filmsearch.aspx?q=This+Means+War
20:09:53 T:3884   DEBUG: ### [Qlock] - Delaying 3 secs
20:09:54 T:4948   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Multiple movies found, searching for the right one ...
20:09:54 T:4948   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Movie not found in list: This Means War

If you search that movie manually in each website you'll find dozens of subtitles for them. This is very very weird, since like a month ago it was working just fine.

RE: [RELEASE] XBMC Subtitles - Addon Script - kim1406 - 2012-07-07 22:21

I think it stopped working with Subscene.com after the new update in the site. The plugin may require an update to work again with subscene.

RE: [RELEASE] XBMC Subtitles - Addon Script - Scorpius - 2012-07-08 02:17

And what about OpenSubtitles? That one doesn't work for me either Sad

RE: [RELEASE] XBMC Subtitles - Addon Script - lubitsch_fan - 2012-07-08 04:36

Hello amet,

I just sent you a pull request with a change that enables the localization of languages names, in the search results:

(Please ignore my previous pull request #105 -I closed it-.
It was fine, but I included a little optimization in the new one).

Don't hesitate to ask for more info

Best regards.

RE: [RELEASE] XBMC Subtitles - Addon Script - kim1406 - 2012-07-08 12:29

(2012-07-08 02:17)Scorpius Wrote:  And what about OpenSubtitles? That one doesn't work for me either Sad

I don't know about Opensubtitles problem in your case as it is WORKING fine here. I have problem only with Subscene.com and I think it is due to the new site update which may require an update in the plugin.

Will wait for amet comment/update on both sites.

RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-07-08 12:34

No comment from me for a next few weeks, I am on a vacation

I can tell you that opensubtitles works here on my iPhone so it might be an issue due to the way rar files are recognized , we will never know until the requirements from the first post are met. Do not c/p the log in a thread and post a full Debug Log to pastebin, it's not difficult

RE: [RELEASE] XBMC Subtitles - Addon Script - Scorpius - 2012-07-08 19:40

Opensubtitles work with unrar'ed movies but it stopped working when they are rar'ed. That's no fun Sad

EDIT: Full debug: http://pastebin.com/mCTSnana

RE: [RELEASE] XBMC Subtitles - Addon Script - sugus4me - 2012-07-12 19:27

Installed XBMC subtitles on my OpenELEC box (Raspberry Pi), works fine so far with one exception: If I use it for series it only seems to search for the name of the series instead of the full episode name so the results I get are almost 100% unusable.

I tried several options but was not successful in changing that. Do I miss something here?

RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-07-13 12:12

(2012-07-12 19:27)sugus4me Wrote:  ...... Do I miss something here?

Debug Log?

RE: [RELEASE] XBMC Subtitles - Addon Script - search620 - 2012-07-13 15:46

Hey if you can add another three sites subtitles I'd be very grateful


These sites with Hebrew subtitles and they will help to so many people
Thank you!

RE: [RELEASE] XBMC Subtitles - Addon Script - NarkoKrig - 2012-07-16 18:46

Subtitles not getting downloaded, thought it says downloaded and extracted.

Running openlec 2.0 beta 5
Subtitle script version 3.2.1

Error log:

Any help or hints would be appreciated.

Update: found a temp fix - thx

RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-07-16 18:48

Known issue, we were working on it... In future read how to post Debug Log

RE: [RELEASE] XBMC Subtitles - Addon Script - jurrabi - 2012-07-16 22:28

Hi amet and all xbmc subtitles fans.

Like many of the non English native XBMC users from time to time I get errors in XBMC Subtitles script (as well as some others like youtube) related to strings encoding.

This last time has been a little weird. The script was working fine for some time. Then, with no update involved or any other noticeable change the script stoped working. At least most of it. Many of the servers failed always with some encoding related line. Things of the var.encode("utf-8") kind started to leave error traces in the log.

As many times, before posting here I like to find the root of the problem. I figured that the problem was caused because the program tries to encode to utf-8 something assuming it is an ascii string when in fact it is a latin1 or some other western Europe encoding variant.

For me, while the official solution comes along something of the kind var.decode("latin1").encode("utf8") usually solves the issue.

But this time I was intrigued since I was pretty sure I didn't change anything. I thought for a while that maybe the web pages changed encoding. But there were too many servers failing at the same time.

So finally I tried something I was sure wasn't going to solve anything. I deleted the subtitles add-on, then deleted the add-on config folder ( scripts.xbmc.subtitles inside userdata/addon_data), that is not deleted when uninstalling, and re-installed the add-on.

And it worked! I cannot explain but it happened like that.

So now I have no clues. Maybe something related to xbmc standard encoding for strings. Or maybe somehow a config option in the script forced it to use some folder with none ascii chars and the the problem comes...

Anyway I promise I'll keep looking into it and try to help.

I will experiment with non ascii folders and try to reproduce the problems and try to find the solution.

But for the time being maybe this solution works for some other folks...