Kodi Community Forum
Allwinner A10 : Is XBMC ported to MALI-400MP ? - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Hardware (https://forum.kodi.tv/forumdisplay.php?fid=112)
+--- Thread: Allwinner A10 : Is XBMC ported to MALI-400MP ? (/showthread.php?tid=126995)



RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - ceo16 - 2012-10-17

Hi, I compiled xbmca10 for my melea1000, I have lubuntu v4 with kernel 3.0.42 +, I continue to have problems with the cpu, when I start xbmc cpu working at 95/100%.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Nu7s - 2012-10-17

(2012-10-17, 05:30)lundman Wrote: If you are playing content over the wired nic, do get the kernel with the fixed nic drivers, otherwise you will get bad playback.
I have binaries for those wanting to test it quickly, although, i think the last upload was a few days ago, so it might not be the very latest.

Could the nic drivers cause my 1080p playback to stutter? I'm having this problem with stock rom.




RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Kweker - 2012-10-17

(2012-10-17, 05:30)lundman Wrote: If you are playing content over the wired nic, do get the kernel with the fixed nic drivers, otherwise you will get bad playback.

I have binaries for those wanting to test it quickly, although, i think the last upload was a few days ago, so it might not be the very latest.

I don't know if there are several patches for the wired nic, but I have used a wired nic patch a few months ago(in android using mxplayer) and the playback for 1080p did not work properly(stuttering video and audio) after the patch and where it worked with the original kernel without patch.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Nu7s - 2012-10-17

Were can I find this patch?


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - lundman - 2012-10-17

I guess different results for all involved. Stock Mele firmware can't stream 1080p over network, hence the patch work. With the patch, and changing the tcpwin size with setprop, makes playback smooth. The NIC drivers used CPU-busy-loop to do timing, so it would needlessly use high CPU, and blocking other processes from executing.

Anyway, patch is available on github. And if needed, I have a 36+ kernel build for miniand image.



RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Snippo - 2012-10-17

(2012-10-17, 09:17)ceo16 Wrote: Hi, I compiled xbmca10 for my melea1000, I have lubuntu v4 with kernel 3.0.42 +, I continue to have problems with the cpu, when I start xbmc cpu working at 95/100%.

What is your FPS in xbmc? I noticed that sometimes (I think) X11 doesn't close properly which causes xbmc to run very slow. Rebooting and restarting solves this most of the time.

I just tried enabling the PVR addons but xbmc freezes when I do that. I guess importing the channels causes too much cpu load.
Edit: Could also be that the addon isn't compatible with this build of xbmc as it freezes xbmc without restarting. Normally a freeze would lead to a restart of xbmc.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - our0 - 2012-10-18

Hello,
After having trouble compiling xbmc (strange pkg-config issues), I finally tried with linaro-precise-alip-20120724-274 (armhf) but now I'm having issues with armel / armhf using lundman's xbmca10.deb
Installing libc6-armel didn't solved it because it complains about missing libs (wich are presents). That's probably ld-related, but I don't know how I can solve that.
Can please somebody tell what I'm doing wrong ?


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rfreiha - 2012-10-18

Hi All

i am trying to follow the steps, when i type sudo apt-get build-dep xbmc, it is not working error package not found xbmc
any idea?
is there step by step guide for compiling it on mk802?
Thanks


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Snippo - 2012-10-18

Here is one for the Mele A2000. To get build-dep xbmc working you need to change your distribution in your xbmc ppa sources.list file to Oneiric. Seems that there is no package available for Precise.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rellla - 2012-10-19

(2012-10-15, 17:22)Snippo Wrote: I did some testing with the a10 build. Playing video files actually works really well. Great job on that Smile.
And some more observations:
- PVR doesn't work as most add-ons are only compatible with x86.
- It's possible to add TVHeadend channels with the htsp:// protocol. SD channels play fine. HD doesn't work at all.
- Dirty regions doesn't work. Just gives a black screen when it's enabled.
- xbmc freezes quite often, which leads to a restart.

Edit: I should have been reading the readme better...

I'm currently stuck with running pvr. Compiling addons is ok. Activating a pvr-addon fails. I got xbmc run smooth on a mele a2000 with empat0's repo, but i think i've some error in reasoning about getting arm/a10/pvr to run without bigger code improvements... Or should this be a minor thing?

rellla


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Snippo - 2012-10-19

Yes, same problem here. I managed to compile it but activating fails. I'm using your repo atm trying to play some H.264 files. Big Buck Bunny plays fine but most of my own movies won't. The only big difference I can discover is that files that play file are Baseline/[email protected] and files that won't play are [email protected]
I really have no knowledge about programming so I won't be able to tell you why it's not working.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rellla - 2012-10-19

I think it's maybe a problem with the header files. Check Makefile.am->sync: in xbmc-pvr-addons. If not intree compiling, you probably have to get the right .h's. If intree building, redo a ./bootstrap, then AC should check automatically. Just a thought - not tested yet.
rellla


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rfreiha - 2012-10-19

hi
am stuck with this error ./configure: line 20320: syntax error near unexpected token `FRIBIDI,'
./configure: line 20320: `PKG_CHECK_MODULES(FRIBIDI, fribidi,'
make: *** [all] Error 2
[email protected]:~/xbmca10/tools/a10/depends/xbmc$

any idea's

Thanks


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Vaevictus2 - 2012-10-21

has anyone / can anyone release a Mele A1000/A2000 ubuntu .img file that is working well as a build environment for the xbmca10 github branch?

ideally all I want to have do is log in to ubuntu on the mele, run a script and bam have the very latest xbmca10 version from github installed.

The easier we make it for users with this device to experiment with the ongoing changes by empatzero the more feedback we can provide


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Djape - 2012-10-21

(2012-10-21, 11:28)Vaevictus2 Wrote: ideally all I want to have do is log in to ubuntu on the mele, run a script and bam have the very latest xbmca10 version from github installed.

Well, it would require ages for your mele to compile xbmc, really.
It is actually done on powerful machine with all environment properly set (cross-compile).

But I like the way you're thinking Laugh