Kodi Community Forum
Allwinner A10 : Is XBMC ported to MALI-400MP ? - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Hardware (https://forum.kodi.tv/forumdisplay.php?fid=112)
+--- Thread: Allwinner A10 : Is XBMC ported to MALI-400MP ? (/showthread.php?tid=126995)



RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Snippo - 2012-10-21

Took a few hours here. It's not like I need to use my A1000 for anything else :p.
If you follow the guide I posted earlier you shouldn't have any problems. Besides, how are you ever going to update xbmca10 (if there will ever be any updates) if you don't know how to compile?


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Vaevictus2 - 2012-10-21

(2012-10-21, 19:56)Snippo Wrote: Took a few hours here. It's not like I need to use my A1000 for anything else :p.
If you follow the guide I posted earlier you shouldn't have any problems. Besides, how are you ever going to update xbmca10 (if there will ever be any updates) if you don't know how to compile?

./updatexbmcfromxbmca10github.sh :p

that's my point. One script, wait a few hours for the compile, new version, start testing and report feedback.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - jompan87 - 2012-10-22

(2012-10-21, 21:52)Vaevictus2 Wrote:
(2012-10-21, 19:56)Snippo Wrote: Took a few hours here. It's not like I need to use my A1000 for anything else :p.
If you follow the guide I posted earlier you shouldn't have any problems. Besides, how are you ever going to update xbmca10 (if there will ever be any updates) if you don't know how to compile?

./updatexbmcfromxbmca10github.sh :p

that's my point. One script, wait a few hours for the compile, new version, start testing and report feedback.

Thats beeing plain lazy, if you've seen the compile guide you'd know theres less than 1 min worth of executing commands once your setup




RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rellla - 2012-10-22

(2012-10-19, 12:56)Snippo Wrote: Yes, same problem here. I managed to compile it but activating fails. I'm using your repo atm trying to play some H.264 files. Big Buck Bunny plays fine but most of my own movies won't. The only big difference I can discover is that files that play file are Baseline/[email protected] and files that won't play are [email protected]
I really have no knowledge about programming so I won't be able to tell you why it's not working.

Do you have 2 small samples of both? Working and non-working?
rellla


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - dannyskj - 2012-10-22

(2012-10-21, 19:56)Snippo Wrote: Took a few hours here. It's not like I need to use my A1000 for anything else :p.
If you follow the guide I posted earlier you shouldn't have any problems. Besides, how are you ever going to update xbmca10 (if there will ever be any updates) if you don't know how to compile?

It took me 5 minutes to cross compile it on a quad core athlon Big Grin


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rellla - 2012-10-22

(2012-10-22, 11:29)dannyskj Wrote:
(2012-10-21, 19:56)Snippo Wrote: Took a few hours here. It's not like I need to use my A1000 for anything else :p.
If you follow the guide I posted earlier you shouldn't have any problems. Besides, how are you ever going to update xbmca10 (if there will ever be any updates) if you don't know how to compile?

It took me 5 minutes to cross compile it on a quad core athlon Big Grin
Can you do a simple summary, how you set up a right crosscompiling environment? Which host system do use? It's tiring doin' 6h native compile all the time ....
Thank you,
rellla

EDIT: Sorry, my fault. I've found it a few post ago. Should try, to build it an a debian machine...


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - alorma - 2012-10-22

Hi!

I tried to instal via apt-get in my hackberry A10, and it says i need openGL to start xbmc, hw can i install this? :S


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - dannyskj - 2012-10-22

Worked fine here using that guide on a ubuntu x64 host.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Snippo - 2012-10-22

@rellla
This one plays smooth and audio is in sync: http://www.dvdloc8.com/view_clip.php?movieid=12954

This one plays choppy and audio is out-of-sync (big time): http://www.dvdloc8.com/view_clip.php?movieid=25481
Same goes for pretty much everything in my library.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - hansarsch - 2012-10-22

how did you guys succeed in installing the lubuntu v3 image on mele devices? I can boot into lubuntu on my mele a2000 but neither wifi nor LAN are working.

no errors but upon connecting the LAN cable no lights are blinking and there's no connection. the WIFI adapter shows up (using iwconfig) but I can't connect to any network.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rfreiha - 2012-10-23

hi
i have managed to compile the package and run it, it run pretty well no legging but no sound
i used the rickomagic lubuntu version
is there away to install the sound drivers?

Thanks


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rellla - 2012-10-24

i have seen that empatzero merged his changes to his eden-pvr branch. can anybody do some tests?


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - CreaB - 2012-10-24

Hey there!

I compiled xbmca10 by using the guide on page 107 and this one: http://linux-sunxi.org/XBMC.
All went fine, was able to install the resulting *.deb-Package on my MK802 II but the performance is really bad.
I guess its the framerate, so you are not able to watch a movie.

Does anybody git a hint, what i'm missing?


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - lundman - 2012-10-24

The guys on irc mentioned that cedarx for armhf have shown up;

https://github.com/linux-sunxi/cedarx-libs/tree/master/libcedarv/linux-armhf




RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Mixx - 2012-10-25

I tried to crosscompile, using the instructions some pages back
Failed first at:
Code:
install -d /allwinner/xbmc-pvr-bin/lib
install: cannot create directory `/allwinner': Permission denied
Modifed:
Code:
XBMCPREFIX=$(HOME)/mk802/xbmc-pvr-bin$(HF)

then had to install g++-arm-linux-gnueabi

Now fails at :
Code:
checking for main in -lEGL... no
configure: error: Could not find a required library. Please see the README for your platform.
make: *** [all] Error 1

What am I doing wrong?