Kodi Community Forum
Allwinner A10 : Is XBMC ported to MALI-400MP ? - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Hardware (https://forum.kodi.tv/forumdisplay.php?fid=112)
+--- Thread: Allwinner A10 : Is XBMC ported to MALI-400MP ? (/showthread.php?tid=126995)



RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rellla - 2012-11-09

(2012-11-09, 15:59)Snippo Wrote: I managed to get the Mele remote to work by following the updated wiki. The keys are mapped very strange on the remote though (right arrow is mapped to backspace...) so I think I'll have to create a new keymap.xml.
Did you try the lircd.conf from wiki? I tried to rename the keys.





RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - Snippo - 2012-11-09

I noticed it after I posted that :p.
I managed to get it to work now. I had to make a custom Lircmap.xml to get the buttons to work in xbmc.
Another option would be to change the button names and remote name in lircd.conf to the standard names used by xbmc.
I didn't test all buttons but most of them should work with your lircd.conf from the wiki and this Lircmap.xml: http://pastebin.com/bZ1ruARD


Re: RE: AW: Allwinner A10 : Is XBMC ported to MALI-400MP ? - chandankp - 2012-11-09

(2012-11-08, 21:00)CreaB Wrote:
(2012-11-08, 19:54)rellla Wrote:
(2012-11-08, 13:39)CreaB Wrote: But the monitor is staying black and no accessibility via network is available..i guess there has gone something wrong, but can not check, because of lack of access.
Lack of access is a problem. It's nearly unpossible to find a mistake. You even cannot see, if it boots into debian. Probably for headless systems a .img which boots and gives at least console access directly or via ssh is more suitable for this mk802-stick. Otherwise it will get a very very blind trial and error search. Not funny. Better you search for a precompiled image...
rellla

Yeah, precompiled Image was what i prefer, but i only found linaro armhf and Ubuntu armel.
The First one gave me "cannot create display", the second one was not useable for xbmc-usage.

At the Moment i am back on Android, on both devices but would really like to switch to Debian armhf with xbmc.

Of anybody can offer me se guides/help/hints, i would try till i get it running.

Android is running ok, but i would like to use linux, because i am using a central mysql-database for xbmc and Android does not offer a nfs-kernel-Module, so I have to use smb.
http://guillaumeplayground.net/mele-a2000-ubuntu-12-10-armhf-base-with-nand-install-v1/
Ubuntu armhf images


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rellla - 2012-11-09

I proudly can announce, that xbmc is running with lirc now. Also i have set up a vdr (http://www.tvdr.de) which streams to xbmc-pvr on the same device. It basically works, but needs still some tuning. A/V Sync takes a long time and console/xbmc-gui/videostream overlays sometimes very heavy. system is armhf-debian on mele a100.
Since xbmc isn't working for production use, mele will act as streaming server with usb-dvb-adapters. And as a mpd, of course ;-)
rellla


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - CreaB - 2012-11-09

(2012-11-08, 13:07)rellla Wrote:
(2012-11-08, 12:51)CreaB Wrote: beacause an update gone bad, i'll start with a new prepared sdcard today.
Is there any better way than installing linaro first (from here https://www.miniand.com/forums/forums/2/topics/82) and then install an kernel/driver, etc.

maybe i startet from the wrong point and there is a smarter base to start from? =)

i recommend you do ALL steps once from scratch (rootfs, kernel, u-boot, script.bin, boot.scr) to build your own sd-card image. i'd prefer debian sid.
you should build rootfs on your own. kernel etc. can be taken from the latest hwpack.
then you can either give my binarys a try or compile xbmca10 yourself.

follow these instructions:
http://rhombus-tech.net/allwinner_a10/hacking_the_mele_a1000/Building_Debian_From_Source_Code_for_Mele/ <- adapt it to debian sid and armhf
http://linux-sunxi.org/XBMC and dicussion site
http://linux-sunxi.org/ in general

and don't mix x11 and xbmc. x11-mali-binarys do not work with fb-based xbmc. possibly there is some mix in linaro's rootfs because they use x11, which causes the error!
rellla

Hey there. you mentioned your binaries. I would like to give them a try, if you would like o provide me one of them.

Thanks in advance!


RE: AW: Allwinner A10 : Is XBMC ported to MALI-400MP ? - CreaB - 2012-11-09

(2012-11-09, 18:51)chandankp Wrote:
(2012-11-08, 21:00)CreaB Wrote:
(2012-11-08, 19:54)rellla Wrote: Lack of access is a problem. It's nearly unpossible to find a mistake. You even cannot see, if it boots into debian. Probably for headless systems a .img which boots and gives at least console access directly or via ssh is more suitable for this mk802-stick. Otherwise it will get a very very blind trial and error search. Not funny. Better you search for a precompiled image...
rellla

Yeah, precompiled Image was what i prefer, but i only found linaro armhf and Ubuntu armel.
The First one gave me "cannot create display", the second one was not useable for xbmc-usage.

At the Moment i am back on Android, on both devices but would really like to switch to Debian armhf with xbmc.

Of anybody can offer me se guides/help/hints, i would try till i get it running.

Android is running ok, but i would like to use linux, because i am using a central mysql-database for xbmc and Android does not offer a nfs-kernel-Module, so I have to use smb.
http://guillaumeplayground.net/mele-a2000-ubuntu-12-10-armhf-base-with-nand-install-v1/
Ubuntu armhf images

either it does not boot, or it does boot but there is no way to use it, because i am using a mk802, without rj45. wifi seems not to work by default and the default video output is vga, but i only have hdmi-devices.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - drachensun - 2012-11-09

I got a request for my binary via email so I've uploaded it. However Guillaume's page looks a lot more complete.

http://pengpod.com/pengwiki/index.php?title=XBMC


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - wolfgar - 2012-11-09

Hi there,

Could I ask to the happy few users who have a working XBMC on their A10 to check if they experience the same issue as I (ie lots of artifacts) when reading H264 videos with weighted P-frame prediction enabled ?
A sample video which is very poorly read by xbmca10 on my device can be found here
I thank you very much by advance for any feedback
Regards


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - chandankp - 2012-11-09

i am tryng to cross compile from ubuntu 12.04 64bit. I am getting following error after the command "make -C xbmc"

checking sys/inotify.h presence... yes
checking for sys/inotify.h... yes
checking boost/shared_ptr.hpp usability... yes
checking boost/shared_ptr.hpp presence... yes
checking for boost/shared_ptr.hpp... yes
configure: Using Python 2.7
checking for main in -lEGL... no
configure: error: Could not find a required library. Please see the README for your platform.
make: *** [all] Error 1
make: Leaving directory `/home/chandan/melehacking/xbmca10/tools/a10/depends/xbmc'
[email protected]:~/melehacking/xbmca10/tools/a10/depends#


Please can anyone help me to fix this error



RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rellla - 2012-11-09

(2012-11-09, 23:03)chandankp Wrote: configure: Using Python 2.7
checking for main in -lEGL... no
configure: error: Could not find a required library. Please see the README for your platform.
make: *** [all] Error 1
make: Leaving directory `/home/chandan/melehacking/xbmca10/tools/a10/depends/xbmc'
[email protected]:~/melehacking/xbmca10/tools/a10/depends#


Please can anyone help me to fix this error
Please post your config.log
rellla



RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - servili007 - 2012-11-11

(2012-11-09, 20:55)drachensun Wrote: I got a request for my binary via email so I've uploaded it. However Guillaume's page looks a lot more complete.

http://pengpod.com/pengwiki/index.php?title=XBMC

was hoping that these were armhf builds, but they are not, they are armel.


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - cnxsoft - 2012-11-11

(2012-11-09, 20:55)drachensun Wrote: I got a request for my binary via email so I've uploaded it. However Guillaume's page looks a lot more complete.

http://pengpod.com/pengwiki/index.php?title=XBMC

I suppose your image is armhf since you've got it running in what looks like the ALIP rootfs (or is it another rootfs with LXDE ?).
Edit: Oups, I should have tried it first, this is indeed an armel image.

I've cross-compiled XBMC armhf, and run it (I run a modified version (for armhf and linaro) of the script: xbmc-watchdog.sh) in Linaro ALIP 12.10, but it get relatively fps in the main menu (between 5fps to 12 fps). What kind of fps do you get in the main menu?

I've also got some issues playing video, it starts with hardware rendering (according to the log), but I can't play video, and the serial console gets flooded with messages like:
Quote:[DISP] not supported image0 pixel sequence:216 in img_sw_para_to_reg

I've also tried to disable lightdm: echo "manual" | sudo tee -a /etc/init/lightdm.override
So that it skips the X11 things, and I just access the command line, but it fails to start completely (EGL issue).


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - davilla - 2012-11-11

Humm, AllWinner reinvents itself as Penpod in the hopes that the bad taste goes away ?


RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - schwatter - 2012-11-11

maybe?



RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - rfreiha - 2012-11-12

Hi All

Anyone has compiled xbmc successfully for linaro armhf?
how does it look like?is it usable?

Thanks