Kodi Community Forum
Greek translation not working....? - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Skins Support (https://forum.kodi.tv/forumdisplay.php?fid=67)
+---- Forum: Transparency! (https://forum.kodi.tv/forumdisplay.php?fid=115)
---- Thread: Greek translation not working....? (/showthread.php?tid=128871)



Greek translation not working....? - sstavross - 2012-04-14

Hi!

I tried your skin and I have to say I like it very much! The only problem is that when I set it to greek (4.0.5, eden, windows 7) all the names/ titles of the skin doesn't show and even my folders' names that have greek letters dosn't show!! Am I doing something wrong?


RE: Greek translation not working....? - ronie - 2012-04-14

the default font included in T! doesn't support greek characters.
switch to the Arial font:
Settings > Appearance > Skin > Fonts - Arial


RE: Greek translation not working....? - sstavross - 2012-04-14

Thank you so much!!

Edit: Is there a way to put install some other fonts that support greek characters. Because the Arial one you have, has some faulties. for example, the letter "O" is always in capital and there are ( ' ) above capital letters that in greek languge we don't put in capital letters!


RE: Greek translation not working....? - sstavross - 2012-04-14

Ok, I've just found that in the translation file of your skin (strings.xml) there aren't the name of the main menu and that your skin is using the names of the default skin. But the name of the default skin ar with small letters and there are ( ' ) above the word but when you make them in capitals, in your skin, the continiue to have the ( ' ) above them and it is a mistake. Can I add the right names in your greek strings.xml file and how? What are the strings ids?


RE: Greek translation not working....? - ronie - 2012-04-14

you can update the greek language file yourself,
see here: http://forum.xbmc.org/showthread.php?tid=83350



RE: Greek translation not working....? - sstavross - 2012-04-14

Thank you, but I don't see the ids for the part of the main menu...




RE: Greek translation not working....? - ronie - 2012-04-14

i don't think there's a problem with the language file.
it's an issue with the font file.

i tried to update it, so greek characters should be properly capitalized now.

if you could test it...

put this file:arial-caps.ttf in ..xbmc\addons\skin.transparency\fonts\
and restart xbmc.


RE: Greek translation not working....? - sstavross - 2012-04-15

Hi again! Sorry for not answering you immediatelly, we have greek Eastern today and not so musch time...
I did replaced the original arial-caps.ttf with the one you provide here but no luck... The tones above capital letters remain. So ,for example instand of "ΒΙΝΤΕΟ" I see "ΒΊΝΤΕΟ".
But I did this: I took the arial-caps.ttf from the skin rapier and replaced yours and .... Success!!! Now the capital letters are perfect with no ( ' )!! So definately it is a font file problem. If you have any other files to test, I'll be glad to!


RE: Greek translation not working....? - ronie - 2012-04-15

thanx for the tip!
i'll copy the greek caps chars from the rapier font file then :-)


RE: Greek translation not working....? - lanc3lot - 2019-06-10

Hey, sorry I use this old thread, but I am facing the same very problem :-) But as I use kodi in both Android and PC build I am trying to find a solution for both. I tried the font above but as its 7 years ago, normally it doesn't work. Is there a way to re-upload someone so I can fix it inside both builds?
Ty in advance!


This forum uses Lukasz Tkacz MyBB addons.