Kodi Community Forum
UPnP Audio : No track number passed, all albums play alphabetically - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Music Support (https://forum.kodi.tv/forumdisplay.php?fid=263)
--- Thread: UPnP Audio : No track number passed, all albums play alphabetically (/showthread.php?tid=130891)



UPnP Audio : No track number passed, all albums play alphabetically - edszfa - 2012-05-07

Hi,

I've got a strange problem with the UPnP server component of XBMC - for some reason when playing audio files my clients seem to list all album tracks in alphabetical order with no regard for the track numbers. I can confirm that these track numbers are held in the ID3 tags of the mp3s, and the even the files themselves are in the correct order as the track number prefixes the song title in my file naming convention.

Is there an option somewhere that I'm missing to pass the track numbers (or force a sort by track no./ file name)? With settings as they are I can't see the UPnP audio server side of things being much use as it's not possible to listen to an album in the correct order. I've been all over the menus, although admittedly I've not dug through the advanced settings config files, looking for a fix. It's driving me crazy.


RE: UPnP Audio : No track number passed, all albums play alphabetically - jhsrennie - 2012-05-07

This is a long standing, erm, feature of XBMC's UPnP support. Basically the UPnP server is a half hearted implementation. I believe there is a project imminent to look at completely rewriting it.


RE: UPnP Audio : No track number passed, all albums play alphabetically - edszfa - 2012-05-07

Wow, really? What a shame, I can't believe something this basic is a bug and hasn't been addressed - it's such a fundamental flaw with what I'd imagine to be a trivial fix.

Many thanks for letting me know, you've saved me hours looking at all the possible config options and wondering what I need to do to fix it. I guess I now need to find and run a sepearate UPnP alongside my XBMC install. Bah.


RE: UPnP Audio : No track number passed, all albums play alphabetically - jmarshall - 2012-05-07

The track is set in the object's m_MiscInfo.original_track_number

It may well be that your client is expecting something else.


RE: UPnP Audio : No track number passed, all albums play alphabetically - nelms - 2012-05-10

Every client I have tried is the same in that songs are listed in alphabetical order. I've tried on my wp7 phone AV Remote, Linada and onePlayer. On my Ipad2 I've tried AirAV and media:connect all display tracks in alphabetical order.

I found this on the forum for media:connect:
http://support.personasoftware.com/discussions/mediaconnect-for-ios/265-audio-player-track-sort-option

Looks like there are a few who find this an issue. Is this on the roadmap for XBMC to look at and if so do you have a timescale?

This is my only niggle with what is otherwise such an amazing system.


RE: UPnP Audio : No track number passed, all albums play alphabetically - jmarshall - 2012-05-11

By the looks of the what it says there we already do set the appropriate properties. You need to track down exactly what needs setting up that we're not doing correctly. Any documentation found would be useful for developers.


RE: UPnP Audio : No track number passed, all albums play alphabetically - edszfa - 2012-05-11

So is it original_track_number or originalTrackNumber? Does this make a difference? I'm guessing it's most likely a bug rather than an incorrect design if it looks like XBMC is doing what 'it's supposed to'.

For info, I've never had any of my players get music in the correct order from XBMC, this includes hardware players such as Roku etc. Other open-source servers such as mt-daapd (formerly FireFly) seem to work as expected with everything I own.


RE: UPnP Audio : No track number passed, all albums play alphabetically - edszfa - 2012-06-05

Not that this is probably being read anymore but I've found a player which allows you to 'force' ordering by track number and even this doesn't work with XBMC as a uPnP source. Maybe it isn't passing anything at all in this property?? Or passing single dodgy value?


RE: UPnP Audio : No track number passed, all albums play alphabetically - berniel99 - 2014-06-09

I have recently installed XBMC (Version 13.1) on a new system and found a similar problem to what is described above, however, in this case, this occurs when using the XBMC machine as a uPnP renderer.

This is the current configuration:

I have a Synology NAS acting as a DLNA server for all of my music. The music is stored in folders (albums rips) in FLAC format, with a single cover.jpg image in each folder.

I use XBMC to play the music, which it does magnificently. XBMC also correctly shows the cover.jpg on screen when playing any tracks within a folder, when selected directly from the computer running XBMC via uPnP, which again is great. Furthermore, the tracks are shown and played in the correct order (track number order).

However, when I use the official XBMC control app on my iPhone, things behave a little different. I am still able to find and play the music, however, the cover.jpg image is not shown with the tracks anymore (on the iPhone or the screen) and worse still, all the tracks are played in alphabetic order, rather than by track number.

I was wondering whether this issue has been forgotten or never solved?