Kodi Community Forum
Updated to nightlies but no options for HD Audio - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: Updated to nightlies but no options for HD Audio (/showthread.php?tid=132040)

Pages: 1 2


Updated to nightlies but no options for HD Audio - matt77303 - 2012-05-21

Hi guys

Ive updated to nightlies using

ppa:team-xbmc-svn/ppa

expecting to see options for HD audio, but i dont.

I see the new services menu, but no options for HD audio like i do in the windows nightlies.

System is saying XBMC 12.0-Alpha1 Git:unknown ( compiled : apr 20 1012 )

Any ideas?


Matt




RE: Updated to nightlies but no options for HD Audio - matt77303 - 2012-05-21

also dont seem to have the new default skin

Matt


RE: Updated to nightlies but no options for HD Audio - matt77303 - 2012-05-21

nobody?

Matt


Updated to nightlies but no options for HD Audio - Memphiz - 2012-05-21

audio engine was merged on may 10th... your build is to old for having these options...


RE: Updated to nightlies but no options for HD Audio - matt77303 - 2012-05-22

thats what i thought, when i do update it says its the latest version.

im doing

sudo apt-get update

sudo apt-get install xbmc

it just says it the latest version and wont update

Matt


RE: Updated to nightlies but no options for HD Audio - davilla - 2012-05-22

that's the problem with 'latest', it could mean anything and nothing at the same time.


RE: Updated to nightlies but no options for HD Audio - matt77303 - 2012-05-22

this is what im following

http://shadower16.wordpress.com/2011/10/06/update-xbmc-live-to-pre-eden-nightlies/

just formatted and did a clean install of xbmc live 10.1 ( i think, the one before it was called xbmcbuntu ) followed the instructions and still ended up on the same build.

Matt




Re: Updated to nightlies but no options for HD Audio - Martijn - 2012-05-22

You are not pulling a nightly version but a alpha version.
They are in different locations (if available for ppa)


RE: Updated to nightlies but no options for HD Audio - john.cord - 2012-05-22

https://launchpad.net/~nathan-renniewaldock/+archive/xbmc-nightly


RE: Updated to nightlies but no options for HD Audio - dandirk - 2012-05-22

Matt, I am in the same boat, looking for a way to update to the master eden branch (for someone like me that isn't afraid to follow instructions but not a linux guru).

I haven't had any luck with instructions on compiling or installing that I found in the wiki or forum. I completely understand, for one they are test versions probably not really for us, more standard users. Also I know I wouldn't be too excited in the tedious and thankless task of writing guides.

Hopefully with the change to monthly test cycles known Dharma processes will be updated/communicated for eden. For the time being, I think I have pretty much given up, going to go back to Dharma or Openelec Dharma.

I know openelec has a thread with some Audio Engine builds that people compiled and put up, but I didn't have luck with those (at least for HD audio passthrough). Though it did look promising, menu sounds worked without a problem (always had had to do some sort of editing to get that to work).


EDIT: Thanks John... or nathan lol

Testing now, though my system has been knocked around a bit with various attempts and compile etc.

EDIT 2: Not working on XBMCbuntu, re-installed 11.0 from iso... At boot login, prompt, got into xbmcbuntu, and xbmc just wouldn't open. I assume because the PPA is more geared towards full linux installs. Well it was worth a try, Matt it may work for you.




RE: Updated to nightlies but no options for HD Audio - john.cord - 2012-05-22

(2012-05-22, 02:12)dandirk Wrote: EDIT 2: Not working on XBMCbuntu, re-installed 11.0 from iso... At boot login, prompt, got into xbmcbuntu, and xbmc just wouldn't open. I assume because the PPA is more geared towards full linux installs.

XBMCbuntu ist a full Ubuntu... what did you do to update?


RE: Updated to nightlies but no options for HD Audio - dandirk - 2012-05-22

I tried that following:

Install 11.0 from ISO (not sure if this maters, but entered xbmc and a password when prompted during install.

From putty ssh...

sudo add-apt-repository ppa:nathan-renniewaldock/xbmc-nightly
sudo apt-get update
sudo apt-get install xbmc




RE: Updated to nightlies but no options for HD Audio - matt77303 - 2012-05-22

that's the same as me but I'm coming from 10.1 (dahma)

Matt


RE: Updated to nightlies but no options for HD Audio - dandirk - 2012-05-22

Found the crash log

Code:
################ SYSTEM INFO ################
Date: Tue May 22 06:52:38 CDT 2012
XBMC Options:
Arch: i686
Kernel: Linux 3.0.0-19-generic-pae #33-Ubuntu SMP Thu Apr 19 20:59:10 UTC 2012
Release:
    Distributor ID:     Ubuntu
    Description:        Ubuntu 11.10 - XBMCbuntu
    Release:    11.10
    Codename:   oneiric
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################

06:52:37 T:3018381072  NOTICE: -----------------------------------------------------------------------
06:52:37 T:3018381072  NOTICE: Starting XBMC (12.0-ALPHA2 Git:Unknown), Platform: Linux (Ubuntu 11.10 - XBMCbuntu, 3.0.0-19-generic-pae i686). Built on May 21 2012
06:52:37 T:3018381072  NOTICE: special://xbmc/ is mapped to: /usr/share/xbmc
06:52:37 T:3018381072  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/xbmc
06:52:37 T:3018381072  NOTICE: special://masterprofile/ is mapped to: /home/xbmc/.xbmc/userdata
06:52:37 T:3018381072  NOTICE: special://home/ is mapped to: /home/xbmc/.xbmc
06:52:37 T:3018381072  NOTICE: special://temp/ is mapped to: /home/xbmc/.xbmc/temp
06:52:37 T:3018381072  NOTICE: The executable running is: /usr/lib/xbmc/xbmc.bin
06:52:37 T:3018381072  NOTICE: Local hostname: xbmc
06:52:37 T:3018381072  NOTICE: Log File is located: /home/xbmc/.xbmc/temp/xbmc.log
06:52:37 T:3018381072  NOTICE: -----------------------------------------------------------------------
06:52:37 T:3018381072  NOTICE: Setup SDL
06:52:38 T:3018381072  NOTICE: load settings...
06:52:38 T:3018381072  NOTICE: special://profile/ is mapped to: special://masterprofile/
06:52:38 T:3018381072  NOTICE: loading special://masterprofile/guisettings.xml
06:52:38 T:3018381072  NOTICE: Getting hardware information now...
06:52:38 T:3018381072  NOTICE: Checking resolution 12
06:52:38 T:3018381072  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
06:52:38 T:3018381072  NOTICE: Loaded playercorefactory configuration
06:52:38 T:3018381072  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
06:52:38 T:3018381072  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
06:52:38 T:3018381072  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
06:52:38 T:3018381072  NOTICE: Loaded settings file from special://profile/advancedsettings.xml
06:52:38 T:3018381072  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <useddsfanart>true</useddsfanart>
                                              <cputempcommand>cputemp</cputempcommand>
                                              <gputempcommand>gputemp</gputempcommand>
                                              <samba>
                                                <clienttimeout>30</clienttimeout>
                                              </samba>
                                              <network>
                                                <disableipv6>true</disableipv6>
                                              </network>
                                            </advancedsettings>
06:52:38 T:3018381072  NOTICE: Getting hardware information now...
06:52:38 T:3018381072  NOTICE: Checking resolution 12
06:52:38 T:3018381072  NOTICE: Default DVD Player: dvdplayer
06:52:38 T:3018381072  NOTICE: Default Video Player: dvdplayer
06:52:38 T:3018381072  NOTICE: Default Audio Player: paplayer
06:52:38 T:3018381072  NOTICE: Disabled debug logging due to GUI setting. Level 0.
06:52:38 T:3018381072  NOTICE: Log level changed to 0
06:52:38 T:3018381072  NOTICE: Loading media sources from special://masterprofile/sources.xml
06:52:38 T:3018381072   ERROR: PulseAudio: Failed to connect context
06:52:38 T:3018381072   FATAL: CApplication::Create: Failed to start the AudioEngine


############### END LOG FILE ################

Looks like pulse and AE have issues... thought pulse was not supposed to be usedHuh

oh well nature of the nightly beast lol


RE: Updated to nightlies but no options for HD Audio - Memphiz - 2012-05-22

Try to move your guisettings.xml away and see if it starts up then. No clue why it trys pulseaudio - but imho in the latest code it should be supported.