Kodi Community Forum
Release Universal Scraper for Music Albums - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Information Providers (scrapers) (https://forum.kodi.tv/forumdisplay.php?fid=147)
+----- Forum: Music Scrapers (https://forum.kodi.tv/forumdisplay.php?fid=303)
----- Thread: Release Universal Scraper for Music Albums (/showthread.php?tid=133547)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34


RE: [Release] Universal Scraper for Music Albums - prawnee - 2013-05-28

Is this something that could be easily fixed guys?


RE: [Release] Universal Scraper for Music Albums - crankylemur - 2013-05-28

ezechiel1917, great catch works fine after adding that to the .xml!

Would be great if it could be added permanently, very minor diff can be found here for it Smile
http://www.xbmclogs.com/show.php?id=22847


RE: [Release] Universal Scraper for Music Albums - ezechiel1917 - 2013-05-28

(2013-05-18, 15:56)Tolriq Wrote: Since wanilton post was not answered I'll add some more Smile

I don't know if the problem is in the scraper or in internal Xbmc yet but in recent Gotham there's a problem with scraping album genres.

My collection is perfect tagged, during one of the recent build the strArtists was dropped (I think for musicBrainz) and Xbmc asked for a rescan for Art
(Maybe change this message box since this is needed for way more than just art).

When I accept the rescan Xbmc drop all my albums genre in strGenres and put the artists in it.

I join a screenshot of the database during the process.

You can see the dropped artists with correct genre, then during the rescan the artist field is populated and the genre is replaced with the artist.

Image

I think this is currently general xbmc album scraping problem, I have the same issue with genres. There are various reports some ID3 tags are not correctly scraped to music database, I also have an issue that local covers are not added to database when album fails to scrape. We just have to wait till it's fixed in git master.


RE: [Release] Universal Scraper for Music Albums - prawnee - 2013-05-29

Olympia, crankylemur, ezechiel1917 thanks for your troubleshooting. Addon updated and working well. Thanks very much!


RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-05-30

Delayed reply ... Wink Thanks though. I've not been fishing for artwork recently, but it's come up again, so I'm still needing these filled in my collection.

(2013-04-04, 23:20)Martijn Wrote: 1.
if i'm correct you can artwork to fanart.tv for singles too. If it's not listed on the artist page use the release-group ID to add it.

If the image quality is not good enough for fanart.tv is local artwork the only way?

(2013-04-04, 23:20)Martijn Wrote: 2.
possibly or add the less well known artists to musicbrainz/theaudiodb and add their information.
adding to musicbrainz allows you to upload artwork to fanart.tv (where a large portion of the artwork from theaudiodb comes from).

What if the artwork is already in theaudiodb?

http://theaudiodb.com/album/2139869
http://theaudiodb.com/album/2152763

These will not scrape from my setup.


RE: [Release] Universal Scraper for Music Albums - zag - 2013-05-30

Make sure its scrapping the correct artists with an nfo file first. The artwork should download fine if its the correct music brainz id.


RE: [Release] Universal Scraper for Music Albums - bandelguy - 2013-06-06

The scraper sometimes fails to download album info . I dont know whats happening. The scraper has become slow . Using latest nightly on Win 7


RE: [Release] Universal Scraper for Music Albums - Tim. - 2013-06-07

I have setup a fresh XBMC 12.2 to test importing my music into XBMC with additional content via this scraper. I am testing with one artist and one album. I am using Music\Artist\Albums file format. I have turned on 'Download additional information on update' and added my source to the library. The artist/album is loaded correctly. The scraper grabbed the artist fanart/photo and bio without issue. The album however only has the description, Artist, Genre, Label and Year. My MP3's are correctly tagged.

After being unable to determine why the other fields are not being populated, I went so far as to make a album.nfo containing only the following:

Code:
http://www.allmusic.com/album/gold-greatest-hits-mw0000206799

However the same content is loaded. I am unsure why the 'Styles' field is not populated, for example. I manually can add the field to the NFO and it works correctly, so my NFO is being read. Why is it that the additional information like 'Styles' and 'Mood' are not being scrapped? I tried this for a few albums and had the same issue. Perhaps it is just these albums?

Any help would be much appreciated! Thanks for all your hard work.


RE: [Release] Universal Scraper for Music Albums - olympia - 2013-06-07

allmusic link in the nfo file doesn't help as the scapers needs the musicbrainz link.

I would suggest you to read the scraper description for the solution.


RE: [Release] Universal Scraper for Music Albums - Tim. - 2013-06-07

Understood. Keep in mind I tried first without any NFO, and found that only those few fields were populated.

I have tried the following URL in an NFO, and now no description or other fields are populated.

Code:
http://musicbrainz.org/release/59cf548b-bd56-4f8e-a610-92e36274c58c

Any help is always appreciated. Thanks!

EDIT: I think I might be understanding now. The reason the information is missing is because MusicBrainz does not have the allmusic link listed for that album under the "External Links" section? If so I need to create an account with MusicBrainz and add the links before scraping?


RE: [Release] Universal Scraper for Music Albums - olympia - 2013-06-07

(2013-06-07, 07:08)Tim. Wrote: Understood. Keep in mind I tried first without any NFO, and found that only those few fields were populated.

I have tried the following URL in an NFO, and now no description or other fields are populated.

Code:
http://musicbrainz.org/release/59cf548b-bd56-4f8e-a610-92e36274c58c

Any help is always appreciated. Thanks!
you need to add the release group, not the release if you want to force something via NFO. However, this will not help in this case, since MB doesn't hold the allmusic link.

(2013-06-07, 07:08)Tim. Wrote: EDIT: I think I might be understanding now. The reason the information is missing is because MusicBrainz does not have the allmusic link listed for that album under the "External Links" section? If so I need to create an account with MusicBrainz and add the links before scraping?
Exactly, but add this on the release-group level instead of the release level.


RE: [Release] Universal Scraper for Music Albums - godfreydanials - 2013-06-07

(2013-06-07, 06:47)olympia Wrote: I would suggest you to read the scraper description for the solution.
Where can I find this scraper description?


RE: [Release] Universal Scraper for Music Albums - Tim. - 2013-06-08

olympia,

Thanks for help! I created an account on MusicBrainz and will definitely be contributing!

I went ahead and checked the release group for my example album: http://musicbrainz.org/release-group/b69d665a-3eee-39f3-b156-58b122232304

You will see there already is an allmusic external link. Granted it is the wrong allmusic album, and I have already submitted an edit to correct this. However, the existing allmusic link does include styles/moods which are not being scraped. So back to square one I guess?

EDIT: Good news is when I place the release group link in a blank nfo:

Code:
http://musicbrainz.org/release-group/b69d665a-3eee-39f3-b156-58b122232304

The styles/moods/additional info scrape correctly! So why is it not working when scraped automatically with the Universal Scraper for Music Albums? Is there a log entry I can check to determine what URL is is trying to use?


RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-07-10

Hi. Ran an update today, and all sorts of strangeness .. updating the library took longer than usual, and when finished the 'music' section was empty. I had it run another update, and it's populated with artists again, but all the tracks are missing.

Here's a log http://www.xbmclogs.com/show.php?id=35765

Any ideas?


Seems fine now.


RE: [Release] Universal Scraper for Music Albums - clubwerks - 2013-07-25

I've googled the crap out of this, but I can't find an answer although I've seen the question asked several times on the XBMC forums. The Weezer self titled albums (Green, Red, Blue) don't scrape properly even though they're all tagged properly using Picard. Is there a way I can either get these to scrape or possibly just include the album description locally? Thanks,


This forum uses Lukasz Tkacz MyBB addons.