Kodi Community Forum
Release Universal Scraper for Music Albums - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Information Providers (scrapers) (https://forum.kodi.tv/forumdisplay.php?fid=147)
+----- Forum: Music Scrapers (https://forum.kodi.tv/forumdisplay.php?fid=303)
----- Thread: Release Universal Scraper for Music Albums (/showthread.php?tid=133547)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34


RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-08-25

Really not getting any where with this. A source that previously scraped a large percentage now does not. So I've looked at individual albums, here is an example:-

Artist: Hard-Fi
Album: Stars of CCTV

MusicBrainz: https://musicbrainz.org/release-group/577e56a9-9ccd-3d62-abab-719197e6f344 check!
AudioDB: http://www.theaudiodb.com/album/2120543 check!
FanArtTV: http://fanart.tv/artist/46d18823-6a15-49ee-8376-c5f7a49530a6/hard-fi/ check!

Yet, within my music library I don't get album artwork. So, I manually try and update, but get this error "Downloading album information failed". And nothing from debug .. but, for what it's worth, here http://www.xbmclogs.com/show.php?id=50076 .

Please, if any one can help ... even a guess would be better than nothing Smile


RE: [Release] Universal Scraper for Music Albums - zag - 2013-08-26

Check that the artist is tagged with the correct hyphen in hard-fi

I've had a few artists with hyphens not scraping and I found out the tag was using a different utf8 character for some reason, manually typing the hyphen into the id3 tag fixed it.


RE: [Release] Universal Scraper for Music Albums - capfuturo - 2013-08-26

Good night n1md4,

A bit more info could be useful to me or to others who might help figure out what could be triggering these error messages? Do you use Mysql? If so, what are your shares and what specific names do you use for the shares? Are you using the SMB source's name?

This might not be related to what is really causing the problem but I guess is better to ask some questions as a starting point in an attempt to narrow down the causes of the issue.

Best,

CF



RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-08-26

Hi CF,

Thanks for the reply. All storage is local. I have 3 drives, an SSD for the system, and 2x 1TB HDDs for data. I've created a VG including both 1TB drives, and then relative LVs for each media section (movies, TV, music, games, etc).

Regards,
n1md4

(2013-08-26, 00:10)zag Wrote: Check that the artist is tagged with the correct hyphen in hard-fi

I've had a few artists with hyphens not scraping and I found out the tag was using a different utf8 character for some reason, manually typing the hyphen into the id3 tag fixed it.

Thanks Zag. Do you have a suggestion for doing this on the command line on Linux? for OGG and FLAC.

I have tried another album, Aha Shake Heartbreak by Kings of Leon, same thing happens.

Just looking down the list of albums that get art, those that do have 'recognised' the associated artist. I'm not sure what's causing that though..


RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-08-30

olympia, I don't suppose you have any idea what causes the "Downloading album information failed" error I described previously? This will be my last post on the subject, unless it gathers traction, but it's a real show-stopper for me; and until now XBMC and associate add-ons have been so good to me, it would be a shame to be beaten now..


RE: [Release] Universal Scraper for Music Albums - olympia - 2013-08-30

(2013-08-30, 01:40)n1md4 Wrote: olympia, I don't suppose you have any idea what causes the "Downloading album information failed" error I described previously? This will be my last post on the subject, unless it gathers traction, but it's a real show-stopper for me; and until now XBMC and associate add-ons have been so good to me, it would be a shame to be beaten now..

No I don't and I also don't understand why you are not starting from scratch... Your database is clearly broken.
...and don't use "builds"! Use XBMC 12.2.


RE: [Release] Universal Scraper for Music Albums - zag - 2013-08-30

Just to say this scraper is working really well for me.

Finds everything I throw at it Smile

Oh and TheAudioDB now supports singles if anyone is interested Wink So get adding!


RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-08-30

(2013-08-30, 11:15)olympia Wrote: No I don't and I also don't understand why you are not starting from scratch... Your database is clearly broken.
...and don't use "builds"! Use XBMC 12.2.

I have tried several times from scratch, and it worked on my previous install. By starting from scratch, do you mean removing xbmc/userdata/Databases/MyMusicXX.db ?



(2013-08-30, 11:54)zag Wrote: Just to say this scraper is working really well for me.

Finds everything I throw at it Smile

Yeah. I'll probably reinstall.

(2013-08-30, 11:54)zag Wrote: Oh and TheAudioDB now supports singles if anyone is interested Wink So get adding!

Nice! Wanted this for some time now Smile


RE: [Release] Universal Scraper for Music Albums - olympia - 2013-08-30

(2013-08-30, 12:35)n1md4 Wrote: I have tried several times from scratch, and it worked on my previous install. By starting from scratch, do you mean removing xbmc/userdata/Databases/MyMusicXX.db ?

Doing this in itself doesn't help in all the cases. I would love to help, but I can't and seems like others can't either.
So I would just start with a clean userdata and see if it helps. Chances are very high it will. Unless you are using some nightly build where something is broken...


RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-08-30

(2013-08-30, 12:46)olympia Wrote:
(2013-08-30, 12:35)n1md4 Wrote: I have tried several times from scratch, and it worked on my previous install. By starting from scratch, do you mean removing xbmc/userdata/Databases/MyMusicXX.db ?

Doing this in itself doesn't help in all the cases. I would love to help, but I can't and seems like others can't either.
So I would just start with a clean userdata and see if it helps. Chances are very high it will. Unless you are using some nightly build where something is broken...

That's okay, I really appreciate all the assistance in any case! I'll try removing userdata, see what happens. Thanks again!


RE: [Release] Universal Scraper for Music Albums - olympia - 2013-08-30

At the end userdata is portable... You only need to rename it to something else for the test (XBMC will create a clean userdata on the next start). Following that, you can delete the freshly created userdata and rename your backup back again to userdata at any time you want.


RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-08-30

Okay. I'd already moved it and rebooted. Scanned the music, and all looks good now Big Grin ... except, it used local nfo files, and haven't loaded any artwork with it! Ha! I'll get there in the end Smile


RE: [Release] Universal Scraper for Music Albums - capfuturo - 2013-08-31

Good night Olympia,

For the last 2 weeks aprox., I haven't been able to retrieve any reviews from Allmusic.com for releases that previously had their reviews perfectly scrapped. Links to allmusic.com are present in Musicbrainz release groups and the musicbrainz links to the releases in the NFO files as well. Styles and moods do get scraped though. Has there been any change on that matter or are the reviews now being retrieved some other way perhaps?

Looking forward to your reply,

CF



[Release] Universal Scraper for Music Albums - olympia - 2013-08-31

(2013-08-31, 01:20)capfuturo Wrote: Good night Olympia,

For the last 2 weeks aprox., I haven't been able to retrieve any reviews from Allmusic.com for releases that previously had their reviews perfectly scrapped. Links to allmusic.com are present in Musicbrainz release groups and the musicbrainz links to the releases in the NFO files as well. Styles and moods do get scraped though. Has there been any change on that matter or are the reviews now being retrieved some other way perhaps?

Looking forward to your reply,

CF

Allmusic reviews are not supported for a long long time now. How did you even choose to scrape allmusic reviews in the scraper settings? No setting is available for this.


RE: [Release] Universal Scraper for Music Albums - n1md4 - 2013-08-31

When updating my library and the scraper says something like "Updating from local info files", considering I've not created any, where is this local info actually being read from? ...it's another attempt at fixing / understanding the system.


This forum uses Lukasz Tkacz MyBB addons.