Kodi Community Forum
Release MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Picture Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=150)
+---- Thread: Release MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags (/showthread.php?tid=133905)



RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - herve502 - 2013-01-13

Thanks Xycl for your reply !

Yes, I have just verified, It's the same build (12.0 RC3 Git:20130102 - 7a6cb7f compiled Jan 3 2013)

Perhaps, it's a problem with french langage with signed charaters (In a first installation, I have a problem with Mypicsdb because my window profile was 'hervé' and an error occured to find the tree with this name) Huh

My new profile is 'herve' on the windows pc and it's OK. With the microserver, where i have the problem, i have the Admin profile (Administrateur in french).

If you find where is the problem, i 'll be very happy becasuse it's a problem I have'nt think , so i can't range my pictures in the hdd and so i can't use XBMC and propose it to my family and say : "Look ! It's easy to use and ... marvellous ! Big Grin"


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - Xycl - 2013-01-14

(2013-01-13, 15:24)herve502 Wrote: Perhaps, it's a problem with french langage with signed charaters (In a first installation, I have a problem with Mypicsdb because my window profile was 'hervé' and an error occured to find the tree with this name) Huh
That's a good hint. I'll fix the problem with user profile names, too.

(2013-01-13, 15:24)herve502 Wrote: My new profile is 'herve' on the windows pc and it's OK. With the microserver, where i have the problem, i have the Admin profile (Administrateur in french).
That should not be the problem as long as it's not written Àdmínìstràtèúr Smile

Please, try the new MyPicsDB Frodo beta release (from my github repo) because between official last release and the new one, the complete picture scanning functionality changed.
To do this, install the repository from my signature and (if they exists) deinstall my old repos.


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - peppe_sr - 2013-01-14

(2013-01-13, 12:47)Xycl Wrote: Plus sign.

I found the issue.
Will be corrected soon.

I'm following on github.
Peppe



RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - Xycl - 2013-01-14

(2013-01-14, 14:38)peppe_sr Wrote: I'm following on github.
Peppe

It's still not deployed.

But you can copy
plugin.image.mypicsd/resources/lib/pathscanner.py
from master branch into your local plugin.image.mypicsd/resources/lib/ directory.
This solves your plus sign problem.



RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - herve502 - 2013-01-14

Wink many thanks, I try this in the evening

[EDIT]

I have installed the repo. The new version is 1.9.8.

But i have the same problem Sad

Should I do the same protocol as last time with the log file ? http://forum.xbmc.org/showthread.php?tid=133905&pid=1295718#pid1295718


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - Xycl - 2013-01-15

I'll gradually upgrade the debug logging.
For the future I hope to catch all issues with the enhanced logging.
For you this means that I'll have to insert debug logs for the complete scanning procedure and the data retrieval from DB. Then we should be able to determine the reason for your problem.I hope to get ready with this within this week Wink

My main problem is that I have to insert a lot of debug outputs which is not rocket science but time-consuming.


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - herve502 - 2013-01-15

OK Wink,

many thanks again ! I keep an eye on the thread and you can tell me what i must to do when your are ready.
(i hope you understand what i write, it's called the french style Blush Smile)




RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - Xycl - 2013-01-15

(2012-12-20, 12:12)Xycl Wrote: Frodo:

Don't use the geolocation with Frodo because it'll crash your XBMC.
It's already fixed by XBMC devs but not in RC1.

It still doesn't work.
My system: Windows 7 64Bit Professional and Ultimate on HTPC (AMD E-350), laptop (Core i7 2620m) and desktop workstation (Core i5 3570k). All XBMC instances working in portable mode.

Trac ticket #13776 is closed and marked as solved but it doesn't work.
[Edit] It's now reopened.

Can someone confirm that it's not only a problem on my machines?
To confirm: Select a geo tagged picture, open the context menu and select "geolocation" which will open a google map in a new window. Close the window with escape. Afterwards you won't be able to start any add-on and even closing XBMC won't work.
(2013-01-15, 13:01)herve502 Wrote: OK Wink,

many thanks again ! I keep an eye on the thread and you can tell me what i must to do when your are ready.
(i hope you understand what i write, it's called the french style Blush Smile)

Il ya 30 ans j'avais français en école. Ce pourquoi pas de problème.


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - herve502 - 2013-01-15

OK

I realise my first geotag ([G] appear after the name of the picture) and I confirm with a dell m 4700 ( core i7-3820QM) after hit the escape key. Similar problems for me.
[ Frodo RC3, (compiled at 3 january) ]


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - Xycl - 2013-01-17

Hi herve502,

thanks for your answer. Trac ticket is now reopened.

Please install the latest MyPicsDB from my github repo and make sure that the XBMC debug logging is activated (system->system->debug) because otherwise MyPicsDB don't write debug logs! It's dependent on the system setting.

If you've a directory with a small count of pictures then scan only this directory.
Afterwards copy the log to xbmclogs.

Xycl


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - herve502 - 2013-01-17

Hallo Xycl Wink


Here is the log file :
http://xbmclogs.com/show.php?id=28623

I have just removed a big part of the data about hd tv movies without interest and with a lot of lines (replaced by '...').

I have Five pictures in the folder C:\TEST2 called :
IMG_4812.JPG, IMG_4813.JPG, IMG_4814.JPG, IMG_4815.JPG, quai.jpg

The debug is activate from the beginning of the run with the installation of the zip file, the scan of TEST2 (already visible, installed in a previous installation and yet visible even the addon was previously removed). I return back in the menu item and start 'added last ten days' without anything into the result folder.


I hope I haven't active the debug mode too early.





RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - Xycl - 2013-01-17

Quote:copy zip://special%3a%2f%2fhome%2faddons%2fpackages%2fplugin.image.mypicsdb-master.zip/plugin.image.mypicsdb-master/scanpath.py -> special://home/addons/plugin.image.mypicsdb-master/scanpath.py

That line means that you copied my development repository as a zip from github. Not good because it contains a wrong path!

Quote:DEBUG: XFILE::CPluginDirectory::WaitOnScriptResult - plugin exited prematurely - terminating
19:56:58 T:3472 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.image.mypicsdb/
19:56:58 T:3472 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.image.mypicsdb/) failed
19:56:58 T:3472 DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/image/)

And that means that XBMC has a big problem because the directory the zip which was copied was named "plugin.image.mypicsdb-master" instead of "plugin.image.mypicsdb".

Quote:19:56:59 T:7068 NOTICE: MyPicturesDB plugin called :
Means that the add-on is not the latest version because now it looks like
Quote:22:47:01 T:5512 NOTICE: [plugin.image.mypicsdb] line 124 in default.py object Main.get_args >> MyPicturesDB plugin called :
22:47:01 T:5512 NOTICE: [plugin.image.mypicsdb] line 125 in default.py object Main.get_args >> sys.argv[0] = plugin://plugin.image.mypicsdb/
22:47:01 T:5512 NOTICE: [plugin.image.mypicsdb] line 126 in default.py object Main.get_args >> sys.argv[2] =
Please delete:
1) Directory: C:\Users\Administrateur\AppData\Roaming\XBMC\addons\plugin.image.mypicsdb-master
2) All zip files called "plugin.image.mypicsdb*" in directory "C:\Users\Administrateur\AppData\Roaming\XBMC\addons\packages"

Then install the repository from my signiture.
1) Download it and install it with system->Add-ons->install from zip file.
2) Install MyPicsDB: system->Add-ons->Get Add-ons->Xycl Add-on Repository->Picture Add-ons->My Pictures Database


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - rgponce - 2013-01-18

strings for Portuguese (Brazil)
http://minup.net/SBsFFe


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - Xycl - 2013-01-18

Translations are done with Transiflex.
Please look at: http://forum.xbmc.org/showthread.php?tid=141158


RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags - herve502 - 2013-01-18

Sorry for my bad protocol, i'm a xbmc's newbie.

1) I have realise the desinstallation of the addon, this action seems to delete the directory
"C:\Users\Administrateur\AppData\Roaming\XBMC\addons\plugin.image.mypicsdb-master"
Quote:2) All zip files called "plugin.image.mypicsdb*" in directory "C:\Users\Administrateur\AppData\Roaming\XBMC\addons\packages"
OK

Quote:1) Download it and install it with system->Add-ons->install from zip file.
Xycl 1.1.0

Here, i start xbmc with log file.
Quote:2) Install MyPicsDB: system->Add-ons->Get Add-ons->Xycl Add-on Repository->Picture Add-ons->My Pictures Database
OK, My Pictures Databa 1.9.11
I install the directory c:\TEST2, 5 scanned, 5 added
I select the 'added last ten days', no result

I don't know if i realise a bad action, but i scanned the directory again and not result again.

I think (and hope) the log file is good now:
http://xbmclogs.com/show.php?id=28743



This forum uses Lukasz Tkacz MyBB addons.