Kodi Community Forum
[RELEASE] Twitch.tv - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Twitch.tv (/showthread.php?tid=134538)



RE: [RELEASE] Twitch.tv - kdubbinn - 2012-09-17

have the newest twitch version on my apple tv 2 and none of the streams will play..it either says opening stream then doesnt open or i get a playback error


RE: [RELEASE] Twitch.tv - StateOfTheArt - 2012-09-17

(2012-09-15, 13:22)kingmob Wrote: [edit2]Tried compiling from git source and that appears to have solved the problem, thanks Smile. Still don't see the channels I follow though Sad

oh that's great... are you sure you entered your right account name in the settings? would be a great help to send your twitch-tv name to me via pm. maybe it's a problem with special characters i don't know of yet.

(2012-09-17, 00:55)kdubbinn Wrote: have the newest twitch version on my apple tv 2 and none of the streams will play..it either says opening stream then doesnt open or i get a playback error

i would guess that there is a problem with librtmp too. rtmp is the streaming protocoll used by twitch.tv (and justin.tv). twitch.tv seems to use some addtions to the protocol like the "jtv_token" which isn't implemented in older librtmp versions.

http://wiki.xbmc.org/index.php?title=HOW-TO:Update_librtmp ... could be worth a try




RE: [RELEASE] Twitch.tv - kdubbinn - 2012-09-17

thats worked perfect! thanks alot man



RE: [RELEASE] Twitch.tv - StateOfTheArt - 2012-09-17

(2012-09-17, 01:13)kdubbinn Wrote: thats worked perfect! thanks alot man

great! hope you enjoy the addon.


RE: [RELEASE] Twitch.tv - Kokarn - 2012-09-23

Great plugin! Have been looking for something like this for some time, it's awesome that it finally has arrived.

Two things tho, one bug and one feature request.

Bug
First of, my followed streams only shows one and not the whole list.
Right now when i go to twitch and watch what i'm following, there are six streams currently live.
In XBMC i can only see one.

The one is the one that currently has the most viewers, might that be the reason?
Nickname is same as here, kokarn

Feature request
It would be great to be able to add and/or browse teams, such as srl or dreamhack.

Anyways, love it. Hope you keep up the good work <3


RE: [RELEASE] Twitch.tv - Kiggerbare - 2012-09-27

Hmm, everytime i try to go into followed streams i get a "script error: Plugin.video.twitch" i'm not sure if it's because i follow to many streams, it worked before i added more streams to my following.
I use the latest stable xbmc build on a windows 7 64bit HTPC.
I also use the latest Pre-compiled librtmp.


RE: [RELEASE] Twitch.tv - StateOfTheArt - 2012-09-29

(2012-09-27, 11:34)Kiggerbare Wrote: Hmm, everytime i try to go into followed streams i get a "script error: Plugin.video.twitch" i'm not sure if it's because i follow to many streams, it worked before i added more streams to my following.
I use the latest stable xbmc build on a windows 7 64bit HTPC.
I also use the latest Pre-compiled librtmp.

Hey, would be useful to see the log file (the part where the error occurs) or to get to know your username on twitch - so i could try it by myself.


RE: [RELEASE] Twitch.tv - Kokarn - 2012-10-01

Now i got a different error, selecting a live stream that i am following got me "No Live Data Found".
Happends just when i click the one i was following, going to featured worked great.

Log file for the last couple of minutes, should include what you need.

http://pastebin.com/H5tW6Gxj


RE: [RELEASE] Twitch.tv - StateOfTheArt - 2012-10-01

(2012-10-01, 22:46)Kokarn Wrote: Now i got a different error, selecting a live stream that i am following got me "No Live Data Found".
Happends just when i click the one i was following, going to featured worked great.

Log file for the last couple of minutes, should include what you need.

http://pastebin.com/H5tW6Gxj

Thanks for the xbmc log. I think i was able to reproduce the error - it happend to me when i tried to watch Cosmowright (while i had 720p selected in settings). The error occurs, when a selected stream doesn't offer a specific video quality (like 720p in this case). I already fixed the bug in the current version available on github. I'll try to get the new version into the official repo very soon.

thumbs up for watching taketv by the way Big Grin


RE: [RELEASE] Twitch.tv - Kokarn - 2012-10-02

(2012-10-01, 23:53)StateOfTheArt Wrote:
(2012-10-01, 22:46)Kokarn Wrote: Now i got a different error, selecting a live stream that i am following got me "No Live Data Found".
Happends just when i click the one i was following, going to featured worked great.

Log file for the last couple of minutes, should include what you need.

http://pastebin.com/H5tW6Gxj

Thanks for the xbmc log. I think i was able to reproduce the error - it happend to me when i tried to watch Cosmowright (while i had 720p selected in settings). The error occurs, when a selected stream doesn't offer a specific video quality (like 720p in this case). I already fixed the bug in the current version available on github. I'll try to get the new version into the official repo very soon.

thumbs up for watching taketv by the way Big Grin

The weird thing is that it worked before, it changed the settings when it wasn't available a couple of days back, also Cosmo. Anyways, great to hear it's been updated.

Checked out the source and realized you use the old jtv api.
Seen the new twitch one? https://github.com/justintv/Twitch-API/wiki/API
If i knew a bit of python i would have helped out but i looked it over and it's way above me.
It does however look doable Smile

Thank you, i watch a bunch of different stuff and i think that was just to check if it works Tongue



RE: [RELEASE] Twitch.tv - Hauser - 2012-10-03

(2012-09-17, 01:06)StateOfTheArt Wrote: i would guess that there is a problem with librtmp too. rtmp is the streaming protocoll used by twitch.tv (and justin.tv). twitch.tv seems to use some addtions to the protocol like the "jtv_token" which isn't implemented in older librtmp versions.

http://wiki.xbmc.org/index.php?title=HOW-TO:Update_librtmp ... could be worth a try

I just wanted to say that I couldn't get the addon to work at all until I followed these steps, but now it seems to be working fine. Thanks for a great release!


RE: [RELEASE] Twitch.tv - StateOfTheArt - 2012-10-07

(2012-10-02, 09:39)Kokarn Wrote: Checked out the source and realized you use the old jtv api.
Seen the new twitch one? https://github.com/justintv/Twitch-API/wiki/API
If i knew a bit of python i would have helped out but i looked it over and it's way above me.
It does however look doable Smile

Thank you, i watch a bunch of different stuff and i think that was just to check if it works Tongue

I'm using the twitch api and the justin api. To list the followed streams, the twitch api requires a user authentication first (which is a problem right now). The justin api just needs the user name to get the followed streams, so it's a lot easier to use justin.tv api in this case.
But I'm working on a user authentication - especially to allow users to watch payed premium content.




RE: [RELEASE] Twitch.tv - Kokarn - 2012-10-08

(2012-10-07, 15:34)StateOfTheArt Wrote:
(2012-10-02, 09:39)Kokarn Wrote: Checked out the source and realized you use the old jtv api.
Seen the new twitch one? https://github.com/justintv/Twitch-API/wiki/API
If i knew a bit of python i would have helped out but i looked it over and it's way above me.
It does however look doable Smile

Thank you, i watch a bunch of different stuff and i think that was just to check if it works Tongue

I'm using the twitch api and the justin api. To list the followed streams, the twitch api requires a user authentication first (which is a problem right now). The justin api just needs the user name to get the followed streams, so it's a lot easier to use justin.tv api in this case.
But I'm working on a user authentication - especially to allow users to watch payed premium content.

Wow, that would be so great!
Loving the work you are doing.


RE: [RELEASE] Twitch.tv - Domanovic - 2012-11-05

So.. i'm quite new at XBMC, so don't hate for my very small amount of knowledge around it. Tongue

I have downloaded and installed the twitch.tv addon via the .zip file, but i can't seem to get it working.

Here is the part of the log file about it.

19:02:08 T:2744 M:2492264448 ERROR: Traceback (most recent call last):
File "C:\Users\Domanovic\AppData\Roaming\XBMC\addons\plugin.video.twitch\default.py", line 7, in ?
import xbmcvfs
ImportError: No module named xbmcvfs
19:02:08 T:3464 M:2492252160 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.twitch/
19:02:08 T:3464 M:2492252160 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.twitch/) failed
19:02:08 T:3440 M:2492235776 WARNING: XFILE::CFactoryDirectory::Create - Unsupported protocol(script) in script://

I am running XBMC Version 11.0 on a Windows 7 64-bit.

Can you help?



RE: [RELEASE] Twitch.tv - Kokarn - 2012-11-05

(2012-11-05, 20:29)Domanovic Wrote: So.. i'm quite new at XBMC, so don't hate for my very small amount of knowledge around it. Tongue

I have downloaded and installed the twitch.tv addon via the .zip file, but i can't seem to get it working.

Here is the part of the log file about it.

19:02:08 T:2744 M:2492264448 ERROR: Traceback (most recent call last):
File "C:\Users\Domanovic\AppData\Roaming\XBMC\addons\plugin.video.twitch\default.py", line 7, in ?
import xbmcvfs
ImportError: No module named xbmcvfs
19:02:08 T:3464 M:2492252160 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.twitch/
19:02:08 T:3464 M:2492252160 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.twitch/) failed
19:02:08 T:3440 M:2492235776 WARNING: XFILE::CFactoryDirectory::Create - Unsupported protocol(script) in script://

I am running XBMC Version 11.0 on a Windows 7 64-bit.

Can you help?

After searching for that specific problem there seems to be versioning problem.

Try to uninstall the add-on and install it from the addon menu in settings instead, that should fix the problem.


This forum uses Lukasz Tkacz MyBB addons.