Kodi Community Forum
[RELEASE] Twitch.tv - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Twitch.tv (/showthread.php?tid=134538)



RE: [RELEASE] Twitch.tv - anxdpanic - 2017-04-17

I think your skin is changing all text to uppercase... you'll have to change to estuary/confluence and open that pop-up and you will see the url properly.

Edit: You noticed at the same time. Smile


RE: [RELEASE] Twitch.tv - flohav - 2017-04-17

OK I got I working, the issue came from my skin showing me only uppercase characters, sorry for bothering and thanks for the quick replies!


RE: [RELEASE] Twitch.tv - anxdpanic - 2017-04-17

No bother, glad we got it sorted out for you. Smile


RE: [RELEASE] Twitch.tv - flohav - 2017-04-17

Actually, I had to update to beta because the channel I was trying to watch had the character "รข" in its title and that would led to an encoding issue. It works like a charm now, we can say all my problems were text-related Smile


RE: [RELEASE] Twitch.tv - Crowly - 2017-04-18

The reconnect to stream worked nicely when stream I was watching went down for a little bit Smile

Edit: When a stream ends because it is finished it also tries to reconnect, don't know if it's possible to detect the difference between a stream crashing etc and being finished. Not really an issue, just wanted to let you know.


RE: [RELEASE] Twitch.tv - eikum - 2017-04-18

Love the update! The quality is amazing! keep it up!


RE: [RELEASE] Twitch.tv - karl2017 - 2017-04-20

Thanks a million for your hard work!
As far as I can see at the moment, 2.0beta9 seems to work here on LibreElec8.01@RPi1b


RE: [RELEASE] Twitch.tv - anxdpanic - 2017-04-20

Thanks Smile Been tested in most common environments now I believe. (Windows/OSMC/LibreELEC/linux/Android/iOS/SPMC).

@Crowly: Yeah, we can tell the difference between 'stopped' or 'ended'. Haven't found a way to determine if 'ended' was due to stream ending or something else. Like you said as well it's not really an issue but if we do find a way, will implement it Smile


RE: [RELEASE] Twitch.tv - colbert - 2017-04-23

A few channels will play, most don't, I keep getting "No Live Data Found" all that's in the log is this:

Code:
12:45:25.077 T:10300   ERROR: CScriptInvocationManager::ExecuteAsync - Not executing non-existing script script.favourites
12:45:25.701 T:11768   ERROR: XFILE::CDirectory::GetDirectory - Error getting noop
12:45:34.616 T:9544   ERROR: SQL: [Addons27.db] Abort due to constraint violation
                                            Query: insert into package(id, addonID, filename, hash)values(NULL, 'plugin.video.twitch', 'special://home/addons/packages/plugin.video.twitch-1.4.5.zip', '7DD8A159BE74A5FCE917FBBA8C42F6A0')
12:45:34.617 T:9544   ERROR: CDatabase::ExecuteQuery - failed to execute query 'insert into package(id, addonID, filename, hash)values(NULL, 'plugin.video.twitch', 'special://home/addons/packages/plugin.video.twitch-1.4.5.zip', '7DD8A159BE74A5FCE917FBBA8C42F6A0')'
12:45:59.665 T:9572  NOTICE: [xbmcswift2] Request for "/" matches rule for function "createMainListing"
12:46:01.578 T:11568  NOTICE: [xbmcswift2] Request for "/createListOfGames/0/" matches rule for function "createListOfGames"
12:46:04.761 T:11556  NOTICE: [xbmcswift2] Request for "/createListForGame/Dota+2/0/" matches rule for function "createListForGame"
12:46:06.087 T:1180  NOTICE: [xbmcswift2] Request for "/playLive/dotastarladder_en/-2/" matches rule for function "playLive"
12:46:07.160 T:10300   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.twitch/playLive/dotastarladder_en/-2/]

I just uninstalled, deleted relevant folders from roaming/Kodi folder and reinstalled the addon too. I'm using Kodi 17.1 on Win10 x64.


RE: [RELEASE] Twitch.tv - Burt_93 - 2017-04-23

Hey all, i'm getting "No Live Data Found" in streams that clearly are working.


RE: [RELEASE] Twitch.tv - jaynford - 2017-04-24

Yeah, also getting that no live data found error


RE: [RELEASE] Twitch.tv - LarkinVB - 2017-04-24

I can confirm that the some streams are not working with the last stable version. Mainly the major stream from the current Dota2 Kiev Master tournament is failing.

Code:
08:19:21.417 T:1517659040  NOTICE: [xbmcswift2] Request for "/playLive/dotamajor3/-2/" matches rule for function "playLive"
08:19:22.841 T:1962176512   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.twitch/playLive/dotamajor3/-2/]

EDIT: It does work with 2.0.0beta10.

Using twitch with libreelec 8.0.1 on raspberry2.


RE: [RELEASE] Twitch.tv - jaynford - 2017-04-25

the 1.4.6 alpha fixed my issue for anyone having the same one.


RE: [RELEASE] Twitch.tv - Luterin - 2017-04-26

Today all of a sudden 1.4.6 alpha stopped showing my followed channels and gave an error, but followed games still worked. Anyway I thought that perhaps Twitch changed something and I knew that 2.0 was in the works, so I updated to 2.0.0 beta10 from the repository, but now nothing works anymore. No matter what I choose, nothing works, not even settings. But if I go into settings via the add-on system, instead of the add-on, then I can access the settings, and there reset the cache and got myself a new OAuth key, but still nothing works.

As a next step I deleted the old twitch related folders, both addon and settings, just to make sure there was no old crap left behind, and then redid the install of beta10 along with a new clear cache and a new OAuth key, but still nothing works when I click on anything. I just get a "working" popup that goes away a second later without any other changes. This no matter what menu choice I select.

I am on Windows 10 running Kodi 16.2, and as a next step I will update it to 17.1 now and see if that helps. Will post back after its done...


RE: [RELEASE] Twitch.tv - Luterin - 2017-04-26

After upgrading to Kodi 17.1 it actually started to work, and I realize that the menu system that didn't work according to my previous post was the "old" one from 1.6.4, even thou I had uninstalled it and removed data etc, but the new 2.0 menu is pretty different so it was easy to spot the difference. No idea why the old version stopped working, or why I couldn't get the new 2.0 to work, but atleast everything is working for me again now, and I even got to upgrade my Kodi which I have been putting off for a long time. Smile


This forum uses Lukasz Tkacz MyBB addons.