Kodi Community Forum
[RELEASE] Twitch.tv - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Twitch.tv (/showthread.php?tid=134538)



RE: [RELEASE] Twitch.tv - ancodia - 2017-04-26

Anyone having problems with 'Following'? It won't open for me. Worked ok yesterday.. Featured streams works ok.


RE: [RELEASE] Twitch.tv - presjpolk - 2017-04-26

Just came over to check on that myself, ancodia.

Looks like there was just a change made in Git that addresses it.


RE: [RELEASE] Twitch.tv - snesmaster40 - 2017-04-26

Yeah I also had problems with the "Following" area not opening. I just grabbed the latest version from the Github on the first post and it's working now.


RE: [RELEASE] Twitch.tv - wmansir - 2017-04-26

Version 2.0 was released on Github a couple of hours ago. I don't know when it will reach the main repo.


RE: [RELEASE] Twitch.tv - Crowly - 2017-04-27

Good job on the configurable main menu Smile

Sorting doesn't seem to work: I can change sort asc/desc, but it doesn't do anything with the list (mainly tried with past broadcasts). "Sort by" doesn't exist in the Estuary skin, in Confluence "sort by" is grayed out. This is with the latest version (from 26 april) from github.


RE: [RELEASE] Twitch.tv - CaelThunderwing - 2017-04-28

aftre getting "No Live Data" i tried updating to the 2.0 Release in the github as i had heard from a streamer the API has recently changed.
before though w/ 1.4.5 thats currently sittin in the Kodi repo for the Pi, i could atleast see my followed streamers so it was processing my oauth correctly.

now? it keeps declining saying ClientID Mismatch and i entered it in correctly. :/ do i need to reinstall the plugin aftre removing it because i updated it over the older one?

Kodi 17.1
(installed into Eazy Hax 16GB RetroPie Image for Pi Zero)


RE: [RELEASE] Twitch.tv - Parjai - 2017-04-28

(2017-04-28, 23:47)CaelThunderwing Wrote: aftre getting "No Live Data" i tried updating to the 2.0 Release in the github as i had heard from a streamer the API has recently changed.
before though w/ 1.4.5 thats currently sittin in the Kodi repo for the Pi, i could atleast see my followed streamers so it was processing my oauth correctly.

now? it keeps declining saying ClientID Mismatch and i entered it in correctly. :/ do i need to reinstall the plugin aftre removing it because i updated it over the older one?

I got that myself when going to 2.0. In settings, check the developer section (all the way at the bottom of settings on the left), and make sure OAuth Client ID is empty, and if it isn't, clear it. That fixed this for me.


RE: [RELEASE] Twitch.tv - soliduz - 2017-04-29

how do I download the updated addon from the Git? If I just click download zip when I install it in Kodi it gives a dependency error for python.

On win10


RE: [RELEASE] Twitch.tv - CaelThunderwing - 2017-04-29

(2017-04-28, 23:50)Parjai Wrote:
(2017-04-28, 23:47)CaelThunderwing Wrote: aftre getting "No Live Data" i tried updating to the 2.0 Release in the github as i had heard from a streamer the API has recently changed.
before though w/ 1.4.5 thats currently sittin in the Kodi repo for the Pi, i could atleast see my followed streamers so it was processing my oauth correctly.

now? it keeps declining saying ClientID Mismatch and i entered it in correctly. :/ do i need to reinstall the plugin aftre removing it because i updated it over the older one?

I got that myself when going to 2.0. In settings, check the developer section (all the way at the bottom of settings on the left), and make sure OAuth Client ID is empty, and if it isn't, clear it. That fixed this for me.

Still get ClientID Mismatch :/ do i need the "oauth:" along w/ the number&letter string?


RE: [RELEASE] Twitch.tv - CaelThunderwing - 2017-04-29

(2017-04-29, 00:00)soliduz Wrote: how do I download the updated addon from the Git? If I just click download zip when I install it in Kodi it gives a dependency error for python.

On win10

you need to install the python .zip along w/ the plugin. and you need to install that python dependancy first before attempting to install the update.

(oops can a moderator merge w/ my previous post? i cant delete this as it gives me a permission denied error)


RE: [RELEASE] Twitch.tv - Parjai - 2017-04-29

(2017-04-29, 00:11)CaelThunderwing Wrote:
(2017-04-28, 23:50)Parjai Wrote:
(2017-04-28, 23:47)CaelThunderwing Wrote: aftre getting "No Live Data" i tried updating to the 2.0 Release in the github as i had heard from a streamer the API has recently changed.
before though w/ 1.4.5 thats currently sittin in the Kodi repo for the Pi, i could atleast see my followed streamers so it was processing my oauth correctly.

now? it keeps declining saying ClientID Mismatch and i entered it in correctly. :/ do i need to reinstall the plugin aftre removing it because i updated it over the older one?

I got that myself when going to 2.0. In settings, check the developer section (all the way at the bottom of settings on the left), and make sure OAuth Client ID is empty, and if it isn't, clear it. That fixed this for me.

Still get ClientID Mismatch :/ do i need the "oauth:" along w/ the number&letter string?

no oauth:


RE: [RELEASE] Twitch.tv - CaelThunderwing - 2017-04-29

(2017-04-29, 00:15)Parjai Wrote:
(2017-04-29, 00:11)CaelThunderwing Wrote:
(2017-04-28, 23:50)Parjai Wrote: I got that myself when going to 2.0. In settings, check the developer section (all the way at the bottom of settings on the left), and make sure OAuth Client ID is empty, and if it isn't, clear it. That fixed this for me.

Still get ClientID Mismatch :/ do i need the "oauth:" along w/ the number&letter string?

no oauth:

been doing that thought at first i had to and was getting the error teh same, could thsi be because i mistakenly registerd a Developer API in my Twitch account for the plugin and tried that previously w/ the 1.4.5 plugin?


RE: [RELEASE] Twitch.tv - Crowly - 2017-04-29

First when you have an issue, look through the last 1-3 pages of this thread, it's very likely your issue has already been mentioned and (probably) solved.

You need to re authorize this addon, it is not compatible with the 1.x settings.


RE: [RELEASE] Twitch.tv - MrSprigster - 2017-04-29

2.0.0 is now fully released.

Big thanks to anxdpanic for his effort on this.


RE: [RELEASE] Twitch.tv - crunchprank - 2017-04-30

Thanks to everyone who contributed to 2.0.0. Quite a substantial update.

For anyone experiencing problems regarding the "Client ID Mismatch", as stated you will need to reauthenticate this application with your Twitch account. You can't simply use any oauth token (e.g. one you generated from the Twitch Apps tmi tool). You'll need to open a web browser, log into your Twitch account, and then go to the Google ShortURL referenced in the plugin (goo.gl/arFEqk) and allow the specified access to your Twitch account. It will then give you your oauth token. You do not need to add the "oauth:" part.


This forum uses Lukasz Tkacz MyBB addons.