Kodi Community Forum
[RELEASE] Twitch.tv - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Twitch.tv (/showthread.php?tid=134538)



RE: [RELEASE] Twitch.tv - anxdpanic - 2018-07-27

@imjustme  For now you'll need to HOW-TO:Install_add-ons_from_zip_files (wiki) the plugin.video.twitch-2.2.4.zip 
Will post to official repo after a couple days to ensure no new issues were introduced.


RE: [RELEASE] Twitch.tv - imjustme - 2018-07-27

perfect! thx so much. Smile


RE: [RELEASE] Twitch.tv - zoydberg - 2018-07-27

thanks for the quick update, but unfortunately now getting "Twitch: Error |Internal Server Error| |[500]|" when trying to browse any VOD for any channel, e.g past broadcasts, uploads, clips etc.

https://pastebin.com/wbiA4T2K

edit: nevermind, removed addon and settings, reinstalled, logged back in and now its working. thanks again though


RE: [RELEASE] Twitch.tv - dale77 - 2018-07-28

Hi,

trying to play streams today using Kodi 17.6 Windows I get a 404 error. Everything has been working fine until today.
Quote:16:31:45.071 T:7176 WARNING: script.module.python.twitch: API version |V5| is deprecated, update to |Helix| by |12/31/18|
16:31:45.939 T:7176  NOTICE: Twitch: Calling |list_channel_videos| for mode |channel_video_list| with pos args |['archive']| and kwargs |{'channel_id': None, 'game': 'Dota 2'}|
16:32:00.058 T:10108 WARNING: script.module.python.twitch: API version |V5| is deprecated, update to |Helix| by |12/31/18|
16:32:00.939 T:10108  NOTICE: Twitch: Calling |play| for mode |play| with pos args || and kwargs |{'video_id': 'v289078704'}|
16:32:01.589 T:10108   ERROR: Twitch: Error |Not Found| |[404]|
16:32:01.617 T:4396   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.twitch/?video_id=v289078704&mode=play]



RE: [RELEASE] Twitch.tv - Not Sure - 2018-07-28

(2018-07-28, 06:45)dale77 Wrote: trying to play streams today using Kodi 17.6 Windows I get a 404 error. Everything has been working fine until today.

Get the update from the Github link posted yesterday.


RE: [RELEASE] Twitch.tv - dale77 - 2018-07-29

(2018-07-28, 15:33)Not Sure Wrote: Get the update from the Github link posted yesterday. 

Thanks, that worked.


RE: [RELEASE] Twitch.tv - r33p0phph - 2018-08-06

Hi,
First thanks for the app on kodi.
This is a problem with the app for kodi/Raspberry PI, today the app started having problems with the feed from twitch.
After 1-3 min stream it buffering and ends by closing app.
I tested internet, Raspberry PI, cables and i reinstalled the app.
I have no problem with twitch on pc/mac/android in the house on same internet.
And i would know if the internet is bad, has the kid is playing Fortnite and has not had any problems.
I also could stream a movie with not problems also on the Raspberry PI.
Raspberry PI is a 3 b with libreelec newest version.
Version 2.2.4

Do any have this problem also?


RE: [RELEASE] Twitch.tv - r33p0phph - 2018-08-09

So not a single person has any problems with the addon..


RE: [RELEASE] Twitch.tv - blindhai - 2018-08-25

(2018-08-09, 21:51)r33p0phph Wrote: So not a single person has any problems with the addon..
 I do, but not the same.

I have an A95X Pro with an Amlogic S905W and i can only get 720p in Twitch and Youtube Addon with inputstream. What i can do is a workaround, i can select "manual stream select" in the options of inputstream and then i can choose 1080p. When i choose this as "default quality" it is fine as long the selected stream has the same or a similar resolution with a similar bitrate. If the bitrate is too different, then i have to manual select another 1080p stream. The same thing happens when there is no 1080p stream available and only 720p.

If i choose "autoselect" in both inputstream and Youtube/Twitch Addon then i always(!) can get only 720p.

I think, i have to give up. I have done the installation like 100% perfect and used CoreElec and(!) LibreElec but the result stays the same. It seems nobody can really help. Maybe it is the box i have.


RE: [RELEASE] Twitch.tv - anxdpanic - 2018-09-01

@blindhai Double check InputStream Adaptive Settings -> Max. resolution general decoder is set to Max, the video resolution may be 1920x1088 so if that setting is set to 1080p it will play at a lower resolution.

I've posted a 2.3.0~beta1 zip if anyone is interested in testing, adds python 3 compatibility and the add-on entry point has been refactored to improve directory navigation speed.


RE: [RELEASE] Twitch.tv - blindhai - 2018-09-02

(2018-09-01, 18:39)anxdpanic Wrote: @blindhai Double check InputStream Adaptive Settings -> Max. resolution general decoder is set to Max, the video resolution may be 1920x1088 so if that setting is set to 1080p it will play at a lower resolution.

I've posted a 2.3.0~beta1 zip if anyone is interested in testing, adds python 3 compatibility and the add-on entry point has been refactored to improve directory navigation speed.
 Thank you. Smile 

I have played with the settings by myself, because i was curious. Configuring the settings to Max and setting the min. Bitrate to 10.000.000 did the trick for me. Only setting it to max didnt work for me. Only after i set the bitrate to min. 10.000.000 made it work.

There really need to be a post where everyone can look the actual best configuration up in here, because the old ones dont work reliable or at all. It shouldnt be like a secret or so.


RE: [RELEASE] Twitch.tv - Juppstein - 2018-09-11

@anxdpanic

With this update 2.3.0beta1 I am not anymore able to go to my followed games list, it will throw an error of not being able to get the directory

https://paste.kodi.tv/votoyuyude

Addendum: Browsing games (the non-followed version) also throws the same error


RE: [RELEASE] Twitch.tv - PnoT - 2018-09-12

(2018-09-02, 00:03)blindhai Wrote:
(2018-09-01, 18:39)anxdpanic Wrote: @blindhai Double check InputStream Adaptive Settings -> Max. resolution general decoder is set to Max, the video resolution may be 1920x1088 so if that setting is set to 1080p it will play at a lower resolution.

I've posted a 2.3.0~beta1 zip if anyone is interested in testing, adds python 3 compatibility and the add-on entry point has been refactored to improve directory navigation speed.
 Thank you. Smile 

I have played with the settings by myself, because i was curious. Configuring the settings to Max and setting the min. Bitrate to 10.000.000 did the trick for me. Only setting it to max didnt work for me. Only after i set the bitrate to min. 10.000.000 made it work.

There really need to be a post where everyone can look the actual best configuration up in here, because the old ones dont work reliable or at all. It shouldnt be like a secret or so. 
 I agree, a FAQ or general setup guide for what works best currently would be nice instead of having to try 2 or 3 different combinations of the plugin / adaptive.

I'm also reporting back from 3 or 4 pages ago that my sudden issues with playing "source" and having to switch to "adaptive" was due to my ISP and some weird packet shaping when they upgraded everyone to 1GB down in the neighborhood.  It took them about 2 months to track the problem down and fix it but since then I'm back to playing "source".


RE: [RELEASE] Twitch.tv - anxdpanic - 2018-09-12

@Juppstein Thanks for the report and log, can you confirm this is resolved by https://github.com/MrSprigster/Twitch-on-Kodi/releases/tag/2.3.2


RE: [RELEASE] Twitch.tv - Juppstein - 2018-09-12

(2018-09-12, 15:36)anxdpanic Wrote: @Juppstein Thanks for the report and log, can you confirm this is resolved by https://github.com/MrSprigster/Twitch-on-Kodi/releases/tag/6.3.1

Confirmed Smile Problem solved.


This forum uses Lukasz Tkacz MyBB addons.