Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-02-26

(2013-02-26, 15:18)xbs08 Wrote: Does the swap make a difference in perfomance on a 256 RPi?
With a low swappiness value, it should have almost no effect when memory isn't full.
When memory becomes full you get a performance reduction rather than a crash.

(2013-02-26, 15:06)miappa Wrote: To answer your questions:
tvservice -s: state 0x12001a [HDMI CEA (32) 3D SbS RGB lim 16:9], 1920x1080 @ 24Hz, progressive
OSD is not doubled
Manually does not work. TV is in 3D mode, but SBS does not work. I hope this makes sense... :S

It doesn't really make sense. When TV is put into SBS mode it should combine the left and right images into a single image that should be the full width of the screen.
Are you seeing the video as two seperate images on left and right side of screen? That shouldn't be possible.
How does it look if you manually disable 3D mode?

Can you take a photo of screen when playing a SBS movie with OSD visible?


RE: OpenELEC Testbuilds for RaspberryPi - miappa - 2013-02-26

Well, it looks the same in 3D mode and in 2D except that it looks like the TV put´s it in 2D-to-3D mode (Panasonic feature).
But SBS does not work and it is not possible to do it manually.
OSD sort of works as it is not scrambled.

If I remove tags I can manually out it in correct mode, but with scrambled OSD of course.

https://www.dropbox.com/s/u28rb0kolcys3xp/image-2D.jpeg
https://www.dropbox.com/s/qg3epqx8h6s794m/image-3D.jpeg

Oh, just figured: OSD is not doubled even in 2D-mode...


RE: OpenELEC Testbuilds for RaspberryPi - doveman2 - 2013-02-26

(2013-02-26, 15:21)popcornmix Wrote:
(2013-02-26, 15:18)xbs08 Wrote: Does the swap make a difference in perfomance on a 256 RPi?
With a low swappiness value, it should have almost no effect when memory isn't full.
When memory becomes full you get a performance reduction rather than a crash.

I'm using a 512 RPI with gpu_mem=128. I don't know if that ensures the memory won't become full but perhaps it minimises the chance enough to not need the swapfile enabled?

Otherwise, if it's just as a backup in case and it's advised to keep it available, is there a way to ensure it's never written to unless absolutely needed (the swappiness value you refer to)?


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-02-26

(2013-02-26, 15:44)miappa Wrote: Well, it looks the same in 3D mode and in 2D except that it looks like the TV put´s it in 2D-to-3D mode (Panasonic feature).
But SBS does not work and it is not possible to do it manually.
OSD sort of works as it is not scrambled.

If I remove tags I can manually out it in correct mode, but with scrambled OSD of course.

https://www.dropbox.com/s/u28rb0kolcys3xp/image-2D.jpeg
https://www.dropbox.com/s/qg3epqx8h6s794m/image-3D.jpeg

Oh, just figured: OSD is not doubled even in 2D-mode...

I get OSD doubled. What versions are you running? Can you find an older version that does work? Can you try rbej's last version?
Does renaming guisetting.xml and restarting affect it?


RE: OpenELEC Testbuilds for RaspberryPi - miappa - 2013-02-26

I cannot reproduce it in new installs of OE!
Tested official, latest nightly and latest rbey´s and all works.
I will test some more things and perhaps start a new thread, but I am starting to think that I have done something myself... try to backtrack what it might be.

Edit: I have tried to delete guisettings.xml but no go...

Edit2: Figured it out. Forgot that I tested GUI in 1080p the other day and it broke 3D tagging for me. Back to 720 and now it´s working again. Sorry... :S


RE: OpenELEC Testbuilds for RaspberryPi - doveman2 - 2013-02-26

Having a weird bug with the network. On DHCP it works but if I set it manually, it show Internet: Not Connected or Busy (MAC address changes from the address to Busy as well) and the DNS server as 127.0.0.1, despite setting it to 8.8.8.8. I can still FTP/SSH in but obviously have no internet from the RPi.

EDIT: Dammit, how are we supposed to put it back to DHCP? I tried setting the IP to 0.0.0.0 and now XBMC just gets stuck in a reboot loop and I can't access it externally anymore, so I'll have to reimage the SD I guess.

EDIT2: I managed to access the SD in my LinuxMint Virtualbox and edited the OpenElec settings.xml to change the IP address line from "0.0.0.0" to "" but it's still stuck in the endless reboot loop.


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2013-02-26

(2013-02-26, 14:33)doveman2 Wrote: How do I disable the swapfile in this? I really don't want to have it constantly writing to my USB and wearing it out.

You may want to add your support to this issue which includes a request for the ability to disable swap for those that don't want it (or can't use it, as is the case with those booting from NFS/SMB, and who don't want to see the warning/error message at boot).

As a short term measure, you could create a /storage/.config/autostart.sh file that includes the "swapoff" command so that swap is disabled as soon as XBMC starts. Although swap is unlikely to be writing to your USB all the time, it will only use it when (if) you run out of memory.


RE: OpenELEC Testbuilds for RaspberryPi - doveman2 - 2013-02-26

Thanks I will, as I want to test NFSBoot anyway but I'm a bit confused as rbej's post said

Quote:Rbej Frodo Brench

http://www.mediafire.com/?10456ccz13ard

- Xbmc 12.0.3 Frodo (many new fixes) (25.02.2013)
- Rpi kernel 3.6.y (25.02.2013)
- Rpi firmware (25.02.2013)
- Pvr Addon (16.02.2013) with PVR TvHeadend 1.6.18 and MythTv 1.6.9 (21.02.2013)
- Xvdr Addon (25.02.2013)
- Gpu memory set to 100mb on default for Rpi 256mb (fix kernal killing Xbmc task on Rpi 256mb board) and Gpu memory set to 256mb on default for Rpi 512mb.

Only in my build:

- enable 128mb swap file

which suggests the swap file isn't normally enabled in OE.


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2013-02-26

(2013-02-26, 17:24)doveman2 Wrote: Having a weird bug with the network. On DHCP it works but if I set it manually, it show Internet: Not Connected or Busy (MAC address changes from the address to Busy as well) and the DNS server as 127.0.0.1, despite setting it to 8.8.8.8. I can still FTP/SSH in but obviously have no internet from the RPi.

EDIT: Dammit, how are we supposed to put it back to DHCP? I tried setting the IP to 0.0.0.0 and now XBMC just gets stuck in a reboot loop and I can't access it externally anymore, so I'll have to reimage the SD I guess.

Try adding "textmode" to the end of your kernel parameters in cmdline.txt - this should stop XBMC from loading and give you console access on the Pi so that you can edit your /var/config/settings.xml (connect a keyboard!) - for dhcp you need the NET* properties (at minimum, NET_IPADDRESS should be blank or 0.0.0.0):

Code:
NET2_DNS1=""
NET2_DNS2=""
NET2_DNS3=""
NET2_GATEWAY=""
NET2_HIDDEN="false"
NET2_IFACE="eth1"
NET2_IPADDRESS=""
NET2_NETWORK="NONE"
NET2_PASSPHRASE=""
NET2_PREFIXLEN="24"
NET2_SECURITY="NONE"
NET2_SSID=""
NET_DNS1=""
NET_DNS2=""
NET_DNS3=""
NET_GATEWAY=""
NET_HIDDEN="false"
NET_HOSTNAME="openelec"
NET_IFACE="eth0"
NET_IPADDRESS=""
NET_NETWORK="LAN"
NET_PASSPHRASE=""
NET_PREFIXLEN="24"
NET_SECURITY="NONE"
NET_SSID=""


Adding "ip=dhcp textmode" to cmdline.txt may allow you ssh access without starting XBMC.

(2013-02-26, 18:04)doveman2 Wrote: which suggests the swap file isn't normally enabled in OE.

Swap was enabled briefly in OE, which is when I ran across it hence the issue I raised, then for some reason it was disabled again (and remains disabled). Neither activity has a corresponding commit so perhaps it was activated by mistake.


RE: OpenELEC Testbuilds for RaspberryPi - doveman2 - 2013-02-26

Thanks. I'd already set NET_IPADDRESS to "0.0.0.0" (after which it got stuck in the reboot loop) and "" and blanking the other values hasn't helped with the reboot loop so I guess it's something else that's the problem, although I don't know what.


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2013-02-26

Did adding textmode and/or ip=dhcp get you anywhere? Your network is brought up using values from settings.xml so it might be worth deleting settings.xml before trashing your installation.


RE: OpenELEC Testbuilds for RaspberryPi - xbs08 - 2013-02-26

How can one check if swap is enabled in Openelec?


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-02-26

(2013-02-26, 19:38)xbs08 Wrote: How can one check if swap is enabled in Openelec?
Code:
cat /proc/meminfo  |grep Swap
SwapCached:            0 kB
SwapTotal:             0 kB
SwapFree:              0 kB
tells me swap is disabled.


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2013-02-26

Check to see if you have /etc/init.d/32_swapfile - if not, your build doesn't support swap.

To see if swap is actually working, run "free" and see if you have non-zero amounts for swap (last line).


RE: OpenELEC Testbuilds for RaspberryPi - doveman2 - 2013-02-26

(2013-02-26, 19:11)MilhouseVH Wrote: Did adding textmode and/or ip=dhcp get you anywhere? Your network is brought up using values from settings.xml so it might be worth deleting settings.xml before trashing your installation.

Yes thanks, I was able to WinSCP in and edit settings.xml. I'll try deleting it. Do you think it's likely that this could cause XBMC to get stuck in a restart loop though?


This forum uses Lukasz Tkacz MyBB addons.