Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - SSC_Jarod - 2013-07-11

Loopy123, thx for the Info but i make the update always by copying the Files to the update Folder, the install script doesn't work for me at all. But in 1 out 5 if i reboot, i got the error and i must do a clean install or write a prevouis image back to card and try again... And sometimes it works then... Sad ... So i can't find a explanation, cause i do same update procedure everytime...


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-07-11

Updated Gotham Branch

- updated Xbmc 13 Gotham

- DTS decode speed up for Rpi

http://netlir.dk/rbej/builds/

http://lysin.me/rbej


RE: OpenELEC Testbuilds for RaspberryPi - wezoly - 2013-07-11

@rbej,
Many thanks for your continued test builds. Also many thanks to popcornmix for his hard work in fixing/optimising xbmc for the rpi Smile

Is there any chance you could compile the latest service addons for your openelec (not just the xbmc PVR addons)?
Getting discontinuity problems with HD channels from a USB DVB-S2 tuner running TVHeadend 3.4. After testing raspbmc and using 3.4 I got the same result. After upgrading to 3.5 GIT the discontinuity problems are resolved. Originally thought the problem was with USB bandwidth / FIQ but it doesn't seem to be the case.
So just wondering if you could compile the latest git tvheadend server addon for the rpi?

Also the VDR server addon seems out of date - receive an "unsupported protocol version" error with VDR when running everything on your build. Seems the latest VDR pvr xbmc addons are newer than the included server version (all-in-one solution)

Thanks again
Wez


RE: OpenELEC Testbuilds for RaspberryPi - Koloss - 2013-07-11

Tomorrow DTS-HD Added? Big Grin

in the evening I test the new build
Fast Forward, etc.

I am glad.Big Grin


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-07-11

(2013-07-11, 13:54)wezoly Wrote: @rbej,
Many thanks for your continued test builds. Also many thanks to popcornmix for his hard work in fixing/optimising xbmc for the rpi Smile

Is there any chance you could compile the latest service addons for your openelec (not just the xbmc PVR addons)?
Getting discontinuity problems with HD channels from a USB DVB-S2 tuner running TVHeadend 3.4. After testing raspbmc and using 3.4 I got the same result. After upgrading to 3.5 GIT the discontinuity problems are resolved. Originally thought the problem was with USB bandwidth / FIQ but it doesn't seem to be the case.
So just wondering if you could compile the latest git tvheadend server addon for the rpi?

Also the VDR server addon seems out of date - receive an "unsupported protocol version" error with VDR when running everything on your build. Seems the latest VDR pvr xbmc addons are newer than the included server version (all-in-one solution)

Thanks again
Wez

Im realy i dont know how compile OpenElec build with tvheadend server. Sorry.


RE: OpenELEC Testbuilds for RaspberryPi - wezoly - 2013-07-11

No problem, thanks for the quick response anyway. I shall setup a build environment here and compile/test. Will let you know how I get on as if it works then I will supply the addon as a zip which others can download too. I'm aiming for a RPI all in one single DVB-S2 sat receiver, especially now that the TVHeadend client works so beautifully with the latest fixes from popcornmix.

Thanks


RE: OpenELEC Testbuilds for RaspberryPi - lysin - 2013-07-11

On this last build, I can't reboot the RasPi trough the menu. I need to ssh into the device and manually issue the reboot command. Anyone else?


RE: OpenELEC Testbuilds for RaspberryPi - delinend - 2013-07-11

(2013-07-11, 15:37)lysin Wrote: On this last build, I can't reboot the RasPi trough the menu. I need to ssh into the device and manually issue the reboot command. Anyone else?

Yes... Same problem here, on the last 2-3 builds.
Reboot and Shutdown buttoms in XBMC, not allways works. Huh It must be a Gotham problem.


RE: OpenELEC Testbuilds for RaspberryPi - Trickname - 2013-07-11

A/Vsync probs seems to be gone here Smile


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-07-11

(2013-07-11, 17:57)Trickname Wrote: A/Vsync probs seems to be gone here Smile

It's nice when you accidentally fix things.

I removed some code I didn't like the look of (although thought was benign) when adding ff/rew support.
After your comment I've had a closer look, and yes it looks like the cause of the A/V sync bug.

Excellent.


RE: OpenELEC Testbuilds for RaspberryPi - Trickname - 2013-07-11

good job !

will do further reports.


RE: OpenELEC Testbuilds for RaspberryPi - Koloss - 2013-07-11

I have no problem with the last gotham build update procedure!

popcornmix: you are a very good developer!!!

Fast Forward and Fast Rewind, its PERFECT Big Grin.

UNBELIEVABLE !!!

You bring out the best of the Pi


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-07-11

Fast Forward works great but Fast Rewind have "deja vu" effect.

PS. Confirm. Popcornmix is realy great developer Wink


Re: RE: OpenELEC Testbuilds for RaspberryPi - superdesi - 2013-07-12

(2013-07-11, 15:37)lysin Wrote: On this last build, I can't reboot the RasPi trough the menu. I need to ssh into the device and manually issue the reboot command. Anyone else?

Yes.....I can confirm the same.


RE: OpenELEC Testbuilds for RaspberryPi - hpbaxxter - 2013-07-12

I notice a clear regression in video playback performance compared to my last test of hight quality/bitrate video streams (blue ray untouched). While in rbej's build of June 17 I could watch Skyfall with dts-hd audio layer without interrupts (I know, it only extracts a dts audio layer, but that costs processing time), rbej's build of July 11 shows regular interruptions even with dts audio layer. Heat with dolby digital is also unwatchable. I can't say exactly which build introduced the regressions. The tests where performed with same oc settings (arm/core/sdram: 900/333/500), only change is avoid_pwm_pll enabled this time, but I assume that's not the reason.

I also had problems with shotdown/reboot from within gui and sd card corruption in last three builds during update process (files where put on Rpi via smb) which I didn't have at least the last six months.

However, I really appreciate the new fast forward and rewind feature, so thanks a lot! Wink


This forum uses Lukasz Tkacz MyBB addons.