Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - Pierre1985 - 2013-07-14

Hi rbej,

i still have the problem that i can not buffer with this new version and i don't know why. is this maybe limited by some kind of protocol, i use nfs to get access to has.
Should i use another protocol?

Or is there a way to find out why its not buffering.

Cheers


RE: OpenELEC Testbuilds for RaspberryPi - Pierre1985 - 2013-07-14

So now i found out that gotham is buffering and frodo not.

anyhow i will use gotham and anything is fine.

Thanks for the help and rbej good job.

cheers.


RE: OpenELEC Testbuilds for RaspberryPi - Johnkg - 2013-07-14

(2013-07-13, 23:49)Trickname Wrote: but found a little:
system totaly crash (and doesn´t reboot good) if i try view pictures and some text is shown in startup. /var/settings somethig

Same problem here with Gotham build

Restarts xbmc after selecting Pictures

debug log: http://xbmclogs.com/show.php?id=36832


RE: OpenELEC Testbuilds for RaspberryPi - nuttypro69 - 2013-07-15

Yes Gotham build the latest restart when I try to install addon but not a complete restart.


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-07-15

(2013-07-14, 15:30)Johnkg Wrote: Same problem here with Gotham build

Restarts xbmc after selecting Pictures

debug log: http://xbmclogs.com/show.php?id=36832

There are some complaints about invalid Exif headers:
Code:
13:57:00 T:2968245344   DEBUG: CNFSFile::Open - opened Pictures/RACHEL!!!!!!!.jpg
13:57:00 T:2968245344    INFO:   msg: ExifParse: incorrect Exif header
13:57:00 T:2968245344   DEBUG: CNFSFile::Close closing file Pictures/RACHEL!!!!!!!.jpg
13:57:00 T:2968245344   DEBUG: CNFSFile::Open - opened Pictures/opopopo.bmp
13:57:00 T:2968245344   DEBUG: CNFSFile::Close closing file Pictures/opopopo.bmp
13:57:00 T:2968245344    INFO:   msg: JpgParse: Not a JPEG file nfs://192.168.1.2/Pictures/opopopo.bmp
13:57:00 T:2968245344   DEBUG: CNFSFile::Open - opened Pictures/malfoy.jpg
13:57:00 T:2968245344    INFO:   msg: ExifParse: incorrect Exif header
13:57:00 T:2968245344   DEBUG: CNFSFile::Close closing file Pictures/malfoy.jpg
13:57:00 T:2968245344   DEBUG: CNFSFile::Open - opened Pictures/IMAG1210.jpg
13:57:00 T:2968245344   DEBUG: CNFSFile::Close closing file Pictures/IMAG1210.jpg
13:57:00 T:2968245344   DEBUG: CNFSFile::Open - opened Pictures/IMAG1207.jpg
13:57:00 T:2968245344   DEBUG: CNFSFile::Close closing file Pictures/IMAG1207.jpg
13:57:00 T:2968245344   DEBUG: CNFSFile::Open - opened Pictures/francis_evil_masked.jpg
13:57:00 T:2968245344    INFO:   msg: ExifParse: incorrect Exif header
13:57:00 T:2968245344   DEBUG: CNFSFile::Close closing file Pictures/francis_evil_masked.jpg

can you try moving all pictures out of nfs://192.168.1.2/Pictures, and adding then back in to see if a particular picture is provoking the crash?
If so, then posting a link to a sample picture that crashes may be helpful.


RE: OpenELEC Testbuilds for RaspberryPi - delinend - 2013-07-15

Hmm.. I see/hear some libsync problems, on the OpenELEC-RPi.arm-Rbej-Version-Gotham-Branch(13.07.2013) build, when I playback DVD/ISO/MPEG-2 movies.

I have to speed-up audio (forward delay) for about +0.375sec. before audio (not tested DTS) and video is in sync.


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-07-15

(2013-07-15, 20:35)delinend Wrote: Hmm.. I see/hear some libsync problems, on the OpenELEC-RPi.arm-Rbej-Version-Gotham-Branch(13.07.2013) build, when I playback DVD/ISO/MPEG-2 movies.

I have to speed-up audio (forward delay) for about +0.375sec. before audio (not tested DTS) and video is in sync.

Yes, I have seen this, but don't have a fix yet. Do you have a sample file that is out of sync in latest build, but is good in an earlier build (e.g. Frodo?).

[edit]
I brought in a file that had been out of sync at weekend and have reverted to Frodo xbmc, and it is still out of sync.
I've now gone through GPU history and found the commit that caused the out of sync problem.

So, hopefully will have a fix soon.


RE: OpenELEC Testbuilds for RaspberryPi - Trickname - 2013-07-15

lipsync is good here streaming Mp2 TS from Tv-card

to pictures problem:
i tryed to open jpeg local from the pi same error


RE: OpenELEC Testbuilds for RaspberryPi - hkramski - 2013-07-15

Hi rbej,

after upgrading your 20130428113320-r14146 build to the most recent one, I'm unable use my bluetooth keyboard (on a non-CEC TV/DVD combo).

Looks like the BT input plugin is disabled on purpose to support ps3 remote etc. (http://wiki.openelec.tv/index.php?title=Bluez-tools_how-to).

Is there an easy way to re-enable a BT keyboard?

TIA
Heinz


RE: OpenELEC Testbuilds for RaspberryPi - pootler - 2013-07-16

hello

I have had a lighthearted challenge on a number of rpi forums asking if anyone yet has been able to watch live tv on the Pi ( both back and frontend on Pi) for more than an hour without a/v sync issues.

Had nearly 300 views on some of these forums but NO REPLIES!!

I have tried some of the latest rbej builds - one recently was a bit better but wrong aspect, and the latest seems to have a constant 200ms out of sync audio.

BUT this does seem constant.

Anyone had any success better than this without having to resort to audio offset, which then messes up sync for my movie collection Smile

PLease remember - I have both front and backend on Pi ( Tvheadend)

Look forward to any replies!

Pootler


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-07-16

(2013-07-15, 20:35)delinend Wrote: Hmm.. I see/hear some libsync problems, on the OpenELEC-RPi.arm-Rbej-Version-Gotham-Branch(13.07.2013) build, when I playback DVD/ISO/MPEG-2 movies.

I have to speed-up audio (forward delay) for about +0.375sec. before audio (not tested DTS) and video is in sync.

Updated firmware with audio sync fix here:
https://github.com/raspberrypi/firmware/commit/9e9acf897857a78a0787c0ef4fdd87f883ed980a
(you can download start.elf and fixup.dat and update the ones on sdcard).


RE: OpenELEC Testbuilds for RaspberryPi - delinend - 2013-07-16

(2013-07-16, 02:03)popcornmix Wrote:
(2013-07-15, 20:35)delinend Wrote: Hmm.. I see/hear some libsync problems, on the OpenELEC-RPi.arm-Rbej-Version-Gotham-Branch(13.07.2013) build, when I playback DVD/ISO/MPEG-2 movies.

I have to speed-up audio (forward delay) for about +0.375sec. before audio (not tested DTS) and video is in sync.

Updated firmware with audio sync fix here:
https://github.com/raspberrypi/firmware/commit/9e9acf897857a78a0787c0ef4fdd87f883ed980a
(you can download start.elf and fixup.dat and update the ones on sdcard).

Thanks Popcornmix. But this did not Work for me.Rolleyes

I allso se the problem on OpenELEC Frodo official 3.0.6

I only see the problem, on my large LG television with HDMI, and not on my PC monitor Dell allso with HDMI (same Raspberry box).

I always set "Deinterlace video" to "Auto" and Default to all movies, and if I set it to "OFF", then there is no libsync problems at all Huh

The problem is not on all movies. So maybe it have something to do, with audio bitrate ?

Btw. my "Adjust display refresh rate to match video" is set to "Always".

PS: I'll make a video sample to you.

Best regards


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-07-16

Updated Frodo Branch

- updated firmware and kernel (3.10.1)

- updated FFmpeg (1.2.1)

- new clock for OmxPlayer (adopted from Gotham). THX Popcornmix!!.

http://netlir.dk/rbej/builds/

http://lysin.me/rbej


RE: OpenELEC Testbuilds for RaspberryPi - Silo100 - 2013-07-16

Hi,

Yet again, wanted to say thanks for the build.

But as others have asked before, is it possible to get access to your changes?

Some of us would like to help OpenELEC and XBMC along, but without knowing what you've changed, it's kind of difficult.

Just thinking of the Open Source Principles...

Cheers Anyway


RE: OpenELEC Testbuilds for RaspberryPi - Trickname - 2013-07-16

(2013-07-16, 14:01)rbej Wrote: Updated Frodo Branch

- updated firmware and kernel (3.10.1)

- updated FFmpeg (1.2.1)

- new clock for OmxPlayer (adopted from Gotham). THX Popcornmix!!.


- Timeserver NTP problem is back again.
- Picture bug - but i found out open pictures from file explorer is working.

+ Fast channelswitching (liveTV) - fast GUI - Libsync is a bit ahead but works fine after korrekturs. +175


This forum uses Lukasz Tkacz MyBB addons.