Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2012-10-20

(2012-10-20, 19:53)tuborg Wrote:
(2012-10-20, 04:04)rbej Wrote: Anyone can confirm lack skin settings ??. Bulid r12196.

The skin settings can now be found under:
Settings > Appearance > Skin > Settings

rather than Settings > Skin

So they can - thanks for that.


RE: OpenELEC Testbuilds for RaspberryPi - sraue - 2012-10-20

Hi,

OpenELEC Development build (r12220):
http://sources.openelec.tv/tmp/image/openelec-rpi/OpenELEC-RPi.arm-devel-20121020212708-r12220.tar.bz2

to update a older build without reinstalling see:
http://wiki.openelec.tv/index.php?title=Updating_OpenELEC#Manually_Updating_OpenELEC

Please also read http://sources.openelec.tv/tmp/image/openelec-rpi/READ_FIRST.txt for general notes about our development builds.

After releasing our OpenELEC-2.0 build based on XBMC Eden the development for OpenELEC-3.0 has started which will officiall support RaspberryPi builds.
We have merged now our work on OpenELEC-3.0 in our master branch because of this and the releasing there was not much updates the last time.

This are the changes:
  • updated XBMC to the last and greatest XBMC master checkout, including the latest changes from Gimli, many thanks! :-)
  • updated firmware, kernel patches and BCM librarys *
  • various other improvenments, fixes and package updates.

With this build we have update the latest bootloaderfiles to support 512MB RPi's (see: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=20255&start=25#p198079 and http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=20255&start=25#p198247. This also also includes the following changes:
  • on creating a fresh SD-Card a default config.txt will be installed which allocates 128MB GPU memory on 256MB and 512MB Raspberry's
  • on updating there will be checked if a config.txt exist, if not the default config.txt will be installed
  • if a config.txt with a uncommented variable 'gpu_mem' variable already exist nothing will be changed
  • if a config.txt without a 'gpu_mem' variable exist our default config.txt will be installed and will be enhanced with your old config.txt. your old config.txt will be backed up to config.txt.bk.

Please backup your old config.txt in the case you dont find your license codes anymore before you install this update

After the update please check your /flash/config.txt byself and report back any issues. Please report back if this update work like excepted on 256MB and 512MB Raspberry's

because XBMC now supports officially RPi and PVR please use XBMC's Trac (http://trac.xbmc.org/) to report XBMC bugs and OpenELEC's github issue tracker (https://github.com/OpenELEC/OpenELEC.tv/issues) for OS related issues and feature/driver requests.


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2012-10-20

Thanks Stefan. r12220 is working fine on a 512MB Pi (though still zooming 1080p, and thumbnails are square etc.)

Regarding the GPU memory, is XBMC on Pi going to be able to make use of the additional RAM on 512MB models, or will GPU be fixed at 128MB and have to employ the same GUI upscaling workaround as the 256MB model?


RE: OpenELEC Testbuilds for RaspberryPi - sraue - 2012-10-20

(2012-10-20, 22:10)MilhouseVH Wrote: Thanks Stefan. r12220 is working fine on a 512MB Pi (still zooming 1080p, and thumbnails are square etc.)

Regarding the GPU memory, is XBMC on Pi going to be able to make use of the additional RAM on 512MB models, or will GPU be fixed at 128MB and have to employ the same GUI upscaling workaround as the 256MB model?

i personally *think* *actually* xbmc is not prepared to benefit from the additiona GPU memory (if setup) thats why i have setup this for both models to 128MB. feel free to change the config.txt and test if you see improvenments - i dont have a 512MB model here to test. actually its important to ship a usefull and stable default config working on both models. its up to the user to try different splits actually or setup overclocking.

your changed config.txt will not be touched on updates, *except* the gpu_mem value is missing, then the default config.txt will be installed and enhanced with your old config - thats at least how it was planned to work :-)

so you can report back on both or at least the 512MB model the memory config works? (128MB GPU, rest system?)



RE: OpenELEC Testbuilds for RaspberryPi - sraue - 2012-10-20

(2012-10-20, 22:10)MilhouseVH Wrote: Thanks Stefan. r12220 is working fine on a 512MB Pi (though still zooming 1080p, and thumbnails are square etc.)

afaik we still use DDS fanarts by default, can you disable this and check if it makes any difference? (loading time etc...)?


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2012-10-20

No obvious difference, unfortunately - either in terms of load time (I'm running force_turbo=1 @ 1000/500/600) or in terms of appearance.

I added "<useddsfanart>false</useddsfanart>" to advancedsettings.xml, deleted Database/Textures13.db and Thumbnails, but the boxart is still out of proportion (banners on TV Shows are also the wrong size/shape).


RE: OpenELEC Testbuilds for RaspberryPi - MikeBuzz - 2012-10-20

Luckily i have both the 256 and 512 RPi, having tested the latest r12220 version on both i have to say the the difference between the 2 is so very different, on the 256 i am unable to watch toy story 1080 with out it pausing every few seconds, so i swapped the sd card in to the 512, what a difference, toy story is now watchable, no pausing, menu speed is very good, will be testing the PVR functionality once i have my new MPG2 keys for the 512

also when swapping the sd card between the 2 different RPi's the GPU always stays at 128mb, with the rest given to system

i am now gonna be ordering another 2 512 versions as i now see that they are a viable alternative to the standard HTPC when using OpenELEC

congrats to Stephen and the rest of the team behind OE


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2012-10-20

(2012-10-20, 22:18)sraue Wrote: so you can report back on both or at least the 512MB model the memory config works? (128MB GPU, rest system?)

I've tried gpu_mem_512=256, and this left the system with ~256MB RAM so presumably 256MB was made available to the GPU. However, I noticed no obvious difference - the system worked just as it did with 128MB GPU memory, no better and no worse (still zooming/upscaling the GUI etc.).

So it doesn't appear that XBMC is taking advantage of the additional GPU RAM.


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2012-10-20

Regarding the squashed thumbnails, I've looked at jpg's in the Thumbnails folder, and XBMC is resizing 1000x1500 (wide x high) thumbnails to 1008x720 (wide x high)... almost as if the resize algorithm has the width and height transposed...


RE: OpenELEC Testbuilds for RaspberryPi - charlie0440 - 2012-10-21

(2012-10-20, 16:13)charlie0440 Wrote: can anyone confirm if they have a pi v512 working with openelec? I get the following error on the splash screen

Code:
***Error in prepare_sysroot: mount_common: Could not mount /Flash/SYSTEM ***

i have checked the md5s. this is occurring for me on all versions i have tried.

Pleased to say this has now gone and I have a working openelec thanks to the latest dev version Smile



RE: OpenELEC Testbuilds for RaspberryPi - gimli - 2012-10-21

(2012-10-18, 08:32)rbej Wrote: EVERYTHING is scaled to 720p, not only GUI.

Nope. It is rendered in 1080p. There is a bug in the calculation and displaying the values. The rendering of the video IS IN 1080p.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2012-10-21

Thanks for explanation.


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2012-10-21

(2012-10-21, 02:10)gimli Wrote:
(2012-10-18, 08:32)rbej Wrote: EVERYTHING is scaled to 720p, not only GUI.

Nope. It is rendered in 1080p. There is a bug in the calculation and displaying the values. The rendering of the video IS IN 1080p.

Is there any way to make this optional, perhaps with an advancedsetting, particularly now that we have 512MB Pis and could devote more RAM to the GPU? I'm guessing we won't be upscaling the XBMC GUI on x86 boxes, so there must be a switch somewhere to enable or disable this GUI scaling feature...


RE: OpenELEC Testbuilds for RaspberryPi - caravela - 2012-10-21

my Edimax ew-7811un wireless nano adapter (RTL8188CUS) stopped working in r2220. it works again reverting back to 12196 .


RE: OpenELEC Testbuilds for RaspberryPi - jesus225 - 2012-10-21

Hello,

I've noticed that after updating to 12020 my zd1211-based wifi dongle no longer works.

In /var/log/messages I can see the following lines regarding wifi:

Jan 1 00:00:08 openelec daemon.info connmand[981]: wlan0 {create} index 3 type 1 <ETHER>
Jan 1 00:00:08 openelec daemon.info connmand[981]: wlan0 {update} flags 4098 <DOWN>
Jan 1 00:00:08 openelec daemon.info connmand[981]: wlan0 {newlink} index 3 address MAC mtu 1500
Jan 1 00:00:08 openelec daemon.info connmand[981]: wlan0 {newlink} index 3 operstate 2 <DOWN>
Jan 1 00:00:08 openelec daemon.info connmand[981]: Adding interface wlan0 [ wifi ]

and:

Jan 1 00:00:06 openelec user.info kernel: [ 6.873034] zd1211rw 1-1.2.2:1.0: phy0
Jan 1 00:00:06 openelec user.info kernel: [ 6.873393] usbcore: registered new interface driver zd1211rw

On running dmesg:

[ 3.149083] usb 1-1.2.2: new high-speed USB device number 6 using dwc_otg
[ 3.250374] usb 1-1.2.2: New USB device found, idVendor=0ace, idProduct=1211
[ 3.250406] usb 1-1.2.2: New USB device strings: Mfr=16, Product=32, SerialNumber=0
[ 3.250424] usb 1-1.2.2: Product: USB2.0 WLAN
[ 3.250437] usb 1-1.2.2: Manufacturer: ZyDAS

This wifi dongle was working out-of-the-box in release number 12196 but it stopped inmediatly after upgrading to 12220.

Do you think this issue could be caused due to the xbmc upgrade or must be an Openelec-related issue?

Best regards.


This forum uses Lukasz Tkacz MyBB addons.