Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - Wanderlei - 2012-12-07

delete.


RE: OpenELEC Testbuilds for RaspberryPi - gimli - 2012-12-07

(2012-12-07, 19:05)rbej Wrote: This fixes working perfect. No more leak memory and crashes when watching online movies. Smearing color is almost fixed. Very quick response after forward and rewind movie.

Thx for the test response.


RE: OpenELEC Testbuilds for RaspberryPi - lowridin_guy - 2012-12-07

Just updated using Rbej's build and so far so good. Will test more tonight. I did notice that it shows a newer linux build version 3.6.9 and now also shows XBMC Beta 3 Smile

XBMC crashed with 15 mins left in a SD movie Sad

Here is the log..
http://pastebin.com/LnUPU2SJ


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2012-12-08

My version is unofficial and may include issues.

Wait for official release.


RE: OpenELEC Testbuilds for RaspberryPi - yantoucan - 2012-12-08

Hi Rbej

Is your update GUI 1080p working with transparency skin? How can i check that the GUI is showing in 1080p?
Thanks for your help


RE: OpenELEC Testbuilds for RaspberryPi - nowisn - 2012-12-08

never expect plugins and skins to work perfectly with any bleeding edge experimental builds of XBMC, these guys are working there butts off and doing an amazing job

Coding is not easy and takes a lot of time so ask your questions in the appropriate add-on and skin threads


RE: OpenELEC Testbuilds for RaspberryPi - kindrudekid - 2012-12-08

I got a few Questions

How do i make my Samsung TV remote to emulate tab when i press return, the only reason m asking is cause when playing radio or songs or even video for that matter and i want to see settings and stuff , i cannot get back to the main menu!!!!!
I got a back button that goes back 10 sec during playback or when streaming show me info!
the return button is just dormant!!!


also i hate the sub menu for movies and TV shows , the title/tags/genres etc that shows up in web interface or when broswing and pressing back from list of movies, how do i remove it?


also is the xbmc remote app for android updated for the frodo ?


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2012-12-08

OpenElec 3.0 beta 4

http://releases.openelec.tv/OpenELEC-RPi.arm-2.95.4.tar.bz2


RE: OpenELEC Testbuilds for RaspberryPi - hkramski - 2012-12-08

(2012-12-08, 20:45)kindrudekid Wrote: How do i make my Samsung TV remote to emulate tab when i press return, the only reason m asking is cause when playing radio or songs or even video for that matter and i want to see settings and stuff , i cannot get back to the main menu!!!!!
I got a back button that goes back 10 sec during playback or when streaming show me info!
the return button is just dormant!!!

For some reason, my Samsung B650's EXIT button is seen as the "menu" key by XBMC (except in Fullscreen and VirtualKeyboard context where it's correctly seen as "back"), so you have to refine /storage/.xbmc/userdata/keymaps/remote.xml a bit. Sounds like you are suffering from the same issue. Btw, FAV.CH is seen as "title", so <title>XBMC.ActivateWindow(Favourites)</title> is needed, too.

See https://github.com/xbmc/xbmc/blob/master/system/keymaps/remote.xml for a default template and http://wiki.xbmc.org/index.php?title=Keymap for general help on modifying key definitions.

(2012-12-08, 20:45)kindrudekid Wrote: also i hate the sub menu for movies and TV shows , the title/tags/genres etc that shows up in web interface or when broswing and pressing back from list of movies, how do i remove it?

See above.

(2012-12-08, 20:45)kindrudekid Wrote: also is the xbmc remote app for android updated for the frodo ?

Have a look at Yatse (https://play.google.com/store/apps/details?id=org.leetzone.android.yatsewidgetfree), works great.

Regards,
Heinz



RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2012-12-09

Does OE 3b4 include all those OMX memory leak/error handling fixups?

Although I'm not sure I want to spend too much time testing right now as the OE Betas are pretty much a one shot deal due to SD card corruption - it's frustrating having to reformat and reconfigure the ext4 partition before each boot. Hopefully this is going to improve, as I'm sure there's been a regression somewhere since the start of the Beta cycle. Switching root to USB memory stick is another solution to SD card corruption that has worked successfully in the past and I might have to give that a go but shouldn't be necessary as SD corruption wasn't a major problem prior to the Betas.


RE: OpenELEC Testbuilds for RaspberryPi - Knofbath - 2012-12-09

(2012-12-09, 02:38)MilhouseVH Wrote: Does OE 3b4 include all those OMX memory leak/error handling fixups?

Although I'm not sure I want to spend too much time testing right now as the OE Betas are pretty much a one shot deal due to SD card corruption - it's frustrating having to reformat and reconfigure the ext4 partition before each boot. Hopefully this is going to improve, as I'm sure there's been a regression somewhere since the start of the Beta cycle. Switching root to USB memory stick is another solution to SD card corruption that has worked successfully in the past and I might have to give that a go but shouldn't be necessary as SD corruption wasn't a major problem prior to the Betas.

Have you tried running fsck on the ext4 partition from a linux environment? I used an old LiveCD I had floating around, faster than imaging.


RE: OpenELEC Testbuilds for RaspberryPi - sebj - 2012-12-09

Quote: it's frustrating having to reformat and reconfigure the ext4 partition before each boot. Hopefully this is going to improve, as I'm sure there's been a regression somewhere since the start of the Beta cycle

Millhouse, are you overclocking?

Had a corruption issue myself when overclocking with my sd card (class 10)

I needed to add

initial_turbo=30

to /flash/config.txt


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2012-12-09

Yes I'm overclocking.

Prior to the Betas (ie. upto and including r12577 at which point I switched to Beta 1), I had no corruption worth mentioning and could reboot repeatedly without a problem, but now with the Betas I'm lucky if OpenELEC survives more than a single boot without corrupting the ext4 partition. This is with the same overclock settings, so I don't see the fact I'm overclocking as an issue, rather something is off in the firmware being shipped with the Betas.


RE: OpenELEC Testbuilds for RaspberryPi - tuxen - 2012-12-09

I have no problem with corruption of the ext4 partition but I noticed that in openELEC B4 I had to set my sdram clock down otherwise it hung at the color gradient screen. But no problems whatsoever with corruption and I run a high clock 1050/400/500 +4 before before B4 it was 1050/500/500 +4 not that it matters so much I can only conclude something changed in the firmware in B4.

I run this overclock 24/7 with force_turbo=1 never had any crashes or corruption, unless I ofcause go higher but that usually just result in a crash. I have a older no name/no sticker 4GB card and a 16GB Kingston class 10.
No corruption on either card, anyway just sharing my experience and that something happened in B4 firmware that limited the sdram clock at boot for me.

This is on a 512MB board as said before I have memory leaks happening on the 256MB when streaming HD content it does not overclock as much but I was running it at stock clock ofcause to eliminate that first. Oh well that's another matter..


RE: OpenELEC Testbuilds for RaspberryPi - sebj - 2012-12-09

Quote:I have memory leaks happening on the 256MB

Been hearing about this more recently, is it a recent bug? Fixed upstream?


This forum uses Lukasz Tkacz MyBB addons.