Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - nuttypro69 - 2013-01-15

Ok cool Tuxen


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-01-15

(2013-01-15, 04:39)tuxen Wrote:
(2013-01-14, 23:02)rbej Wrote:
(2013-01-14, 09:27)tuxen Wrote: I have a problem with 1080p 3DSBS files where the overlaying GUI only fills 1280x720 in the upper left corner when the pictures are put togheter. And the black half transparent bar where player controls are located stays at the "bottom" constantly. File stops playing after a few mins doesn't if 3DSBS is removed from file name.. Firmware from 09/01. Deleted guisettings.xml. Latest r12928 build.

Try this:

My new custom build.

http://www.mediafire.com/?10456ccz13ard

- OpenElec build r12928
- Xbmc build RC3 (14.01.2013) with updated fix for 3DSBS and 3DTAB movies.
- Special Rpi kernel 3.6.y (13.01.2013)
- Rpi firmware (13.01.2013)
- Pvr Addon (13.01.2013)
- Xvdr Addon (11.01.2013)
- Gpu memory set to 100mb on default (fix kernal killing Xbmc task on Rpi 256mb board)
- Memory cache set to 2621440 on default

Update Instruction:

http://openelec.tv/installation/updating

Set gpu_mem=100 in config.txt and cachemembuffersize to 2621440 in advencedsettings.

or clean install:

http://wiki.openelec.tv/index.php?title=Installing_OpenELEC_on_Raspberry_Pi

This one worked absolutely perfectl! GUI now fills whole screen and the tv detect 3D right away. The freeze after a few minuttes is also completely gone. Smile

Thanks a lot rbej! Keep up the nice work it's much appriciated!

Ps. Would you pherhabs consider making your future builds more universal.

Popcormix add today another update fix for 3DSBS and 3DTOP movies.

I updated my last custom build. Tuxen. Please test 3D movies. Thanks!!.

PS. Popcornmix. Can you share your 3dsbs and 3dtop fixed as patch??. Is a very easy matter compiling Xbmc. Now i must download all 8 files and copy to Xbmc source and repack again. It takes a lot of time.



RE: OpenELEC Testbuilds for RaspberryPi - xandy - 2013-01-15

(2013-01-14, 21:14)rbej Wrote: http://wiki.openelec.tv/index.php?title=Building_and_Installing_OpenELEC_for_Raspberry_Pi

Thanks for the reply but it didnt really help. I have been building the nightly builds happily though naively for a while so Im OK with that. I want to build the 2.99.1 RC1 specifically. I have tralled web sites trying to find clear instructions before posting. The attempts I am making (as detailed in previous post) are not working and I dont know if its because Im on the wrong track or if its buggy.

Can you take another look ?


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-01-15

git clone https://github.com/OpenELEC/OpenELEC.tv.git
cd OpenELEC.tv
git pull

PROJECT=RPi ARCH=arm make release

This is correct.

If you use Ubuntu you must install few packages before FIRST compiling.

Quote:sudo apt-get install g++ nasm flex bison gawk gperf autoconf automake m4 cvs libtool \
byacc texinfo gettext zlib1g-dev libncurses5-dev git-core build-essential xsltproc libexpat1-dev zip

Quote:sudo apt-get install autopoint xfonts-utils

Quote:sudo apt-get install libxml-parser-perl

and install Java.




RE: OpenELEC Testbuilds for RaspberryPi - pplucky - 2013-01-15

(2013-01-15, 04:39)tuxen Wrote:
(2013-01-14, 23:02)rbej Wrote:
(2013-01-14, 09:27)tuxen Wrote: I have a problem with 1080p 3DSBS files where the overlaying GUI only fills 1280x720 in the upper left corner when the pictures are put togheter. And the black half transparent bar where player controls are located stays at the "bottom" constantly. File stops playing after a few mins doesn't if 3DSBS is removed from file name.. Firmware from 09/01. Deleted guisettings.xml. Latest r12928 build.

Try this:

My new custom build.

http://www.mediafire.com/?10456ccz13ard

- OpenElec build r12928
- Xbmc build RC3 (14.01.2013) with updated fix for 3DSBS and 3DTAB movies.
- Special Rpi kernel 3.6.y (13.01.2013)
- Rpi firmware (13.01.2013)
- Pvr Addon (13.01.2013)
- Xvdr Addon (11.01.2013)
- Gpu memory set to 100mb on default (fix kernal killing Xbmc task on Rpi 256mb board)
- Memory cache set to 2621440 on default

Update Instruction:

http://openelec.tv/installation/updating

Set gpu_mem=100 in config.txt and cachemembuffersize to 2621440 in advencedsettings.

or clean install:

http://wiki.openelec.tv/index.php?title=Installing_OpenELEC_on_Raspberry_Pi

This one worked absolutely perfectl! GUI now fills whole screen and the tv detect 3D right away. The freeze after a few minuttes is also completely gone. Smile
Hello.

I just tried this build with my 256 Rpi and my Samsung 3DTV, but although the movie seems to play nice, 2 issues:
- TV did not detect 3D right away;
- Subtitles are totally scrambled (seems like they are being displayed in the whole screen and as 3D mode overlaps the SBS images, it also overlaps the half part of the subtitles...

Can anyone help, please?

Thanks in advance.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-01-15

I updated my last custom build. Including new fix for 3d movie. Download again r14012013 and try.


RE: OpenELEC Testbuilds for RaspberryPi - valerio - 2013-01-15

(2013-01-14, 19:52)xandy Wrote: Hi, can someone help with some simple advice. I want to build 2.99.1 RC1 from source for reasons which I can elaborate if necessary. I see there is a branch called openelec-3.0 which I guess is the right place so I do this:

git clone https://github.com/OpenELEC/OpenELEC.tv.git openelec-3.0
cd openelec-3.0
git pull origin openelec-3.0

PROJECT=RPi ARCH=arm make

Is this correct approach ... Im guessing a bit ??

regards

Andy

Hi,
I think you should substitute
Code:
git pull origin openelec-3.0
with
Code:
git checkout 2.99.1

This should checkout the tag used for RC1 from your local git repository and then you should be able to build your project having RC1 source. You should be also able to list tags with
Code:
git tag -l
Keep in mind that I haven't tested this though :-)


RE: OpenELEC Testbuilds for RaspberryPi - pplucky - 2013-01-15

(2013-01-15, 12:27)rbej Wrote: I updated my last custom build. Including new fix for 3d movie. Download again r14012013 and try.
With this custom build (just downloaded it and tried), 3D movie simply shows as non-3D, as any regular movie, so even worst Big Grin

Edit: Rebooted after deleting guisettings.xml and it is still the same ;-)


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-01-15

(2013-01-15, 12:38)pplucky Wrote:
(2013-01-15, 12:27)rbej Wrote: I updated my last custom build. Including new fix for 3d movie. Download again r14012013 and try.
With this custom build (just downloaded it and tried), 3D movie simply shows as non-3D, as any regular movie, so even worst Big Grin

LOL.

I upload now "old" r14012013 build.


RE: OpenELEC Testbuilds for RaspberryPi - pplucky - 2013-01-15

(2013-01-15, 12:42)rbej Wrote:
(2013-01-15, 12:38)pplucky Wrote:
(2013-01-15, 12:27)rbej Wrote: I updated my last custom build. Including new fix for 3d movie. Download again r14012013 and try.
With this custom build (just downloaded it and tried), 3D movie simply shows as non-3D, as any regular movie, so even worst Big Grin

LOL.

I upload now "old" r14012013 build.
OK, just let me know if I can be of any help and how...


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-01-15

(2013-01-15, 12:38)pplucky Wrote: With this custom build (just downloaded it and tried), 3D movie simply shows as non-3D, as any regular movie, so even worst Big Grin

You need to name your videos with 3DSBS or 3DTAB in filename.
E.g. avatar.3DSBS.mkv



RE: OpenELEC Testbuilds for RaspberryPi - pplucky - 2013-01-15

(2013-01-15, 13:00)popcornmix Wrote:
(2013-01-15, 12:38)pplucky Wrote: With this custom build (just downloaded it and tried), 3D movie simply shows as non-3D, as any regular movie, so even worst Big Grin

You need to name your videos with 3DSBS or 3DTAB in filename.
E.g. avatar.3DSBS.mkv

And I did... Full filename is: The.Nightmare.Before.Christmas.3D.1993.H-3DSBS.H264.Multi.AC3.3D4ALL.Ex-3DBlurayisoTeam.mkv


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-01-15

(2013-01-15, 13:05)pplucky Wrote: And I did... Full filename is: The.Nightmare.Before.Christmas.3D.1993.H-3DSBS.H264.Multi.AC3.3D4ALL.Ex-3DBlurayisoTeam.mkv

Firstly, switching to 3D mode only works when you have "Adjust display refresh rate to match video" enabled.

If you do, then can you enable debug and post xbmc.log.
Also can you (ssh in and) run
tvservice -s
before starting the video, and then again when video is playing.

Also what does
tvservice -m CEA
return?


RE: OpenELEC Testbuilds for RaspberryPi - pplucky - 2013-01-15

(2013-01-15, 13:25)popcornmix Wrote: Firstly, switching to 3D mode only works when you have "Adjust display refresh rate to match video" enabled.
This did the trick for auto switch to 3D mode, but now the movie shows huge bars up and above, cutting part of the movie!
You can check here how it looks.

If I put "Adjust display refresh rate to match video" to "Off", it goes back to normal (showing 2 pictures SBS by default, but no cuts).
You can check here how it looks.

Enabling 3D mode manually also doesn't cut.

Subtitles seem to show OK with "Adjust display refresh rate to match video" at "On start/stop", but with huge characters (bigger than in normal mode).

(2013-01-15, 13:25)popcornmix Wrote: Also can you (ssh in and) run
tvservice -s
before starting the video,
Code:
state 0x12001a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60Hz, progressive

(2013-01-15, 13:25)popcornmix Wrote: and then again when video is playing.
Code:
state 0x12001a [HDMI CEA (31) 3D SbS RGB lim 16:9], 1920x1080 @ 50Hz, progressive

(2013-01-15, 13:25)popcornmix Wrote: Also what does
tvservice -m CEA
return?
Code:
Group CEA has 14 modes:
           mode 1: 640x480 @ 60Hz 4:3, clock:25MHz  progressive
           mode 2: 720x480 @ 60Hz 4:3, clock:27MHz  progressive
           mode 3: 720x480 @ 60Hz 16:9, clock:27MHz  progressive
           mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz  progressive 3D:TopBot|SbS-HH
           mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz  interlaced 3D:TopBot|SbS-HH
  (native) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz  progressive 3D:TopBot|SbS-HH
           mode 17: 720x576 @ 50Hz 4:3, clock:27MHz  progressive
           mode 18: 720x576 @ 50Hz 16:9, clock:27MHz  progressive
           mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz  progressive 3D:TopBot|SbS-HH
           mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz  interlaced 3D:TopBot|SbS-HH
           mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz  progressive 3D:TopBot|SbS-HH
           mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz  progressive 3D:TopBot|SbS-HH
           mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz  progressive 3D:TopBot|SbS-HH
           mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz  progressive 3D:TopBot|SbS-HH



RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-01-15

(2013-01-15, 13:48)pplucky Wrote: This did the trick for auto switch to 3D mode, but now the movie shows huge bars up and above, cutting part of the movie!
You can check here how it looks.

tvservice looks right.

What zoom mode are you on? Can you switch to normal.
The latest version of PR forces normal zoom mode when in 3D. If there is still a problem can you try deleting guisettings.xml once more.


This forum uses Lukasz Tkacz MyBB addons.