Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2013-02-06

(2013-02-06, 01:45)efegue Wrote: Can you guys point me on how to do a USB install on OpenELEC? I search a lot, but I didn't find any consistent information on how to do this in windows.

Assuming you only want /storage on USB:

1) Format an SD card with a single FAT partition
2) Copy SYSTEM, KERNEL (renamed to kernel.img), bootcode.bin, fixup.dat, start.elf, config.txt and cmdline.txt files to the SD card
3) Format the USB key with a single ext4 partition (you could use Raspbian on the Pi to format the USB key with ext4)
4) Configure cmdline.txt with "disk=/dev/sda1"

You could also format the USB key with two partitions - one FAT ~100MB, the second ext4 - and "boot" the Pi from the USB key by placing the SYSTEM file in the USB FAT partition, having specified "boot=/dev/sda1 disk=/dev/sda2" in cmdline.txt, but there really is little advantage in doing this compared with the single USB partition approach outlined above.

PS: @admins - this forum needs a sticky...


RE: OpenELEC Testbuilds for RaspberryPi - papreston - 2013-02-06

Hi

I'm running the latest build and having audio/video sync problem with live HD and HD recorded tv shows. I'm using NextPVR as my back end on a WHS machine which works well with my other XBMC on windows. The sync starts fine but the video skips and stops and becomes out of sync. Sometimes the buffering window comes up for a few seconds. SD DVDs play back fine. Sounds like a network problem to me but I don't know enough about the PI to know where to start. I'm on a wired network. I have the MPEG license.

Any help would be great!
Thanks


RE: OpenELEC Testbuilds for RaspberryPi - vlad59 - 2013-02-06

(2013-02-05, 13:06)popcornmix Wrote:
(2013-02-05, 09:48)vlad59 Wrote: Does mplayer -dumpstream work for you or have you another tool in mind ?

Sounds possible. You'll have to confirm it suffers the same problem as the live stream. It is possibly that mplayer will fix the timestamps or repacketise the data and so avoid the problem, but it's worth a try.

As expected the dumped stream (with mplayer) doesn't show the problem ... and I do not have enough upload bandwidth to give you access to the stream to test.

I retried just after that the rtsp stream (in a strm file) and it stutters a lot during the first 3 seconds where it drops video frames but the audio stays off sync afterward.

If it can help you here is a mplayer log playing the stream

Code:
Playing rtsp://212.27.38.253/fbxtv_pub/stream?namespace=1&service=372&flavour=ld
.
Connecting to server 212.27.38.253[212.27.38.253]: 554...

Cache size set to 640 KBytes
Cache fill: 19.88% (130284 bytes)

libavformat version 54.61.104 (internal)
TS file format detected.
VIDEO H264(pid=2060) AUDIO AAC(pid=2061) NO SUBS (yet)!  PROGRAM N. 49280
Cannot seek backward in linear streams!
FPS seems to be: 25.000000
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 54.91.100 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[aac @ 01187e00]get_buffer() failed
AUDIO: 48000 Hz, 2 ch, floatle, 0.0 kbit/0.00% (ratio: 0->384000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [dsound] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
Movie-Aspect is 1.82:1 - prescaling to correct movie aspect.
[swscaler @ 012cb320]BICUBIC scaler, from yuv420p to yuyv422 using MMXEXT
VO: [directx] 720x576 => 1048x576 Packed YUY2
A:24079.9 V:24080.3 A-V: -0.397 ct: -0.428 110/110 21%  5%  0.9% 0 0 47%

Exiting... (Quit)



RE: OpenELEC Testbuilds for RaspberryPi - zoltan - 2013-02-06

Hi rbej,
I just replaced openelec official 2.99.2 with your last build on my raspberry.
I also applied your suggested settings:
"For Rpi 512Mb set gpu_mem=256, cachemembuffersize to 5242880"

Since then, I'm not able anymore to watch tv steam from my dreambox dm800se using pvr addon vu+ or tuxbox client connection. The stream hangs as soos an it starts, just after 1 second.
Before, with 2.99.2 official, it didn't happen. I was able to watch at least sd channels.

Does it depend on settings above (gpu_mem op cachemembuffersize)?
Thanks


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-07

Gpu_mem and cache buffer size have no effect on watch Live TV. It must be something else


RE: OpenELEC Testbuilds for RaspberryPi - papreston - 2013-02-08

Hi all

I posted a few messages back about possible network issues while watching HD.
I found this page http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=20126
I put the sysctl.conf file inside the configfiles folder, It seems to have fixed my problem. HD live TV was MUCH better.




RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-08

My new custom build.

Rbej Frodo Final Version 3

http://www.mediafire.com/?10456ccz13ard

- OpenElec build r13238
- Xbmc 12.0.1 Frodo Final
- Rpi kernel 3.6.y (07.02.2013)
- Rpi firmware (07.02.2013)
- Pvr Addon (18.01.2013) with PVR TvHeadend 1.6.18 fixed. (Thx Jbree85) and MythTv 1.6.8 (07.02.2013)
- Xvdr Addon (07.02.2013)
- Gpu memory set to 100mb on default for Rpi 256mb (fix kernal killing Xbmc task on Rpi 256mb board) and Gpu memory set to 256mb on default for Rpi 512mb.
- Memory cache set to 2621440 on default
- GUI resolution switch (taken from XBIAN)

Add to advencedsettings <guires>XXXX</guires>

XXXX = GUI resolution. 480p,720p,900p,1080p. <guires>720</guires>, <guires>1080</guires> etc...

Update Instruction:

http://wiki.openelec.tv/index.php?title=Updating_OpenELEC

For Rpi 512Mb set gpu_mem=256, cachemembuffersize to 5242880 and change GUI to 1080p.

For Rpi 256Mb set gpu_mem=100, cachemembuffersize to 2621440 and change GUI to 900p.

***
If you want try new codecs add this line to config.txt

start_file=start_x.elf
fixup_file=fixup_x.elf

or clean install:

http://wiki.openelec.tv/index.php?title=Installing_OpenELEC_on_Raspberry_Pi

----------------------------------------------------------------------------------------------------------------------------------

Firmware changelog:

https://github.com/raspberrypi/firmware/commits/master

Kernel changelog:

https://github.com/raspberrypi/linux/commits/rpi-3.6.y

Xbmc changelog:

https://github.com/xbmc/xbmc/commits/Frodo

OpenElec changelog:

https://github.com/OpenELEC/OpenELEC.tv/commits/master

PVR changelog:

https://github.com/fetzerch/xbmc-pvr-addons/commits/master

XVDR changelog:

https://github.com/pipelka/xbmc-addon-xvdr/commits/master



RE: OpenELEC Testbuilds for RaspberryPi - lowridin_guy - 2013-02-08

Just curious, since Frodo has been final for a few days now what are the differences betweenyour Frodo final builds versions 1,2,3?

EDIT: also wouldn't your build version of XBMC be considered "Gotham"? I'm just a little confused and any help would be appreciated.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-08

Frodo Final 1

- OpenElec build r13108
- Xbmc 12 Frodo Final
- Rpi kernel 3.6.y (22.01.2013)
- Rpi firmware (26.01.2013)
- Pvr Addon (18.01.2013)
- Xvdr Addon (11.01.2013)

Frodo Final 2

- OpenElec build r13143
- Xbmc Frodo 12 Final
- Rpi kernel 3.6.y (01.02.2013)
- Rpi firmware (30.01.2013)
- Pvr Addon (18.01.2013)
- Xvdr Addon (29.01.2013)

Frodo Final 3

- OpenElec build r13227
- Xbmc 12.0.1 Frodo Final
- Rpi kernel 3.6.y (07.02.2013)
- Rpi firmware (07.02.2013)
- Pvr Addon (18.01.2013) with PVR TvHeadend 1.6.18 fixed. (Thx Jbree85)
- Xvdr Addon (07.02.2013)

Firmware changelog:

https://github.com/raspberrypi/firmware/commits/master

Kernel changelog:

https://github.com/raspberrypi/linux/commits/rpi-3.6.y

Xbmc changelog:

https://github.com/xbmc/xbmc/commits/Frodo

OpenElec changelog:

https://github.com/OpenELEC/OpenELEC.tv/commits/master

PVR changelog:

https://github.com/fetzerch/xbmc-pvr-addons/commits/master

XVDR changelog:

https://github.com/pipelka/xbmc-addon-xvdr/commits/master


RE: OpenELEC Testbuilds for RaspberryPi - lowridin_guy - 2013-02-08

I see the different revision dates. I guess I would have to look up change logs for each thing. So is build 13227 considered Frodo or Gotham? I thought earlier versions of XBMC were Gotham and now we are back at Frodo? That is what is most confusing.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-08

Gotham is Alpha version Xbmc 13. Official OpenElec r13227 include Frodo. I decide support only stable version Xbmc. If OpenElec team will be support Xbmc 13 , i will support to.



RE: OpenELEC Testbuilds for RaspberryPi - Slatri - 2013-02-08

Tried the latest frodo build and the audio is still way out of sync more than 10 seconds. I will grab a log when I get home


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-02-08

(2013-02-08, 20:06)Slatri Wrote: Tried the latest frodo build and the audio is still way out of sync more than 10 seconds. I will grab a log when I get home

The logs don't include timestamp information, so you will likely need to upload a sample (e.g. 100MB) of a file that exhibits the problem.


RE: OpenELEC Testbuilds for RaspberryPi - Slatri - 2013-02-08

How would I do that? I could also give you my dns and the plugin if that would be better. if you want to pm me I can the details. Thank you


RE: OpenELEC Testbuilds for RaspberryPi - tvankirk - 2013-02-09

(2013-02-08, 16:39)rbej Wrote: My new custom build.

Rbej Frodo Final Version 3
Rbej,
I've been happily running your builds for a couple of weeks now and was wondering if it would be possible to add the latest development MythTV PVR addon to your build.

http://wiki.xbmc.org/index.php?title=PVR/Backend/MythTV/BuildFromSource#Build_MythTV_git_into_OpenELEC

I was able to compile it into openelec (it is a huge improvement over the version in Frodo) but doing it with all of your additional goodies is beyond my capabilities without a pretty specific how-to.

Thanks



This forum uses Lukasz Tkacz MyBB addons.