Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - ntadej - 2013-02-13

You simply update OpenELEC as you would with official builds. Don't forget to update firmware too Smile


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-02-13

(2013-02-13, 13:36)tuxen Wrote: I think he means when you bring up codec info the last line reads:

W (fps:9.xx. CPU:20.6)

Is that fps a resemblence of the unlaying GUI?!

Yes, this comes from OMXPlayerVideo and reports how often it kicks the UI into rendering a frame.
On a platform where video is rendered through opengl, this would need to match the video framerate, but on the Pi, the video is rendered asynchronously by the GPU, so this can be lower.


RE: OpenELEC Testbuilds for RaspberryPi - tuxen - 2013-02-13

Ah ok. Thanks a lot for the explanation popcornmix. Makes perfect sense then.. Smile


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-13

Update Frodo Final 3

- OpenElec build r13287 (with enable 128MB swap file)

- Pvr Addon (12.02.2013) with PVR TvHeadend 1.6.18 fixed. (Thx Jbree85) and MythTv 1.6.9 (09.02.2013)

http://www.mediafire.com/?10456ccz13ard


RE: OpenELEC Testbuilds for RaspberryPi - spjonez - 2013-02-13

(2013-02-13, 16:14)rbej Wrote: Update Frodo Final 3

- OpenElec build r13287 (with enable 128MB swap file)

- Pvr Addon (12.02.2013) with PVR TvHeadend 1.6.18 fixed. (Thx Jbree85) and MythTv 1.6.9 (09.02.2013)

http://www.mediafire.com/?10456ccz13ard
Hey rbej, I'd like to try your new Frodo Final 3 tonight to see if it fixes the .ass subtitles in one series I have. Does this build also include the fixes from the build you posted yesterday?

With this build do I need to remove cachemembuffersize and replace with alwaysforcebuffer?

I have my storage on an attached USB, where does the swap file get created? Currently I'm using a 4GB micro SD with just the system partition on it the rest is un-partitioned space. I have two USB HD's plugged in to the Pi, one is EXT (32gb) / NTFS (2TB), the other is NTFS (2.5TB). Can I upgrade to this build or do I have to do a fresh install?

Thanks!


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-13

1. Include all fixes.

2. Yes. Delete cachemembuffersize and add this:

<alwaysforcebuffer>true</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>

3. I think swap file is created on Storage partition.

4. Upgrade.


RE: OpenELEC Testbuilds for RaspberryPi - gollor - 2013-02-13

Oh im so sorry I thought this was exactly the same as the build available from:
http://openelec.thestateofme.com/

But thanks so much! Going to put it on my sdcard now! Ur a great person!

EDIT: May I also confirm that it successfully scrapes sftp directories! One again thank you to the people who fixed it and for compiling it.


RE: OpenELEC Testbuilds for RaspberryPi - hkramski - 2013-02-13

(2013-02-13, 16:14)rbej Wrote: Update Frodo Final 3

- OpenElec build r13287 (with enable 128MB swap file)

- Pvr Addon (12.02.2013) with PVR TvHeadend 1.6.18 fixed. (Thx Jbree85) and MythTv 1.6.9 (09.02.2013)

http://www.mediafire.com/?10456ccz13ard

Tried this (256 MB, class 10 8 GB card) and enabled

<alwaysforcebuffer>true</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>.

Now I get massive lagging after 5 min forward skips in SD movies from SMB source (100 MBit/s Ethernet).
Never had buffering issues in my LAN before (your previous 20130209102343-r13238 was running well).

Regards,
Heinz


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2013-02-13

@Heinz: Does setting <alwaysforcebuffer>false</alwaysforcebuffer> restore your old non-lagging behaviour?


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-13

I think this is ass subs patch bug. I must check it.


RE: OpenELEC Testbuilds for RaspberryPi - hkramski - 2013-02-13

(2013-02-13, 20:27)MilhouseVH Wrote: @Heinz: Does setting <alwaysforcebuffer>false</alwaysforcebuffer> restore your old non-lagging behaviour?

No.

(These are top level settings which don't go into the <network>-section, as <cachemembuffersize> did, right? If they need to be inside <network>, call me stupid...)

Heinz


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-13

This is Ass subs patch bug. I compile build without this patch and no more lags when skips in SD movies from SMB/NFS sources.


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-02-13

(2013-02-13, 20:38)hkramski Wrote: (These are top level settings which don't go into the <network>-section, as <cachemembuffersize> did, right? If they need to be inside <network>, call me stupid...)

Same place as cachemembuffersize, so inside network section.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-13

Update Frodo Final 3

- OpenElec build r13301 (with enable 128MB swap file)

- Remove again Ass Subs Patch (fixed lags when skips SD movies from SMB/NFS sources)

http://www.mediafire.com/?10456ccz13ard

PS. Popcornmix. Please fixed Ass Subs Patch.


RE: OpenELEC Testbuilds for RaspberryPi - hkramski - 2013-02-13

That was fast!

Seems to be fixed, thanks a lot for your good work.

Regards,
Heinz


This forum uses Lukasz Tkacz MyBB addons.