Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - asummerf - 2013-02-18

Latest build getting crashes and even xbmc restart jumping sound sd mp4 file.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-18

Please try set

<alwaysforcebuffer>false</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>

Working fine with this files:

http://www.bindasmasti.in/index.php?dir=Full_Videos/Mp4/Bollywood%20Videos/Latest%20Movie%20Songs%20Video%202012/Race%202%20%282012%29&p=1&sort=1


RE: OpenELEC Testbuilds for RaspberryPi - evanspae - 2013-02-18

(2013-02-18, 14:04)rbej Wrote: Please try set

<alwaysforcebuffer>false</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>

Working fine with this files:

http://www.bindasmasti.in/index.php?dir=Full_Videos/Mp4/Bollywood%20Videos/Latest%20Movie%20Songs%20Video%202012/Race%202%20%282012%29&p=1&sort=1

I had a similar issue, I think the upgrade instruction may need to be updated to remove lines re
For Rpi 512Mb set gpu_mem=256, cachemembuffersize to 5242880 and change GUI to 1080p etc

Quote:Update Instruction:

http://wiki.openelec.tv/index.php?title=...g_OpenELEC

For Rpi 512Mb set gpu_mem=256, cachemembuffersize to 5242880 and change GUI to 1080p.

For Rpi 256Mb set gpu_mem=100, cachemembuffersize to 2621440 and change GUI to 900p.

***
If you want try new codecs add this line to config.txt

start_file=start_x.elf
fixup_file=fixup_x.elf

or clean install:

http://wiki.openelec.tv/index.php?title=...spberry_Pi

My system now working without setting cachemembuffersize to 2621440 .

Could rbej confirm this and whether or not Rpi 256Mgb will work with new settings and a GUI of 1080p


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-18

Thanks. I changed.

Rpi 256mb working with Gui 1080p but may be memory out, when watch movie.


RE: OpenELEC Testbuilds for RaspberryPi - gollor - 2013-02-18

Works perfectly with the latest. No buffer issues at all. Nice one!!!Big Grin


RE: OpenELEC Testbuilds for RaspberryPi - FattyMcDirty - 2013-02-18

with the latest build and the recommended instructions, i'm not able to playback any video file at all any more. clickin' on the video i wanna watch, the cycling animation shows, and instead of starting the movie, the cycling animation stops and i'm still in my video menu list.... could u PLZ upload the previous build? Sad

edit: did set cachemembuffersize back to 5242880 and removed those new options from your post... and it's playing again like it did before...


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-18

You remove cachemembuffersize from advencedsettings and add this in network section:

<alwaysforcebuffer>false</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>

Not work??.


RE: OpenELEC Testbuilds for RaspberryPi - sdsnyr94 - 2013-02-18

I can confirm I have seen what FattyMcDirty is talking about. After a fresh install and adding the 2 lines in the network section, on occasions when you click on a video the "Working" box comes up, and in the bottom left corner of the screen you can see the Video title, time progressing/time remaining, etc (as if you hit 'Tab' on the keyboard)... The Time does not progress, however if you press Pause, you will receive the 'Paused' box (top right of screen). In that box, the playback time has progressed. You do not get any audio or video while this is occuring. Pressing 'stop' causes the playback overlay to go away.

Sorry, I am not a home and do not have any logs to post.

When the unit does playback.... WOW! I did have one time while playing back LOTR:Two Towers where something went wrong, because when I checked it after about 2 hours it was at the main menu. Unfortunately I did not have debug log turned on, so there was no way to see what happened. The next time I played the video, it played to completion, and scenes that I know previously had buffering issues were perfectly smooth.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-18

Tomorrow i compile new build with standard cachemembuffersize and share to test.


RE: OpenELEC Testbuilds for RaspberryPi - Pierre1985 - 2013-02-18

@sdsnyr94

i got this problem to, with a slow network connection and 20% freememorycachepercent. if you can show the cache status u can see that the raspberry is trying to fill up the cache.
Try to push the playbutton this stops the process and let the movie start.

So this works for me, i have no issues with the patch all files works perfect for me.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-18

Quote:"freememorycachepercent": The amount of free memory to use as buffer size. Please note that of the percentage of free memory used ~75% will be used for forward buffering and ~25% will be used for the back buffer. The default is 50% which is a good default for memory limted devices such as the atv2. The max is 80 percent and there is a hard limit of 1GB buffer size irregardless of free ram. Setting it to 0 will force filecaching (same as the way cachemembuffersize was used)

Sdsnyr94 and FattyMcDirty

Try set 0 in freememorycachepercent.

I have fast wired connection and add this option.

<alwaysforcebuffer>false</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>

Everythings works perfect with last build.


RE: OpenELEC Testbuilds for RaspberryPi - radioparadise - 2013-02-18

I would like to say it works: now I made a clean install to latest version, and everything is working OK. Video, Audio, liveRadio, recorded TV - but no liveTV. When opening a channel, immediately the system restart. Since I used XBMC Backup, I fear some of the older settings are in conflict with the new omxplayer, i.e.for interlaced Video. I don't find omxplayer-settings. Any ideas where I can look for a solution?


RE: OpenELEC Testbuilds for RaspberryPi - FattyMcDirty - 2013-02-18

(2013-02-18, 20:31)rbej Wrote: You remove cachemembuffersize from advencedsettings and add this in network section:

<alwaysforcebuffer>false</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>

Not work??.

nope... no playback possible.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-18

Its realy strange....Try delete guisetting. You have Rpi 256 or 512mb??

Add to network section in advenced settings:

<curlclienttimeout>30</curlclienttimeout>

If still not work please give logs.


AW: OpenELEC Testbuilds for RaspberryPi - FattyMcDirty - 2013-02-19

yea... got a 512mb rpi... gonna tedt it 2morrow.... withe the cachememsize set, movies with 4gb+ size work.... tvshow with about 1gb or less doesn't start playing.... would there be a chance to upload one of your previous builds insteag of overwriting build 3? would be great... this is kinda not usable for me as an everyday driver now Sad


This forum uses Lukasz Tkacz MyBB addons.