Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (/showthread.php?tid=140518)



RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-19

Try delete guisetting.

Add to network section in advenced settings:

<curlclienttimeout>30</curlclienttimeout>

and set gpu_mem=128 in config.txt

Tomorrow i compile new build.


RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-02-19

@rbej
https://github.com/popcornmix/xbmc/commit/6c00a258a5b88189e8640c490922c1ef30bb54c3

might be worth trying. It should fix streams where the resolution changes (i.e. streams that hang at commercials).


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-19

Ok Smile


RE: OpenELEC Testbuilds for RaspberryPi - sdsnyr94 - 2013-02-19

(2013-02-17, 14:02)tuxen Wrote:
(2013-02-16, 22:27)sdsnyr94 Wrote:
(2013-02-16, 21:04)popcornmix Wrote: Is this a new problem, or have you always suffered from it?

In this thread, I have mentioned this a number of times. I have played movies that are within 1:30 - 2 hr in length with few problems, so for my testing I am using the extended editions of the Lord of the Rings blurays. If you would like the mediainfo on them, I can post them later.

Usually I do not watch the movie, since it is so long and at this point I am not concerned about any buffering (I just want to see it playback to completion before worrying about that) ... I just start playback and walk away or let it run overnight. Xbian Alpha 3, Xbian alpha 4 (after creating swap file), and Raspbmc Final all play the videos to completion.
Not to annoy rbej or anything. He makes some great builds with new features for all to enjoy. <thanks>
But have you tried a ordinary latest official nightly? It has swap to and a friend of mine (the guy I gave my old 256MB board to) have recently watched the same blurays as you without problems on he's now 256MB board. How big are your files? These are self ripped and around ~20GB with DTS. Or are you streaming of the Internet? And is it all files > 2 hours or just lotr?

Edit: pherhabs I should mention that he is streaming from a nas via samba. The memory bug with ice****s and other internet streaming addons are also totally gone.

I have not tried the "ordinary" nightly builds in a while... I may give them a run just to see.

Yes, my files are self-ripped ~20Gb with DTS... I am streaming from my Unraid server via NFS.
Not sure if it is all files >2 hrs... I know that the Dark Knight Rises failed at about that point also, but then I started testing with only the LOTR movies.. just because their extremely long length made great test subjects.


RE: OpenELEC Testbuilds for RaspberryPi - evanspae - 2013-02-19

Hi rbej;

I now am having a 2 problems with r13341 on a 256Mb pi

included in advancedsettings.xml
<guires>900</guires>
<alwaysforcebuffer>true</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent> ,

I am now getting black screen freezes preventing playback of H264 (all my material is UK BBC HD stuff not DVD rips). Only way to get H264 working is by hard reboot which sometimes works. MPEG2 works fine, new buffer mechanism seems great on MPEG2 and H264 when it does playback.

Secondly I am getting distorted audio via HDMI out could this be anything todo with simultaneous analogue/HDMI audio mods? Peripheral a/v amp etc have not changed..


Finally all my settings above are in video section of advancedsettings.xml do I need a separate network section ie something like;

<network>
<alwaysforcebuffer>true</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>
</network>


RE: OpenELEC Testbuilds for RaspberryPi - evanspae - 2013-02-19

This may be of use to other users who may be as simple as me yet want to improve the skip buffering!! I think I just answered my own questionTongueTongueTongue

I have looked at xbmc wiki and checked syntax, my advancedsettings.xml is now;

<advancedsettings>

<guires>900</guires>


<network>
<alwaysforcebuffer>true</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>
<!-------------<cachemembuffersize>2621440</cachemembuffersize>----------->
</network>

</advancedsettings>


At the moment this seems to be working fine....... I will check if the guires needs to be in its own section


RE: OpenELEC Testbuilds for RaspberryPi - jghm - 2013-02-19

Working fine here on a fresh installation.

My settings on a Rpi 512Mb if it can help someone.

advancedsettings.xml

<advancedsettings>

<network>
<alwaysforcebuffer>true</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>
</network>

<guires>1080</guires>

<gui>
<algorithmdirtyregions>3</algorithmdirtyregions>
<nofliptimeout>0</nofliptimeout>
</gui>

<lookandfeel>
<enablerssfeeds>false</enablerssfeeds>
</lookandfeel>

<bginfoloadermaxthreads>2</bginfoloadermaxthreads>

</advancedsettings>

config.txt

arm_freq=900
core_freq=333
sdram_freq=450
over_voltage=2

arm_freq_min=700
core_freq_min=250
sdram_freq_min=400
over_voltage_min=0

force_turbo=0

initial_turbo=50

gpu_mem_512=256

decode_MPG2=xxxxxxxxxxxxxx
decode_WVC1=xxxxxxxxxxxxx

start_file=start_x.elf
fixup_file=fixup_x.elf

hdmi_ignore_cec_init=1


BTW great builds Rbej, thank you


RE: OpenELEC Testbuilds for RaspberryPi - pplucky - 2013-02-19

I don't know if this issue with guires was already fixed.

Was it?


RE: OpenELEC Testbuilds for RaspberryPi - jghm - 2013-02-19

@pplucky

no, the bug is still there, I've just tried with :
<guires>1080</guires> <!-- Added for rbej custom OE build -->

But with <guires>1080</guires> alone, no problem


RE: OpenELEC Testbuilds for RaspberryPi - pplucky - 2013-02-19

(2013-02-19, 13:21)evanspae Wrote: <advancedsettings>

<guires>900</guires>

</advancedsettings>

At the moment this seems to be working fine....... I will check if the guires needs to be in its own section
This should be OK, no section needed, just beware of comments after the tag (like mentioned before).


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-19

I compile now new clean build. Please wait 2-3 hours.


RE: OpenELEC Testbuilds for RaspberryPi - rbej - 2013-02-19

Frodo Final 3 updated

http://forum.xbmc.org/showthread.php?tid=140518&pid=1339015#pid1339015

After update please remove swap file from .storage/cache folder and remove this lines from config.txt

start_file=start_x.elf
fixup_file=fixup_x.elf

New codecs now is included in start.elf and fixup.dat files.



RE: OpenELEC Testbuilds for RaspberryPi - popcornmix - 2013-02-19

(2013-02-19, 17:38)rbej Wrote: Frodo Final 3 updated

Out of interest this branch:
https://github.com/popcornmix/xbmc/tree/new_stall

changed two days ago (but you had made a build with these patches from before then).

Do your patches match the latest two commits on that branch?


RE: OpenELEC Testbuilds for RaspberryPi - FattyMcDirty - 2013-02-19

root ~/.cache # rm swapfile
rm: can't remove 'swapfile': Operation not permitted


RE: OpenELEC Testbuilds for RaspberryPi - Milhouse - 2013-02-19

(2013-02-19, 19:47)FattyMcDirty Wrote: root ~/.cache # rm swapfile
rm: can't remove 'swapfile': Operation not permitted

Presumably your swapfile is still in use, try "swapoff" then remove it.

Or boot the new update, then remove your swapfile (which will no longer be in use). I'm not sure why it's necessary to remove the swapfile before booting the new kernel which has no swap support.


This forum uses Lukasz Tkacz MyBB addons.