Kodi Community Forum
WIP Stereoscopic 3D support for half/full SBS, over/under, etc - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Kodi Application (https://forum.kodi.tv/forumdisplay.php?fid=93)
+--- Thread: WIP Stereoscopic 3D support for half/full SBS, over/under, etc (/showthread.php?tid=147285)



RE: Stereoscopic 3D support for half/full SBS, over/under, etc - nickr - 2013-09-18

why not .3dbd.sbs.mkv and .3dbd.ou.mkv respectively?

then add those definitions to advancedsettings.xml

The skin will see .3dbd and XBMC playback will see .3dbd.sbs or .3dbd.ou


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - Lamerjack - 2013-09-18

(2013-09-17, 16:50)szape Wrote: You're right, latest nightly build under Windows 7 x64 with DXVA2 enabled. Turned off DXVA, anaglyph works but stutters, so i have to wait for the video acceleration to work. Thanks for your suggestion and support and all of your work!

Same problem. With amd and nvidia board. I just found that with nvidia (maybe also with amd i have to test) if go in Video Scaling Method is see that is set on Bicubic. I change to the next that is "Auto" and i have same problem. I change to the next that is "DXVA" i change to the next and anagliph works fine. all the next works fine.
Continuing to change to the next i arrive again to "bicubic" and still works. I change to the next again ("AUTO") and again no 3d.
I hope that this help.
Regards.
Enrico.(using the build of today 18/09/2013)


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - renatoriolino - 2013-09-18

Hello,

Yesterday I tried the stereoscopic 3d mode and it is working great!! I thank you all for this great work!

I have only one request:

My TV (Philips) automatically detect 3D SBS/TAB mode only after the screen resolution/refresh rate has changed. Because of this, I enabled on XBMC to set the refresh equally to the movie.

Unfortunately it didn't worked as expected because XBMC changes the refresh rate before switching to 3D mode (or opening the popup asking which 3d mode).

Is it hard to change this, so that first the popup asking the 3d mode is showed and only then after entering in the select mode, the screen refresh is changed?

Thanks

PS: Used git master from 2013-09-16 (with openelec).


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - tommymsw - 2013-09-18

(2013-09-18, 05:27)nickr Wrote: why not .3dbd.sbs.mkv and .3dbd.ou.mkv respectively?

then add those definitions to advancedsettings.xml

The skin will see .3dbd and XBMC playback will see .3dbd.sbs or .3dbd.ou

Hmmmm. perhaps you are correct. When I used .3dbd and then .3dbd.ou, Gotham viewed them BOTH as SBS for some reason. My goal was to only have to rename the O/U movies as I only have like 4 or 5 in that format. I have a TON in SBS and didn't want to find them, rename them all, remove them from the library and the re-add them. It will be much easier from this point forward, all the work is in the renaming I think.


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - da-anda - 2013-09-18

(2013-09-18, 13:17)renatoriolino Wrote: My TV (Philips) automatically detect 3D SBS/TAB mode only after the screen resolution/refresh rate has changed. Because of this, I enabled on XBMC to set the refresh equally to the movie.

Unfortunately it didn't worked as expected because XBMC changes the refresh rate before switching to 3D mode (or opening the popup asking which 3d mode).

Is it hard to change this, so that first the popup asking the 3d mode is showed and only then after entering in the select mode, the screen refresh is changed?
We know this and we started working on it, but solution is actually not that easy (we need a way to switch the refresh rate also when toggling to stereomode while playing etc).


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - da-anda - 2013-09-18

(2013-09-18, 11:56)Lamerjack Wrote: Same problem. With amd and nvidia board. I just found that with nvidia (maybe also with amd i have to test) if go in Video Scaling Method is see that is set on Bicubic. I change to the next that is "Auto" and i have same problem. I change to the next that is "DXVA" i change to the next and anagliph works fine. all the next works fine.
Continuing to change to the next i arrive again to "bicubic" and still works. I change to the next again ("AUTO") and again no 3d.
Just to get it right - it's not working with AUTO and DXVA, others work, right? That's somewhat "expected" behaviour until we sorted this bug out.


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - usirius1 - 2013-09-20

Im trying to use the 3D mode in the most recent Gothom Monthly release. Most of my videos are half SBS, but when I select certain ones that are half SBS, XBMC auto detects it as Over Under when it is really SBS. I tell it to play SBS anyways, and it displays it incorrectly as such
Image

I apologize if this has been brought up in the thread already, but i tried looking through the thread, and I couldnt find anything about this


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - afedchin - 2013-09-20

@usirius1, change the stereo type of movies in video settings or change mkv steroscopictags. For this use mkvmerge GUI > File > Header Editor > Drag drop mkv file > Video Track > Video Stereo Mode > Add Element and enter the code


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - da-anda - 2013-09-20

@usirius1 what container format is that movie? If MKV then your headers are wrong. You can fix this like afedchin explained or you simply go to the videosettings OSD in the view you posted and override the stereomode for this particular movie.
If the movie is not a MKV, which format is it?


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - plesken - 2013-09-21

(2013-09-20, 03:42)usirius1 Wrote: Im trying to use the 3D mode in the most recent Gothom Monthly release. Most of my videos are half SBS, but when I select certain ones that are half SBS, XBMC auto detects it as Over Under when it is really SBS. I tell it to play SBS anyways, and it displays it incorrectly as such

I apologize if this has been brought up in the thread already, but i tried looking through the thread, and I couldnt find anything about this

I have the same behavior. I have run 3D movie from plugin with link like http://<host>/?k=play&id_movie=<ID>&hash=<hash>. I couldn't set half sbs to display correctly. I have no file localy, so I can't change tags, file name and etc. I think it is important bug.


Re: RE: Stereoscopic 3D support for half/full SBS, over/under, etc - nickr - 2013-09-21

(2013-09-21, 00:25)plesken Wrote:
(2013-09-20, 03:42)usirius1 Wrote: Im trying to use the 3D mode in the most recent Gothom Monthly release. Most of my videos are half SBS, but when I select certain ones that are half SBS, XBMC auto detects it as Over Under when it is really SBS. I tell it to play SBS anyways, and it displays it incorrectly as such

I apologize if this has been brought up in the thread already, but i tried looking through the thread, and I couldnt find anything about this

I have the same behavior. I have run 3D movie from plugin with link like http://<host>/?k=play&id_movie=<ID>&hash=<hash>. I couldn't set half sbs to display correctly. I have no file localy, so I can't change tags, file name and etc. I think it is important bug.

You won't get much action without a debug log.


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - Lamerjack - 2013-09-24

(2013-09-18, 15:42)da-anda Wrote:
(2013-09-18, 11:56)Lamerjack Wrote: Same problem. With amd and nvidia board. I just found that with nvidia (maybe also with amd i have to test) if go in Video Scaling Method is see that is set on Bicubic. I change to the next that is "Auto" and i have same problem. I change to the next that is "DXVA" i change to the next and anagliph works fine. all the next works fine.
Continuing to change to the next i arrive again to "bicubic" and still works. I change to the next again ("AUTO") and again no 3d.
Just to get it right - it's not working with AUTO and DXVA, others work, right? That's somewhat "expected" behaviour until we sorted this bug out.
Sorry for the delay!
I tested also on amd same issue.
Also Bibubic doesn't work... but after one menu cycle it works!
I tested also with glasses and i noticed that the the picture is not correct. Looks 2x wide and not aligned. Maybe i will try a newer build!


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - pomfpomfpomf - 2013-09-26

Hi.

This is great feature but I've got some major issues with it.

I've switched XBMC to "1920x2205 tab" resolution in settings. After that some interface images are rendered wrong (i.e. settings icon or "back" or "home" buttons). [1]

Then, when watching 2d movie its aspect ratio gets screwed [2]; 3D movie has wrong aspect ratio too (black bars at the left and right) [3] and subtitles are shrunk [4]

My "xbmc --version" output:
Code:
XBMC Media Center 13.0-ALPHA8 Git:753f414209bf921f03e16984d7b110443e13729b

Running on Gentoo Linux. Please tell me if there's additional information you need.

[1]
Image
[2]
Image
[3]
Image
[4]
Image


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - tommymsw - 2013-09-27

Yes, I have noticed the same problem. It seems as if when playing in 2d, it is no longer capable of stretching the image properly. Meaning, I think it plays the video in the original format, so if you have it set to remove the bars, or fit the screen, it can not do so while also converting to 2d. I assume this will be something they fix as time goes on?


RE: Stereoscopic 3D support for half/full SBS, over/under, etc - pomfpomfpomf - 2013-09-27

(2013-09-27, 15:12)tommymsw Wrote: Yes, I have noticed the same problem. It seems as if when playing in 2d, it is no longer capable of stretching the image properly. Meaning, I think it plays the video in the original format, so if you have it set to remove the bars, or fit the screen, it can not do so while also converting to 2d. I assume this will be something they fix as time goes on?

Video from the second screenshot is 1920x800, video from the third/fourth one is 1920x1080 half over under with "Video display height" set to 540. I don't have any options set to remove the bars and judging by those pictures it clearly doesn't play videos in original format.