Kodi Community Forum
Comskip for Linux released - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: PVR & Live TV Support (https://forum.kodi.tv/forumdisplay.php?fid=167)
+---- Forum: Tvheadend (https://forum.kodi.tv/forumdisplay.php?fid=168)
---- Thread: Comskip for Linux released (/showthread.php?tid=150084)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23


RE: Comskip for Linux released - quale - 2013-10-11

0.93e (maybe even before that, but 0.93e is the only one I tried) cannot use existing logo file - dumps core. The following "patch" fixes it (for me at least):
Code:
--- LoadSettings.cpp.orig    2013-02-03 00:25:04.000000000 -0500
+++ LoadSettings.cpp    2013-10-11 14:39:39.895963019 -0400
@@ -1580,14 +1580,17 @@
        fclose(f);
        data[len] = '\0';
        double tmp;
+        int picWidth = 0, picHeight = 0;

        if ( (tmp = FindNumber(data, "picWidth="
                , (double)_width)) > -1 )
-            _videoWidth = _width = (int)tmp;
+            picWidth = (int)tmp;

        if ( (tmp = FindNumber(data, "picHeight="
                , (double)_height)) > -1 )
-            _height = (int)tmp;
+            picHeight = (int)tmp;
+
+        setVideoSize(picHeight, picWidth, picWidth);

        if ( (tmp = FindNumber(data, "logoMinX="
                , (double) _logoRange.x.min) ) > -1 )



RE: Comskip for Linux released - cbxbiker61 - 2013-12-09

0.93f has been released with changes for deprecated parameters in ffmpeg 2.1+.


RE: Comskip for Linux released - cbxbiker61 - 2014-01-05

0.93g fixes segfault when no video codec is found (damaged video file).


RE: Comskip for Linux released - xxxnelly - 2014-01-06

Has anyone got working comskip.ini settings that work for UK channels?

I have tried a few different settings but no success.


RE: Comskip for Linux released - xxxnelly - 2014-01-17

Does no one have example settings?


RE: Comskip for Linux released - Prof Yaffle - 2014-01-17

All I can tell you is that I've struggled with the same and not succeeded. C5 works reasonably well, but chokes when they do the shrinking-the-programme-into-a-window-to-tell-you-what's-on-next trick. ITVHD is all over the place because of their idents, C4 cuts too early as they fade the DOG out and back in again.

I end up comskipping as a rough cut, then editing the EDL file by hand until I'm happy - or, increasingly, using avidemux to find the cut points and writing the EDL from scratch.


RE: Comskip for Linux released - xxxnelly - 2014-01-18

(2014-01-17, 11:03)Prof Yaffle Wrote: All I can tell you is that I've struggled with the same and not succeeded. C5 works reasonably well, but chokes when they do the shrinking-the-programme-into-a-window-to-tell-you-what's-on-next trick. ITVHD is all over the place because of their idents, C4 cuts too early as they fade the DOG out and back in again.

I end up comskipping as a rough cut, then editing the EDL file by hand until I'm happy - or, increasingly, using avidemux to find the cut points and writing the EDL from scratch.

It seems far too much effort for removing the adverts unless it is automated, I will just push the skip button Smile

What about any other countries, is this just a problem in the UK or do most have it?


RE: Comskip for Linux released - jessh - 2014-01-23

It seems that whatever I set detect_method to in comskip.ini it does not change what detection methods comskip says it is using and it always says that it is set to 43. Other settings do have an effect and it says that it is using the right ini file. Is this a known limitation or something wrong? So far I am finding that it finds very few commercials so would be nice to get it to find more.

Thanks,
Jess


RE: Comskip for Linux released - cbxbiker61 - 2014-01-25

(2014-01-23, 22:39)jessh Wrote: It seems that whatever I set detect_method to in comskip.ini it does not change what detection methods comskip says it is using and it always says that it is set to 43. Other settings do have an effect and it says that it is using the right ini file. Is this a known limitation or something wrong? So far I am finding that it finds very few commercials so would be nice to get it to find more.

Thanks,
Jess

make sure comskip.ini is in /etc/comskip/comskip.ini and modify that. you could run "strace" to verify which comskip.ini is found.


RE: Comskip for Linux released - jessh - 2014-01-25

Figured it out. This is what I had in my file:
;detect_method=43
detect_method=255

Apparently ; does not work to comment out lines and it was setting it from the first one and not the second. I would still call it a bug as there should be some way to comment out lines without having them pulled in.

~Jess


RE: Comskip for Linux released - Marx1 - 2014-01-25

Try # to comment line


RE: Comskip for Linux released - seminox - 2014-02-19

Hi @all,

i'm struggeling to compile comskip ( via cross_compile ) for a synology ds213+.
The DS213+ is a QoriQ based System.

i'm using a ubuntu32bit 12.04 virtual machine as base.

Toolchain: http://sourceforge.net/projects/dsgpl/files/DSM%204.3%20Tool%20Chains/PowerPC%20QorIQ%20Linux%202.6.32/
GPL Source: http://sourceforge.net/projects/dsgpl/files/DSM%204.1%20Tool%20Chains/PowerPC%20QorIQ%20Linux%202.6.32/gcc4374_eglibc2874_qoriq-GPL.tgz/download

i unzipped (tar xvzf *** -C) the toolchain and the gpl source to /usr/local
i unzipped the newest comskip dir /home/user/Downloads/comskip-0.93g

in the comskip path i use the following build script:
build.sh

Code:
#env
CC=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-gcc
LD=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-ld
RANLIB=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-ranlib
CFLAGS="-I/usr/local/powerpc-none-linux-gnuspe/include -mcpu=8548 -mhard-float -mfloat-gprs=double"
LDFLAGS="-L/usr/local/powerpc-none-linux-gnuspe/lib"
./configure --host=powerpc-unknown-linux --target=powerpc-unknown-linux --build=i686-pc-linux --prefix=/usr/local

running this script throws the following error:
....
checking for AVCODEC... no
configure: error: Package requirements (libavcodec >= 53.42) were not met:

No package 'libavcodec' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.
Alternatively, you may set the environment variables AVCODEC_CFLAGS and AVCODEC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

----
ok, wrong ffmpeg version. so i did:
Code:
wget http://ffmpeg.org/releases/ffmpeg-1.1.1.tar.bz2
tar xf ffmpeg-1.1.1.tar.bz2
cd ffmpeg-1.1.1
./configure --prefix=/var/tmp/ComSkipWork/ffmpeg-1.1.1-install
make -j8
make install

i assume i have to put the PKG_CONFIG_PATH for the ffmpeg install into my build script:

Code:
#env
CC=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-gcc
LD=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-ld
RANLIB=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-ranlib
CFLAGS="-I/usr/local/powerpc-none-linux-gnuspe/include -mcpu=8548 -mhard-float -mfloat-gprs=double"
LDFLAGS="-L/usr/local/powerpc-none-linux-gnuspe/lib"
PKG_CONFIG_PATH=/var/tmp/ComSkipWork/ffmpeg-1.1.1-install/lib/pkgconfig ./configure --host=powerpc-unknown-linux --target=powerpc-unknown-linux --build=i686-pc-linux --prefix=/usr/local

this finishes without errors.

when i run "make" it throws an error in line 81: missing aclocal-1.14.
WARNING: 'aclocal-1.14' is missing on your system
....


ok. the i moved "/var/tmp/ComSkipWork/ffmpeg-1.1.1-install" to "/usr/local/powerpc-none-linux-gnsupe/source/ffmpeg-1.1.1"
and put this flags into my build.sh:

Code:
AVCODEC_CFLAGS=/usr/local/powerpc-none-linux-gnsupe/source/ffmpeg-1.1.1/libavcodec/avcodec.h
AVCODEC_LIBS=/usr/local/powerpc-none-linux-gnsupe/source/ffmpeg-1.1.1/liabavcodec/libavcodec.a

and elmininated the PKG_CONFIG_PATH variable.

now build.sh looks like this:

Code:
#env
CC=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-gcc
LD=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-ld
RANLIB=/usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-ranlib
CFLAGS="-I/usr/local/powerpc-none-linux-gnuspe/include -mcpu=8548 -mhard-float -mfloat-gprs=double"
LDFLAGS="-L/usr/local/powerpc-none-linux-gnuspe/lib"
AVCODEC_CFLAGS=/usr/local/powerpc-none-linux-gnsupe/source/ffmpeg-1.1.1/libavcodec/avcodec.h
AVCODEC_LIBS=/usr/local/powerpc-none-linux-gnsupe/source/ffmpeg-1.1.1/libavcodec/libavcodec.a
./configure --host=powerpc-unknown-linux --target=powerpc-unknown-linux --build=i686-pc-linux --prefix=/usr/local

..... now i'm back to this error:
....
checking for AVCODEC... no
configure: error: Package requirements (libavcodec >= 53.42) were not met:

No package 'libavcodec' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.
Alternatively, you may set the environment variables AVCODEC_CFLAGS and AVCODEC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


can anyone help me?


RE: Comskip for Linux released - seminox - 2014-02-20

ok. i got further.

i now use this script for setting the environment variables an running the ./configure

build.sh:
Code:
#env
export DS_TOOLCHAIN_ROOT=/usr/local/powerpc-none-linux-gnuspe
export PATH="$DS_TOOLCHAIN_ROOT/bin:/usr/local/bin:/usr/bin:/bin"      #:$PATH
export CC="$DS_TOOLCHAIN_ROOT/bin/powerpc-none-linux-gnuspe-gcc -I$DS_TOOLCHAIN_ROOT/include -I/usr/local/include -L$DS_TOOLCHAIN_ROOT/lib -L/usr/local/lib"
export CXX=$DS_TOOLCHAIN_ROOT/bin/powerpc-none-linux-gnuspe-g++
export CPP=$DS_TOOLCHAIN_ROOT/bin/powerpc-none-linux-gnuspe-cpp
export CPPFLAGS="-I/usr/local/include -I$DS_TOOLCHAIN_ROOT/include"
export LD=$DS_TOOLCHAIN_ROOT/bin/powerpc-none-linux-gnuspe-ld
export RANLIB=$DS_TOOLCHAIN_ROOT/bin/powerpc-none-linux-gnuspe-ranlib
export CFLAGS="-I$DS_TOOLCHAIN_ROOT/include -I/usr/local/include -mcpu=8548 -mhard-float -mfloat-gprs=double"
export LDFLAGS="-L/usr/local/lib -L$DS_TOOLCHAIN_ROOT/lib"
export LD_LIBRARY_PATH=/usr/local/lib
export LD_RUN_PATH=/usr/local/lib
export LUA_CFLAGS="-I/usr/local/include"
export LUA_LIBS="-L/usr/local/lib"
export LIBCURL_CPPFLAGS="-I/usr/local/include"
export LIBCURL="-L/usr/local/lib"
export PKG_CONFIG_LIBDIR=/usr/local/lib
export LIBS="-L/usr/local/lib -L$DS_TOOLCHAIN_ROOT/lib -llua"    #-Lmysqlclient_r
export PKG_CONFIG=/usr/bin
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"
export AVCODEC_CFLAGS="/usr/local/powerpc-none-linux-gnuspe/source/ffmpeg-1.1.1/libavcodec/avcodec.h"
export AVCODEC_LIBS="/usr/local/powerpc-none-linux-gnuspe/source/ffmpeg-1.1.1/libavcodec/libavcodec.a"
export AVFORMAT_CFLAGS="/usr/local/powerpc-none-linux-gnuspe/source/ffmpeg-1.1.1/libavformat/avformat.h"
export AVFORMAT_LIBS="/usr/local/powerpc-none-linux-gnuspe/source/ffmpeg-1.1.1/libavformat/libavformat.a"
export AVUTIL_CFLAGS="/usr/local/powerpc-none-linux-gnuspe/source/ffmpeg-1.1.1/libavutil/avutil.h"
export AVUTIL_LIBS="/usr/local/powerpc-none-linux-gnuspe/source/ffmpeg-1.1.1/libavutil/libavutil.a"
export ARGTABLE2_CFLAGS="/home/marco/Downloads/argtable2-13/src/argtable2.h"
export ARGTABLE2_LIBS="/home/marco/Downloads/argtable2-13/src/.libs/libargtable2.a"
./configure --host=powerpc-none-linux-gnuspe --target=powerpc-none-linux-gnuspe --prefix=/usr/local

which runs fine. here is the output:
Code:
[email protected]:~/Downloads/comskip-0.93g$ ./build.sh
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for powerpc-none-linux-gnuspe-strip... powerpc-none-linux-gnuspe-strip
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for style of include used by make... GNU
checking for powerpc-none-linux-gnuspe-gcc... /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-gcc -I/usr/local/powerpc-none-linux-gnuspe/include -I/usr/local/include -L/usr/local/powerpc-none-linux-gnuspe/lib -L/usr/local/lib
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... yes
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-gcc -I/usr/local/powerpc-none-linux-gnuspe/include -I/usr/local/include -L/usr/local/powerpc-none-linux-gnuspe/lib -L/usr/local/lib accepts -g... yes
checking for /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-gcc -I/usr/local/powerpc-none-linux-gnuspe/include -I/usr/local/include -L/usr/local/powerpc-none-linux-gnuspe/lib -L/usr/local/lib option to accept ISO C89... none needed
checking whether /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-gcc -I/usr/local/powerpc-none-linux-gnuspe/include -I/usr/local/include -L/usr/local/powerpc-none-linux-gnuspe/lib -L/usr/local/lib understands -c and -o together... yes
checking dependency style of /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-gcc -I/usr/local/powerpc-none-linux-gnuspe/include -I/usr/local/include -L/usr/local/powerpc-none-linux-gnuspe/lib -L/usr/local/lib... gcc3
checking how to run the C preprocessor... /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-cpp
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether we are using the GNU C++ compiler... yes
checking whether /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-g++ accepts -g... yes
checking dependency style of /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-g++... gcc3
checking for gawk... (cached) mawk
checking how to run the C preprocessor... /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-cpp
checking for size_t... yes
checking for working alloca.h... yes
checking for alloca... yes
checking for ANSI C header files... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for strings.h... (cached) yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for stdbool.h that conforms to C99... yes
checking for _Bool... yes
checking whether /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-g++ supports C++11 features by default... no
checking whether /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-g++ supports C++11 features with -std=gnu++11... no
checking whether /usr/local/powerpc-none-linux-gnuspe/bin/powerpc-none-linux-gnuspe-g++ supports C++11 features with -std=gnu++0x... no
configure: No compiler with C++11 support was found
checking for stdlib.h... (cached) yes
checking for GNU libc compatible malloc... no
checking whether lstat correctly handles trailing slash... no
checking whether stat accepts an empty string... yes
checking for memset... yes
checking for strerror... yes
checking pkg-config is at least version 0.9.0... ./configure: line 5947: /usr/bin: Is a directory
no
checking for AVCODEC... yes
checking for AVFORMAT... yes
checking for AVUTIL... yes
checking for ARGTABLE2... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
[email protected]:~/Downloads/comskip-0.93g$

but when i run "make -j8" i get the following:
Code:
[email protected]:~/Downloads/comskip-0.93g$ make -j8
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash /home/marco/Downloads/comskip-0.93g/missing aclocal-1.14 -I m4
/home/marco/Downloads/comskip-0.93g/missing: Zeile 81: aclocal-1.14: Kommando nicht gefunden.
WARNING: 'aclocal-1.14' is missing on your system.
         You should only need it if you modified 'acinclude.m4' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'aclocal' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
make: *** [aclocal.m4] Fehler 127
[email protected]:~/Downloads/comskip-0.93g$

could anyone help me please?

maybe there is somebody out there with a working build environment for the DS213+ that can compile a working binary of comskip for me?

thanx in advance.....


RE: Comskip for Linux released - schumi2004 - 2014-02-20

@seminox
This is the latest i received from @aisman https://app.box.com/s/eft4u1p7lbk5rkifj4pp


RE: Comskip for Linux released - seminox - 2014-02-20

thanx for your help,
but the ds213+ is not based on arm cpu. It is a Freescale QorIQ P1022 (PowerPC)

So this is not usable for me.


This forum uses Lukasz Tkacz MyBB addons.