Kodi Community Forum
Tvheadend can't find tuner card - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: PVR & Live TV Support (https://forum.kodi.tv/forumdisplay.php?fid=167)
+---- Forum: Tvheadend (https://forum.kodi.tv/forumdisplay.php?fid=168)
---- Thread: Tvheadend can't find tuner card (/showthread.php?tid=151039)



Tvheadend can't find tuner card - Billzilla - 2013-01-06

I've built a new HTPC box and am having a lot of trouble getting the tuner card to work.
It's a Hauppauge HVR-2210 and it seems to be detected okay - using Putty I get this -

[ 14.509355] tveeprom 9-0000: Hauppauge model 89009, rev D3F2, serial# 795782
[ 14.509357] tveeprom 9-0000: MAC address is 00:0d:fe:79:6d:3c
[ 14.509358] tveeprom 9-0000: tuner model is NXP 18271C2_716x (idx 152, type )
[ 14.509360] tveeprom 9-0000: TV standards PAL(B/G) NTSC(M) PAL(I) SECAM(L/L' PAL(D/D1/K) ATSC/DVB Digital (eeprom 0xfc)
[ 14.509361] tveeprom 9-0000: audio processor is SAA7164 (idx 43)
[ 14.509362] tveeprom 9-0000: decoder processor is SAA7164 (idx 40)
[ 14.509363] tveeprom 9-0000: has radio, has IR receiver, has no IR transmittr
[ 14.509364] saa7164[0]: Warning: Unknown Hauppauge model #89009
[ 14.509364] saa7164[0]: Hauppauge eeprom: model=89009
[ 14.566970] tda18271 10-0060: creating new instance
[ 14.571824] TDA18271HD/C2 detected @ 10-0060
[ 14.810580] DVB: registering new adapter (saa7164)
[ 14.810583] DVB: registering adapter 0 frontend 0 (NXP TDA10048HN DVB-T)...
[ 14.841271] tda18271 11-0060: creating new instance
[ 14.846049] TDA18271HD/C2 detected @ 11-0060
[ 15.079816] tda18271: performing RF tracking filter calibration
[ 17.369684] tda18271: RF tracking filter calibration complete
[ 17.370024] DVB: registering new adapter (saa7164)
[ 17.370027] DVB: registering adapter 1 frontend 0 (NXP TDA10048HN DVB-T)...
[ 1246.273551] nvidia: module license 'NVIDIA' taints kernel.
[ 1246.273554] Disabling lock debugging due to kernel taint
[ 1246.279834] NVRM: No NVIDIA graphics adapter found!
[ 1280.970521] NVRM: No NVIDIA graphics adapter found!
[ 2427.298447] hda-intel: Unstable LPIB (65496 >= 4368); disabling LPIB delay cunting
[ 2477.795319] NVRM: No NVIDIA graphics adapter found!
[ 2489.742353] NVRM: No NVIDIA graphics adapter found!


And also this -

root ~ # ls -lR /dev/dvb
/dev/dvb:
total 0
drwxr-xr-x 2 root root 120 Jan 6 06:07 adapter0
drwxr-xr-x 2 root root 120 Jan 6 06:07 adapter1

/dev/dvb/adapter0:
total 0
crw-rw---- 1 root video 212, 4 Jan 6 06:07 demux0
crw-rw---- 1 root video 212, 5 Jan 6 06:07 dvr0
crw-rw---- 1 root video 212, 3 Jan 6 06:07 frontend0
crw-rw---- 1 root video 212, 7 Jan 6 06:07 net0

/dev/dvb/adapter1:
total 0
crw-rw---- 1 root video 212, 68 Jan 6 06:07 demux0
crw-rw---- 1 root video 212, 69 Jan 6 06:07 dvr0
crw-rw---- 1 root video 212, 67 Jan 6 06:07 frontend0
crw-rw---- 1 root video 212, 71 Jan 6 06:07 net0

But when I access tvheadend through my browser it just will not show the tuner card.

Everything else seems to work okay but I really need the tuner card to work, any ideas please??


RE: Tvheadend can't find tuner card - Billzilla - 2013-01-07

I've also turned the box off, removed the card, turned it back on and run it for a while then off again, then re-installed the card.
No difference.

Please guys, I really need help here!


RE: Tvheadend can't find tuner card - adamsutton - 2013-01-07

Better to post TVH specific issues (rather than TVH-XBMC integration) on lonelycoder.com.

Adam


RE: Tvheadend can't find tuner card - Billzilla - 2013-01-07

Ta.
I asked about the problem on another forum and got this reply -

lem post=60204 Wrote:Seems to be issues with the linux driver for these cards.
Open case on GitHub
https://github.com/OpenELEC/OpenELEC.tv/issues/1349

Also suggests that some firmware files have been removed from the build.

Is there a way around it or a solution coming soon? I'm very inexperienced with Linux, etc, so I really don't know how to fix much myself.


RE: Tvheadend can't find tuner card - Billzilla - 2013-01-08

Okay I found this -
https://github.com/OpenELEC/OpenELEC.tv/issues/340

And ...

https://github.com/OpenELEC/dvb-firmware/pull/3

And ...

https://github.com/OpenELEC/OpenELEC.tv/commit/2352fd1d9b254d012da6dc45f77f4e010c6dbe08

I don't understand much of that, did that guy find a solution? If so how do I do it as well please?


RE: Tvheadend can't find tuner card - Billzilla - 2013-01-09

I give up, I'm going to have to use Windows. Sad


This forum uses Lukasz Tkacz MyBB addons.