Kodi Community Forum
[RELEASE] Movie Set Artwork Automator - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=151)
---- Thread: [RELEASE] Movie Set Artwork Automator (/showthread.php?tid=153502)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38


RE: [RELEASE] Movie Set Artwork Automator - Milhouse - 2013-11-09

I couldn't install v0.2.0 in latest Gotham master (OpenELEC on Pi, built from git) - kept getting the following error:
Code:
Addon script.moviesetart requires xbmc.python version 2.0 which is not available
which I'm assuming is some sort of bug in Gotham as the addon appears to have a valid dependency:
Code:
<requires>
    <import addon="xbmc.python" version="2.0"/>
  </requires>

I'd have thought that if the addon requires xbmc.python version 2.0, then this dependency should be met in Frodo and Gotham (xbmc.python version 2.1.0 and 2.12.0 respectively). If not I guess that's going to break a lot of addons unnecessarily.

Anyway I tried different versions ("2.1", "2.1.0", "2.12" and "2.12.0") but none worked - now got an invalid structure error - so in the end I just removed the above <requires> from addon.xml and the addon installed without a problem...

Obviously Gotham is under heavy development, but this is just a heads up... not sure what's going on. Smile


RE: [RELEASE] Movie Set Artwork Automator - Martijn - 2013-11-09

(2013-11-09, 02:12)MilhouseVH Wrote: I couldn't install v0.2.0 in latest Gotham master (OpenELEC on Pi, built from git) - kept getting the following error:
Code:
Addon script.moviesetart requires xbmc.python version 2.0 which is not available
which I'm assuming is some sort of bug in Gotham as the addon appears to have a valid dependency:
Code:
<requires>
    <import addon="xbmc.python" version="2.0"/>
  </requires>

I'd have thought that if the addon requires xbmc.python version 2.0, then this dependency should be met in Frodo and Gotham (xbmc.python version 2.1.0 and 2.12.0 respectively). If not I guess that's going to break a lot of addons unnecessarily.

Anyway I tried different versions ("2.1", "2.1.0", "2.12" and "2.12.0") but none worked - now got an invalid structure error - so in the end I just removed the above <requires> from addon.xml and the addon installed without a problem...

Obviously Gotham is under heavy development, but this is just a heads up... not sure what's going on. Smile
easy
it should just be 2.1.0 and they should update the addon.xml and submit to repo


RE: [RELEASE] Movie Set Artwork Automator - Milhouse - 2013-11-09

2.1.0 didn't work (no error in the log, just got a notification that the addon had an invalid structure, which was also weird), but why shouldn't it still work with 2.0? Isn't a dependency on 2.0 saying "2.0 and above"?


RE: [RELEASE] Movie Set Artwork Automator - Martijn - 2013-11-09

gotham is 2.1.0 and above. this was already announced a year ago that it should become 2.1.0 even for Frodo


RE: [RELEASE] Movie Set Artwork Automator - Milhouse - 2013-11-09

OK, one for trentf I guess, but as I said, 2.1.0 wasn't working... everything but 2.0 gave an invalid structure error, and 2.0 gave unmet dependency, only removing the requires worked! Smile


RE: [RELEASE] Movie Set Artwork Automator - Martijn - 2013-11-09

(2013-11-09, 02:23)MilhouseVH Wrote: OK, one for trentf I guess, but as I said, 2.1.0 wasn't working... everything but 2.0 gave an invalid structure error, and 2.0 gave unmet dependency, only removing the requires worked! Smile

then you did something wrong as most addons in repo have 2.1.0 Smile


RE: [RELEASE] Movie Set Artwork Automator - Milhouse - 2013-11-09

Must have done, dunno what though - just changed the version string! Smile


RE: [RELEASE] Movie Set Artwork Automator - trentf - 2013-11-09

(2013-11-09, 02:12)MilhouseVH Wrote: I couldn't install v0.2.0 in latest Gotham master (OpenELEC on Pi, built from git) - kept getting the following error:

Anyway I tried different versions ("2.1", "2.1.0", "2.12" and "2.12.0") but none worked - now got an invalid structure error - so in the end I just removed the above <requires> from addon.xml and the addon installed without a problem...

Thanks for the investigative work. I have followed your advice and just commented out the dependency for now.


RE: [RELEASE] Movie Set Artwork Automator - JustSomeGuy - 2013-11-20

(2013-01-30, 00:03)trentf Wrote: Ok, it may be that the new thumbnail caching system in Frodo isn't 100% reliable (and I just got lucky in my testing, you didn't), and the script should still overwrite the thumbnail cache files as well as updating the video database.

Could you try removing the example thumbnail files (D:\Home Theatre\XBMC\portable_data\userdata\Thumbnails\Video\a\ad882f00.tbn and D:\Home Theatre\XBMC\portable_data\userdata\Thumbnails\Video\Fanart\ad882f00.tbn), restart XBMC and see if the new poster appears?

If it does, I will update the script to overwrite those files. If it still doesn't work, i might need to remove the reference to the image filename from the texture cache db.

When you change the contents of the correctly-named file which was used previously to set the collection art then rerun the add-on, the art does not change. I looked in the Thumbnail cache and the file is still the same there. I think this may be the same as above, just a different data point; but just in case it's helpful, I'm noting it.

Actually, I find changing the contents of the previously used file and setting the fan art using the GUI also does not work; so there is something wrong with the mechanism used to update the cache. The add-on may be able to work around it by deleting the cache where the GUI remains broken.

Apparently this is a known issue as noted in the Wiki So maybe the add-on can just do the same thing automatically.


RE: [RELEASE] Movie Set Artwork Automator - Redox - 2013-11-23

Hi everyone and sorry in advance for any mistakes in English. I'm French.

I am trying to use this amazing script but I have encountered a little issue. I am running Windows 7 and XMBC Frodo 12.2.

First of all, the structure of my set movie:

Movie/Back To The Future Collection/poster.jpg
Movie/Back To The Future Collection/fanart.jpg
Movie/Back To The Future Collection/Back To The Future I/Back To The Future I.mkv
Movie/Back To The Future Collection/Back To The Future II/Back To The Future II.mkv
Movie/Back To The Future Collection/Back To The Future III/Back To The Future III.mkv

The thing is when I start XBMC and I go to the Movie section (I am using Confluence theme) I don't see the poster and the fanart for the movie set. I see only the poster and fanart for the first movie.
But if I go to the Video section (file mode where we add sources) I can see these pictures.

I don't understand why... What is wrong ?
If you need any further information I'll make some screenshots.

Thanks a lot !


RE: [RELEASE] Movie Set Artwork Automator - saitoh183 - 2013-11-23

screenshot of your config window for Automator


RE: [RELEASE] Movie Set Artwork Automator - Redox - 2013-11-24

Thanks ! Here is the screenshot :


Image

If I click on Artworks Source (Source des Artowrks) nothing happens.


Re: [RELEASE] Movie Set Artwork Automator - saitoh183 - 2013-11-24

Your file needs to be the collection name that the collection is called in XBMC.
<collection name>-poster.jpg


RE: [RELEASE] Movie Set Artwork Automator - Milhouse - 2013-11-24

(2013-11-24, 04:24)saitoh183 Wrote: Your file needs to be the collection name that the collection is called in XBMC.
<collection name>-poster.jpg

No, folder.jpg and fanart.jpg should work given his folder layout, which probably means his filenames are not configured correctly in MSAA (his screenshot unfortunately chops all of that off)

Might it be that he has MSAA configured to look for poster.jpg, when he is in fact using folder.jpg?

Changing the Poster setting to "poster.jpg, folder.jpg" should then work. Not sure what he has for fanart.jpg though, and I' ve no idea what "Pochette" is either - Google translate tells me it's "wallet"... Smile

@Redox: Posting another screenshot with the second (bottom) half of the settings would be helpful.

(2013-11-24, 00:04)Redox Wrote: If I click on Artworks Source (Source des Artowrks) nothing happens.

Nothing is meant to happen, it's just a tab with the name of the current settings panel (of which there is only one panel, and one tab...)


[RELEASE] Movie Set Artwork Automator - MaxCore - 2013-11-24

(2013-11-24, 04:35)MilhouseVH Wrote:
(2013-11-24, 04:24)saitoh183 Wrote: Your file needs to be the collection name that the collection is called in XBMC.
<collection name>-poster.jpg

No, folder.jpg and fanart.jpg should work given his folder layout, which probably means his filenames are not configured correctly in MSAA (his screenshot unfortunately chops all of that off)

Might it be that he has MSAA configured to look for poster.jpg, when he is in fact using folder.jpg?

Changing the Poster setting to "poster.jpg, folder.jpg" should then work. Not sure what he has for fanart.jpg though, and I' ve no idea what "Pochette" is either - Google translate tells me it's "wallet"... Smile

@Redox: Posting another screenshot with the second (bottom) half of the settings would be helpful.

(2013-11-24, 00:04)Redox Wrote: If I click on Artworks Source (Source des Artowrks) nothing happens.

Nothing is meant to happen, it's just a tab with the name of the current settings panel (of which there is only one panel, and one tab...)

Pochette = cover case


This forum uses Lukasz Tkacz MyBB addons.