Kodi Community Forum
[RELEASE] Movie Set Artwork Automator - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=151)
---- Thread: [RELEASE] Movie Set Artwork Automator (/showthread.php?tid=153502)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38


RE: [RELEASE] Movie Set Artwork Automator - isamu.dragon - 2014-06-02

(2014-05-22, 17:23)masterziggy Wrote: Hi;
Is possible add extrafanart1 for the background of moviesets cas?
Thanks!

(2014-05-22, 17:38)MilhouseVH Wrote: Pretty sure extrafanart is just a directory of fanart relative to a parent directory.that skins know to look for, there is nothing written to the media library db so not sure what this addon is supposed to do.

I created a modded version of the script to automatically add extrafanart1, however I have it set to default to the "fanart.jpg" in your set directory. You can change the file name to look for in the settings menu
script.moviesetart.frodo.0.2.2-Extrafanart1.Mod


RE: [RELEASE] Movie Set Artwork Automator - brazen1 - 2014-06-02

Posted this elsewhere and realized I should be posting here.


isamu.dragon/trentf

Thank you for the mod. I have installed it.
I am clearly doing something wrong? Hoping someone can help me.
Artwork is not added unless I do it manually. I assume this add-on is supposed to automate?

I do not have special folders for sets. I simply have XBMC 'Group movies in sets' selected and it does group them.
So now I want to add artwork for those sets and I'm using this add-on. I config Movie Set Artwork Automator. For example: Fanart is set to default fanart.jpg. Common parent folder selected/forced update. I launch it and it asks do I want to update. Yes. After running it returns with found artwork, made updates. I go to a 'Movie Set'. Manage/choose art/ and the only thing added is the poster. I have the option to select fanart for example, which is empty. Browse/item folder/ and there are 3 fanart.jpg's. I manually select one of them, and now I have fanart. Wasn't this add-on supposed to do that for me? The same holds true for all the other artwork which is also available and name configured proper in the add-on. Banner, extrafanart, clearart, clearlogo they are all blank unless I manually select them and add them myself. I changed extrafanart default fanart.jpg to fanart1.jpg just like it is in my local art and nothing happens. I'm sure it works perfect for you and everyone else. Any idea what I could be doing wrong? I suspect in order for this to work, my movies have to be grouped in a 'Collection' folder? I don't want to group my movies. I like them separate and the fact that XBMC groups them for me without having to make special folders and move things around. If that is the case, will this ever work without special grouping?


RE: [RELEASE] Movie Set Artwork Automator - isamu.dragon - 2014-06-02

for the addon to work correctly (Stock or Modded Versions), you need the following file style
Code:
Set Directory\Movie Directory\Movie File.ext
or for visual Example (I have the file inlay.jpg for the extrafanart1)
Image


RE: [RELEASE] Movie Set Artwork Automator - brazen1 - 2014-06-02

Got it. Needs to have special folders for collections grouped inside, exactly what I want to avoid. That explains it. Thanks for the clarification.


RE: [RELEASE] Movie Set Artwork Automator - trentf - 2014-06-04

(2014-06-02, 19:58)brazen1 Wrote: Got it. Needs to have special folders for collections grouped inside, exactly what I want to avoid. That explains it. Thanks for the clarification.

That is not true. You can have organise your video files anyway you like and then use a single artwork folder that prefixes artwork with the collection name.

Example in original post.
\Blu-ray\Alien\Alien (1979) [BDRip] [1080p] [q18] [FLAC].mkv
\Blu-ray\Aliens\Aliens (1986) [BDRip] [1080p] [q20] [FLAC].mkv
\Blu-ray\Artwork\Alien Anthology-fanart.jpg
\Blu-ray\Artwork\Alien Anthology-folder.jpg


RE: [RELEASE] Movie Set Artwork Automator - brazen1 - 2014-06-04

(2014-06-04, 00:39)trentf Wrote:
(2014-06-02, 19:58)brazen1 Wrote: Got it. Needs to have special folders for collections grouped inside, exactly what I want to avoid. That explains it. Thanks for the clarification.

That is not true. You can have organise your video files anyway you like and then use a single artwork folder that prefixes artwork with the collection name.

Example in original post.
\Blu-ray\Alien\Alien (1979) [BDRip] [1080p] [q18] [FLAC].mkv
\Blu-ray\Aliens\Aliens (1986) [BDRip] [1080p] [q20] [FLAC].mkv
\Blu-ray\Artwork\Alien Anthology-fanart.jpg
\Blu-ray\Artwork\Alien Anthology-folder.jpg

I can be pretty ignorant at times but I still think I have to create special folders?
For example:

Alien (1979) is on 1 HDD. (E:/Movies1/Alien (1979)/Alien (1979).avi + all the artwork)
Aliens (1986) is on 2nd HDD. (F:/Movies2/Aliens (1986)/Aliens (1986).avi + all the artwork)
XBMC/Videos - Settings/Library/Group movies in sets (Now I have sets that need artwork applied)

It's my understanding I have 4 options:

I can manually select each and every single type of artwork and I have to start the process from the very beginning each and every time. Movies/Movie Sets/Manage/Choose art/Fanart/Browse/*Item folder/Scroll/select 1 of various fanart.jpg's and then to add a banner for the same set I can start this exact process over again until the set has all the artwork applied. About 6 times. Tedious.

I can create a new folder called Alien Collection. Provided there is enough free space to cut and paste the various folders/movies/artworks/nfo's etc. into it, I can begin chopping up my library(s). Then I could use this add-on.

I can create a folder called Movie Set Artwork. I can create dummy folders inside this new folder and be sure to name them Alien Collection and so on. Then I can use this add-on.

I can enjoy movie sets with no artwork.

Please share if I've missed any other option and thank you for the input I have received.

XMBC creates the sets and caches the artwork after I manually enter them and I don't have to do anything like create special folders or shuffle movies around into more special folders. My laziness gravitated to this add-on with high expectations thinking the manual part would be automatic. I think it was the name of the add-on that grabbed my attention and efforts. Movie Set Artwork Automator.


RE: [RELEASE] Movie Set Artwork Automator - trentf - 2014-06-05

(2014-06-04, 19:19)brazen1 Wrote: I can manually select each and every single type of artwork and I have to start the process from the very beginning each and every time. Movies/Movie Sets/Manage/Choose art/Fanart/Browse/*Item folder/Scroll/select 1 of various fanart.jpg's and then to add a banner for the same set I can start this exact process over again until the set has all the artwork applied. About 6 times. Tedious.

I can create a new folder called Alien Collection. Provided there is enough free space to cut and paste the various folders/movies/artworks/nfo's etc. into it, I can begin chopping up my library(s). Then I could use this add-on.

I can create a folder called Movie Set Artwork. I can create dummy folders inside this new folder and be sure to name them Alien Collection and so on. Then I can use this add-on.

I can enjoy movie sets with no artwork.

You don't need to call the artwork folder "Movie Set Artwork" (configured in settings), and you don't need subfolders. But you do need a folder of artwork if you want to use this addon and have unstructured movie collections. If you are looking for a scraper to find the artwork in the first place, you need to find something else.


RE: [RELEASE] Movie Set Artwork Automator - brazen1 - 2014-06-05

(2014-06-05, 05:36)trentf Wrote:
(2014-06-04, 19:19)brazen1 Wrote: I can manually select each and every single type of artwork and I have to start the process from the very beginning each and every time. Movies/Movie Sets/Manage/Choose art/Fanart/Browse/*Item folder/Scroll/select 1 of various fanart.jpg's and then to add a banner for the same set I can start this exact process over again until the set has all the artwork applied. About 6 times. Tedious.

I can create a new folder called Alien Collection. Provided there is enough free space to cut and paste the various folders/movies/artworks/nfo's etc. into it, I can begin chopping up my library(s). Then I could use this add-on.

I can create a folder called Movie Set Artwork. I can create dummy folders inside this new folder and be sure to name them Alien Collection and so on. Then I can use this add-on.

I can enjoy movie sets with no artwork.

You don't need to call the artwork folder "Movie Set Artwork" (configured in settings), and you don't need subfolders. But you do need a folder of artwork if you want to use this addon and have unstructured movie collections. If you are looking for a scraper to find the artwork in the first place, you need to find something else.

Thank you for helping me. I don't understand your suggestion? Forgive me.
Indeed, I do not have structured collections. I have setting in XBMC to group movies in sets enabled.

"But you do need a folder of artwork if you want to use this addon and have unstructured movie collections". Ok. So I created this folder. I simply named the folder 'Movie Set Artwork'. I went to the add-on config and pointed it to this folder. Inside this folder I created a subfolder and named it Alien Collection. But you write "You don't need to call the artwork folder "Movie Set Artwork" (configured in settings), and you don't need subfolders." Ok. Now my confusion starts.

"If you are looking for a scraper to find the artwork in the first place, you need to find something else." I'm not looking for a scraper? All my artwork is already inside each folder alongside my title. My structure is:
Root of drive
Folder named Movies
Subfolders named by title containing titles and artwork.

Are you assuming ALL my artwork for ALL my titles is in 1 common folder already? It's not. I export 'Separate files' and scrape to individual folders containing title.

Would you be kind enough to explain in more detail the proper way this add-on can work for me? As you can see..... I'm completely lost.


RE: [RELEASE] Movie Set Artwork Automator - trentf - 2014-06-06

(2014-06-05, 16:55)brazen1 Wrote: "If you are looking for a scraper to find the artwork in the first place, you need to find something else." I'm not looking for a scraper? All my artwork is already inside each folder alongside my title. My structure is:
Root of drive
Folder named Movies
Subfolders named by title containing titles and artwork.

Are you assuming ALL my artwork for ALL my titles is in 1 common folder already? It's not. I export 'Separate files' and scrape to individual folders containing title.

Would you be kind enough to explain in more detail the proper way this add-on can work for me? As you can see..... I'm completely lost.

What I meant by unstructured was not having all the movies that form a set or collection, under a parent folder for that set. You say you already have all the artwork inside each folder for each title. But that is individual movie artwork, where do you have the poster/fanart artwork for the movie set itself?

My point about not being a scraper was referring to the fact that it can't fetch the movie set artwork that is not normally fetched by XBMC like it does for individual movie artwork. You need to download that yourself. This addon just helps finding it on the file system and assigning it to the sets in XBMC.


RE: [RELEASE] Movie Set Artwork Automator - ThePaPa - 2014-06-14

Hi,
I'm using Xbmc Gotham 13.1 with the Aeon MQ5 skin and i would like to change the artworks of my movie sets.

So, I tried to install the add-on.

But when I launch it, it says "0 artworks found for sets, database updated 0 times"

Image

Is there a solution to my problem?

Thanks in advance


RE: [RELEASE] Movie Set Artwork Automator - Milhouse - 2014-06-14

(2014-06-14, 15:57)ThePaPa Wrote: Is there a solution to my problem?

Post a debug log (wiki) including the period when you run MSAA. Ensure that JSON component debugging is enabled.


RE: [RELEASE] Movie Set Artwork Automator - ThePaPa - 2014-06-14

Here it is


RE: [RELEASE] Movie Set Artwork Automator - Milhouse - 2014-06-14

Nope, nothing there.


RE: [RELEASE] Movie Set Artwork Automator - ThePaPa - 2014-06-15

(2014-06-14, 17:20)MilhouseVH Wrote: Nope, nothing there.

Sorry, fail.

I launched xbmc then I ran the add-on, here is the log file:

http://uploaded.net/file/kmel2cgw


RE: [RELEASE] Movie Set Artwork Automator - Milhouse - 2014-06-15

Pleasure use xbmclogs.com or pastebin.com.


This forum uses Lukasz Tkacz MyBB addons.