Kodi Community Forum
Release Picture Slideshow Screensaver - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Look and feel (https://forum.kodi.tv/forumdisplay.php?fid=178)
---- Thread: Release Picture Slideshow Screensaver (/showthread.php?tid=154032)



RE: [Release] Picture Slideshow Screensaver - willemd - 2015-11-03

Hehe, maybe I've had that notification, but you know: don't fix if not broken. It still worked. Wink


But just to be clear: it seems Kodi gives the exact same message with the new addon.


RE: [Release] Picture Slideshow Screensaver - ronie - 2015-11-04

thanx, confirmed!

i've created a bugreport for it:
http://trac.kodi.tv/ticket/16361


RE: [Release] Picture Slideshow Screensaver - kasmca - 2015-11-05

I have a weird problem with this screensaver. I have been using it without any problems for months but a few weeks back instead of showing my image folder pictures, it started showing video fan art instead. I noticed that if I go to the advanced tab and turn off "Create Image Index" it will work, but it takes 3-4 minutes to build the index on the fly before it will show my pictures. My images are accessed through an SMB windows drive. When I turn on "Create Image Index" and I try to update the index and it only takes a couple of seconds so I don't think it really worked. Again, it reverts back to showing Video Fan Art instead, even though the source is set to Image folder.

I have an identical set up on a different system and it doesn't have any problems.


RE: [Release] Picture Slideshow Screensaver - ronie - 2015-11-06

(2015-11-05, 23:57)kasmca Wrote: I have a weird problem with this screensaver. I have been using it without any problems for months but a few weeks back instead of showing my image folder pictures, it started showing video fan art instead. I noticed that if I go to the advanced tab and turn off "Create Image Index" it will work, but it takes 3-4 minutes to build the index on the fly before it will show my pictures. My images are accessed through an SMB windows drive. When I turn on "Create Image Index" and I try to update the index and it only takes a couple of seconds so I don't think it really worked. Again, it reverts back to showing Video Fan Art instead, even though the source is set to Image folder.

I have an identical set up on a different system and it doesn't have any problems.

can you go to ../userdata/addon_data/screensaver.picture.slideshow
there's should be two files, 'settings.xml' and a random hex 'abc123456789def' one.
please pastebin the contents of both.


RE: [Release] Picture Slideshow Screensaver - kasmca - 2015-11-06

Here is the log. I will try to get the contents of those 2 files

http://xbmclogs.com/paefy4g2t


RE: [Release] Picture Slideshow Screensaver - ronie - 2015-11-06

(2015-11-06, 00:12)kasmca Wrote: Here is the log. I will try to get the contents of those 2 files

http://xbmclogs.com/paefy4g2t

thanx but that's a normal log. i need a Debug Log please.


RE: [Release] Picture Slideshow Screensaver - kasmca - 2015-11-06

There were actually 4 files that had random hex names. I deleted them all and went back to the screensaver settings, clicked preview and then it rebuilt the proper index and now everything is fine.


RE: [Release] Picture Slideshow Screensaver - bvisick - 2015-11-08

Hi,

I can't get the screen saver (v2.1.9) to show pictures from my Synology NAS. I can navigate to the folder on the NAS when I set the image file source but the screensaver just gives me a blank screen with a large spinning wheel in preview (or when it runs). It does work OK if I point it at a folder on the SD card and I can see the images on the NAS from the main Pictures menu.

I've tried creating and updating the image index: when it is set to look in a local folder the file with a random hex name contains each file name in [ ], when I try to use the NAS the corresponding file is just 2 bytes long and contains only [].

Debug log posted at http://pastebin.com/rC5Uxp36

I'd be grateful for any help! Thanks.


RE: [Release] Picture Slideshow Screensaver - ronie - 2015-11-08

(2015-11-08, 20:31)bvisick Wrote: I've tried creating and updating the image index: when it is set to look in a local folder the file with a random hex name contains each file name in [ ], when I try to use the NAS the corresponding file is just 2 bytes long and contains only [].

Debug log posted at http://pastebin.com/rC5Uxp36

hmmm.. nothing in the log that would indicate an issue.

if you get an index file with just '[]' it means the screensaver wasn't able to fetch a directory listing from your nas.
is the share password protected perhaps?


RE: [Release] Picture Slideshow Screensaver - Hitcher - 2015-11-08

You might want to try a newer build with this fix -

https://github.com/xbmc/xbmc/pull/8349


RE: [Release] Picture Slideshow Screensaver - bvisick - 2015-11-09

Thanks both for the quick replies.

Seeing Ronie's comment about shares and passwords I thought perhaps I was being optimistic thinking that I could use a UPNP source since that doesn't have either. I mounted the NAS directory on the RPi instead and it's working fine now. Thanks for the hint and the great screensaver.


RE: [Release] Picture Slideshow Screensaver - s9607571m - 2015-11-15

Hi Ronie and Developers,

Using this plugin for a photo display on a Wall mounted TV.
Any possibility that the screensaver could have a selectable option to start immediately when Kodi loads?

Currently the 1min wait serves the purpose but if the unit is ever being power cycled for troubleshooting it would be nice not to have to wait the 1mins to ensure everything is working.


RE: [Release] Picture Slideshow Screensaver - ronie - 2015-11-15

(2015-11-15, 04:52)s9607571m Wrote: Hi Ronie and Developers,

Using this plugin for a photo display on a Wall mounted TV.
Any possibility that the screensaver could have a selectable option to start immediately when Kodi loads?

Currently the 1min wait serves the purpose but if the unit is ever being power cycled for troubleshooting it would be nice not to have to wait the 1mins to ensure everything is working.

nope, kodi control if/when the screensaver gets started.
there's noting i can do in the addon to change that.


RE: [Release] Picture Slideshow Screensaver - Raytestrak - 2015-11-15

(2015-11-15, 04:52)s9607571m Wrote: Hi Ronie and Developers,

Using this plugin for a photo display on a Wall mounted TV.
Any possibility that the screensaver could have a selectable option to start immediately when Kodi loads?

Currently the 1min wait serves the purpose but if the unit is ever being power cycled for troubleshooting it would be nice not to have to wait the 1mins to ensure everything is working.

Take a look at this.

It's an old thread, so maybe it won't work anymore, but it's worth the try.


RE: [Release] Picture Slideshow Screensaver - DJ_Izumi - 2015-11-16

I have a small feature request, but I wonder if it's behind the technical feature set of Kodi so it couldn't happen even if there was dev interest, but anyway. When an image that is much taller or wider than the screen is displayed, it's stretched out and dimmed in the background a second time to avoid black space, would it also be possible to apply a blur effect to background version? However, I've never seen any part of the Kodi interface feature a blur, so I wonder if it's not technically possible.


This forum uses Lukasz Tkacz MyBB addons.