Kodi Community Forum
PleXBMC add-on / skin integration support - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Skins Support (https://forum.kodi.tv/forumdisplay.php?fid=67)
+---- Forum: Amber (https://forum.kodi.tv/forumdisplay.php?fid=203)
---- Thread: PleXBMC add-on / skin integration support (/showthread.php?tid=175995)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22


RE: PleXBMC add-on support - Zekeman - 2013-12-21

Ok. I think I'm going crazy. I loaded up Amber (recent one) and when in a show or movie I can't find the option to download subtitles from and outside source. I do notice on the osd menu there is a "message" like icon 3rd in on bottom but that doesn't bring anything up when selected. Any ideas?


PleXBMC add-on support - pecinko - 2013-12-21

(2013-12-21, 04:27)Zekeman Wrote: Ok. I think I'm going crazy. I loaded up Amber (recent one) and when in a show or movie I can't find the option to download subtitles from and outside source. I do notice on the osd menu there is a "message" like icon 3rd in on bottom but that doesn't bring anything up when selected. Any ideas?

Are you on Frodo or Gotham? Also, be sure you use a proper version of Amber that matches XBMC version.

Since main repo was updated, download Amber from XBMC.


RE: PleXBMC add-on support - Zekeman - 2013-12-21

(2013-12-21, 12:07)pecinko Wrote:
(2013-12-21, 04:27)Zekeman Wrote: Ok. I think I'm going crazy. I loaded up Amber (recent one) and when in a show or movie I can't find the option to download subtitles from and outside source. I do notice on the osd menu there is a "message" like icon 3rd in on bottom but that doesn't bring anything up when selected. Any ideas?

Are you on Frodo or Gotham? Also, be sure you use a proper version of Amber that matches XBMC version.

Since main repo was updated, download Amber from XBMC.

Pecinko... I am using the Boxee XBMC version but have been updating with the FRODO updates with any addon's or themes or what not as I see this is based on this... I also downloaded Amber from your thread the newest one for Frodo....


PleXBMC add-on support - pecinko - 2013-12-21

(2013-12-21, 18:57)Zekeman Wrote:
(2013-12-21, 12:07)pecinko Wrote:
(2013-12-21, 04:27)Zekeman Wrote: Ok. I think I'm going crazy. I loaded up Amber (recent one) and when in a show or movie I can't find the option to download subtitles from and outside source. I do notice on the osd menu there is a "message" like icon 3rd in on bottom but that doesn't bring anything up when selected. Any ideas?

Are you on Frodo or Gotham? Also, be sure you use a proper version of Amber that matches XBMC version.

Since main repo was updated, download Amber from XBMC.

Pecinko... I am using the Boxee XBMC version but have been updating with the FRODO updates with any addon's or themes or what not as I see this is based on this... I also downloaded Amber from your thread the newest one for Frodo....

Ok, goto plexbmc/advanced and disable playback monitor. Better?


RE: PleXBMC add-on support - Zekeman - 2013-12-21

(2013-12-21, 20:29)pecinko Wrote:
(2013-12-21, 18:57)Zekeman Wrote:
(2013-12-21, 12:07)pecinko Wrote: Are you on Frodo or Gotham? Also, be sure you use a proper version of Amber that matches XBMC version.

Since main repo was updated, download Amber from XBMC.

Pecinko... I am using the Boxee XBMC version but have been updating with the FRODO updates with any addon's or themes or what not as I see this is based on this... I also downloaded Amber from your thread the newest one for Frodo....

Ok, goto plexbmc/advanced and disable playback monitor. Better?

Thank you much! One last thing then I'm good as gold... Can you point me in the right direction to go back to episodes in stead of seasons in recently added on shelf? and also point me in direction where in Amber I can edit the the "Sub Menu" options under TV Shows to add a "All Shows" instead of "Recently Viewed"

Thanks so much for your hard work!


RE: PleXBMC add-on support - tube82 - 2013-12-22

(2013-12-19, 14:24)pecinko Wrote: Version 3.3.7

Re-organize settings
Enable shelf toggles (hide movies, tv, all etc)
Add option to hide watched items from recent movie shelf
Bump add-on version to 3.3.7
Skin integration works in both Amber and Quartz

https://github.com/pecinko/plugin.video.plexbmc/archive/amber.zip

Nice update! I like the new settings and the option to hide watched items from the shelf.


RE: PleXBMC add-on support - Zodler - 2013-12-31

pecinko could you please explain what your Plexmbc mod has more? If we install the official Plexmbc from its repo, what will we missing?

UPDATE:

I also noticed today that when I install your PleXMBC addon the transcoder tab disappears. Anyone else has this problem in PleXMBC settings? In the official Addon I can see the Transcoder tab and I can set the Transcoding quality, but the official PleXMBC doesn't work with your skin AMBER that I want.


RE: PleXBMC add-on support - pecinko - 2014-01-01

(2013-12-31, 17:42)Zodler Wrote: pecinko could you please explain what your Plexmbc mod has more? If we install the official Plexmbc from its repo, what will we missing?

https://github.com/hippojay/plugin.video.plexbmc/pull/22

Quote:I also noticed today that when I install your PleXMBC addon the transcoder tab disappears. Anyone else has this problem in PleXMBC settings? In the official Addon I can see the Transcoder tab and I can set the Transcoding quality, but the official PleXMBC doesn't work with your skin AMBER that I want.

Huh....

Take a second look at settings. I've posted above items were re-organized.


RE: PleXBMC add-on support - ph3d - 2014-01-02

Is it possible for tvtunes addon to work with plex through the skin or is this only for local video library's?

Everything else is great - Amazing skin and updates I love having the unwatched etc under my plex categories

Cheers


RE: PleXBMC add-on support - xawen - 2014-01-03

I just installed Plex yesterday and I'm trying to get this plugin working with my RaspBMC image. I'm running into an error every time I try to launch the plugin though: Script Failed: plugin.video.plexbmc-amber. I found a few errors in the xmbc.log (below) but they don't mean anything to me. Any suggestions would be hugely appreciated.

XBMC 12.2 (RaspBMC version)
Amber 1.3.0 (same error with Confluence)
PlexBMC 3.3.8
Plex 0.9.8.18 - Brand new install. 2 sections, 3 total folders.

Section from xbmc.log that shows the launch (debug logging is on):
Code:
13:33:03 T:2770334784  NOTICE: PleXBMC -> Running with cElementTree on Python 2.5+
13:33:03 T:2770334784  NOTICE: ===== PLEXBMC START =====
13:33:03 T:2770334784  NOTICE: PleXBMC -> running Python: sys.version_info(major=2, minor=7, micro=3, releaselevel='final', serial=0)
13:33:03 T:2770334784  NOTICE: PleXBMC -> running PleXBMC: 3.3.8
13:33:03 T:2770334784  NOTICE: PleXBMC -> Platform: Linux/RPi
13:33:03 T:2770334784  NOTICE: PleXBMC -> Flatten is: 0
13:33:03 T:2770334784  NOTICE: PleXBMC -> Settings streaming: 0
13:33:03 T:2770334784  NOTICE: PleXBMC -> Setting filter menus: true
13:33:03 T:2770334784  NOTICE: PleXBMC -> Setting debug to true
13:33:03 T:2770334784  NOTICE: PleXBMC -> Setting stream Control to : PLEX CONTROL (1)
13:33:03 T:2770334784  NOTICE: PleXBMC -> Force DVD playback: false
13:33:03 T:2770334784  NOTICE: PleXBMC -> SMB IP Override: false
13:33:03 T:2770334784  NOTICE: PleXBMC -> Script argument is ['plugin://plugin.video.plexbmc/', '14', '?content_type=video']
13:33:03 T:2770334784  NOTICE: == ENTER: get_params ==
13:33:03 T:2770334784  NOTICE: PleXBMC -> get_params: Parameter string: ?content_type=video
13:33:03 T:2770334784  NOTICE: PleXBMC -> Detected parameters: {'content_type': 'video'}
13:33:03 T:2770334784  NOTICE: PleXBMC -> Mode: -1
13:33:03 T:2770334784  NOTICE: PleXBMC -> URL: None
13:33:03 T:2770334784  NOTICE: PleXBMC -> Name:
13:33:03 T:2770334784  NOTICE: PleXBMC -> identifier: None
13:33:03 T:2770334784  NOTICE: PleXBMC -> token: None
13:33:03 T:2770334784  NOTICE: == ENTER: displaySections() ==
13:33:03 T:2770334784  NOTICE: == ENTER: discoverAllServers ==
13:33:03 T:2770334784  NOTICE: PleXBMC -> local GDM discovery setting enabled.
13:33:03 T:2770334784  NOTICE: PleXBMC -> discoverAllServers: Attempting GDM lookup on multicast
13:33:03 T:2770334784  NOTICE: PlexGDM: Sending discovery messages: M-SEARCH * HTTP/1.0
13:33:03 T:2770334784  NOTICE: PlexGDM: Received data from 192.168.1.113, 32414
13:33:03 T:2770334784  NOTICE: PlexGDM: Data received is:
                                             HTTP/1.0 200 OK
                                            Content-Type: plex/media-server
                                            Resource-Identifier: 5843e09eebb9daa8493cfc517a25aea7fd492419
                                            Name: blizzard
                                            Port: 32400
                                            Updated-At: 1388771902
                                            Version: 0.9.8.18.290-11b7fdd
13:33:04 T:2770334784  NOTICE: PlexGDM: Number of servers Discovered: 1
13:33:04 T:2770334784  NOTICE: PlexGDM: Server Discovered: blizzard
13:33:04 T:2770334784  NOTICE: PleXBMC -> discoverAllServers: GDM discovery completed
13:33:04 T:2770334784  NOTICE: PleXBMC -> serverList is {0: {'updated': '1388771902', 'uuid': '5843e09eebb9daa8493cfc517a25aea7fd492419', 'serverName': 'blizzard', 'owned': '1', 'server': '192.168.1.113', 'port': '32400', 'version': '0.9.8.18.290-11b7fdd', 'role': 'master', 'master': 1, 'content-type': 'plex/media-server', 'class': None, 'discovery': 'auto'}}
13:33:04 T:2770334784  NOTICE: == ENTER: deduplicateServers ==
13:33:04 T:2770334784  NOTICE: PleXBMC -> displaySections: Using list of 1 servers: {0: {'updated': '1388771902', 'uuid': '5843e09eebb9daa8493cfc517a25aea7fd492419', 'serverName': 'blizzard', 'owned': '1', 'server': '192.168.1.113', 'port': '32400', 'version': '0.9.8.18.290-11b7fdd', 'role': 'master', 'master': 1, 'content-type': 'plex/media-server', 'class': None, 'discovery': 'auto'}}
13:33:04 T:2770334784  NOTICE: == ENTER: getAllSections ==
13:33:04 T:2770334784  NOTICE: PleXBMC -> getAllSections: Using servers list: {0: {'updated': '1388771902', 'uuid': '5843e09eebb9daa8493cfc517a25aea7fd492419', 'serverName': 'blizzard', 'owned': '1', 'server': '192.168.1.113', 'port': '32400', 'version': '0.9.8.18.290-11b7fdd', 'role': 'master', 'master': 1, 'content-type': 'plex/media-server', 'class': None, 'discovery': 'auto'}}
13:33:04 T:2770334784  NOTICE: == ENTER: getServerSections ==
13:33:04 T:2770334784  NOTICE: == ENTER: getURL ==
13:33:04 T:2770334784  NOTICE: PleXBMC -> getURL: url = http://192.168.1.113:32400/library/sections
13:33:04 T:2770334784  NOTICE: PleXBMC -> getURL: header = {}
13:33:04 T:2770334784  NOTICE: PleXBMC -> getURL: ====== XML returned =======
13:33:04 T:2770334784  NOTICE: <?xml version="1.0" encoding="UTF-8"?>
                                            <MediaContainer size="2" allowSync="0" identifier="com.plexapp.plugins.library" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1387862392" title1="Plex Library">
                                            <Directory art="/:/resources/movie-fanart.jpg" filters="1" refreshing="0" thumb="/:/resources/movie.png" key="1" type="movie" title="Movies" agent="com.plexapp.agents.themoviedb" scanner="Plex Movie Scanner" language="en" uuid="ae47a606-2960-4ba4-bc67-06be2f3c2b9b" updatedAt="1388766976" createdAt="1388695377">
                                            <Location id="1" path="/mnt/media/Movies" />
                                            <Location id="2" path="/mnt/data/fileshares/usenet/complete/movies" />
                                            </Directory>
                                            <Directory art="/:/resources/show-fanart.jpg" filters="1" refreshing="0" thumb="/:/resources/show.png" key="2" type="show" title="TV Shows" agent="com.plexapp.agents.thetvdb" scanner="Plex Series Scanner" language="en" uuid="91e38873-7612-4482-a478-a67685412045" updatedAt="1388766988" createdAt="1388695400">
                                            <Location id="3" path="/mnt/data/fileshares/usenet/complete/tv" />
                                            </Directory>
                                            </MediaContainer>
13:33:04 T:2770334784  NOTICE: PleXBMC -> getURL: ====== XML finished ======
13:33:04 T:2770334784   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: 'NoneType' object is not callable
                                            Traceback (most recent call last):
                                              File "/home/pi/.xbmc/addons/plugin.video.plexbmc-amber/default.py", line 5247, in <module>
                                                displaySections()
                                              File "/home/pi/.xbmc/addons/plugin.video.plexbmc-amber/default.py", line 1159, in displaySections
                                                for section in getAllSections(ds_servers):
                                              File "/home/pi/.xbmc/addons/plugin.video.plexbmc-amber/default.py", line 604, in getAllSections
                                                section_details =  getServerSections( server['server'], server['port'] , server['serverName'], server['uuid'])
                                              File "/home/pi/.xbmc/addons/plugin.video.plexbmc-amber/default.py", line 522, in getServerSections
                                                tree = etree.fromstring(html).getiterator("Directory")
                                              File "<string>", line 123, in XML
                                            TypeError: 'NoneType' object is not callable
                                            -->End of Python script error report<--
13:33:04 T:3040808960   ERROR: GetDirectory - Error getting plugin://plugin.video.plexbmc/?content_type=video
13:33:04 T:3040808960   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.plexbmc/?content_type=video) failed
13:33:04 T:2770334784  NOTICE: Thread Background Loader start, auto delete: false



RE: PleXBMC add-on support - pecinko - 2014-01-03

Try disabling MyPlex and use GDM server discovery, if you have server on LAN.


RE: PleXBMC add-on support - xawen - 2014-01-04

(2014-01-03, 23:20)pecinko Wrote: Try disabling MyPlex and use GDM server discovery, if you have server on LAN.

I'm getting the same error (and same xbmc.log entries) with GDM, MyPlex and Manual config. You're right though, the server is on the LAN.

Edit: After a few reboots, it seems to be able to connect. Playback is a bit flakey, but I haven't adjusted any settings yet.


PleXBMC add-on support - pecinko - 2014-01-04

Add your media locations as sources in XBMC. Script is smart enough to play it directly in that case, just like regular XBMC files. Presuming you have rpi compatible files, you don't need transcoding.


RE: PleXBMC add-on support - MisterSe├▒or - 2014-01-04

This a a great addon that i used in the past, but for some reason i can't get it to work now.

There is too much information on forums and different versions for different skins that i can help but beating my head against the wall.

I know, i'm probably an idiot.

But this shoulb be as simple as installing an addon and just work.

I've installed pretty much everything from diferent Amber Skins versions to different PlexBMC versions with no success.

Sometimes sections appear in the Amber menu, sometimes they don't. And when they appear opening a video just pops "script error".



Could someone PLEASE write a simple description (and links) of how to get it working on a 512mb Pi with latest openelec? And please write it like you were talking to a 5 year old. I' not a computer geek.



I'm using latest PMS in a unRaid server on local LAN.


RE: PleXBMC add-on support - pecinko - 2014-01-05

(2014-01-04, 19:35)MisterSe├▒or Wrote: Could someone PLEASE write a simple description (and links) of how to get it working on a 512mb Pi with latest openelec? And please write it like you were talking to a 5 year old. I' not a computer geek.

1.Install Amber from xbmc repository.
2. Install plexbmc - see link in 1st post of this thread
3. go to settings on home page and find "Go Plex" in submenu. Activate it.
4. plexbmc settings can be found in the same place. Adjust it to your needs.


Some notes:

- your NAS may not support photo transcoding. If that is the case activate full-res artwork in advanced settings of plexbmc
- you will probably encounter some problems with latest PMS. Either downgrade to 0.9.8.13 or lower version or try restarting htpc. It might help to activate both GDM (auto discovery of PMS) and MyPlex login in plexbmc settings or disabling MyPlex and leaving only GDM. Using MyPlex only won't work reliably. I might have a solution for this problem but some code re-writing is needed and I need to find some time to do it.


This forum uses Lukasz Tkacz MyBB addons.