Kodi Community Forum
[Release] Internet Archive - archive.org - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [Release] Internet Archive - archive.org (/showthread.php?tid=180623)

Pages: 1 2 3 4 5


Internet Archive - archive.org - divingmule - 2013-12-17 19:00

This add-on covers both the video and audio sections of the Internet Archive - http://www.archive.org

For videos open the add-on from Video Add-ons and for audio open the add-on from Music Add-ons.

The latest release is version 2.1.0. Download and install from zip - https://divingmules-repo.googlecode.com/files/plugin.audio.internet.archive-2.1.0.zip
Should be available from the XBMC.org repository in the near future.

The code is on GitHub - https://github.com/divingmule/plugin.audio.internet.archive

Post any issues, questions, comments here.


RE: Internet Archive - archive.org - fouad796 - 2013-12-17 20:01

great release as always cant wait to test it


RE: Internet Archive - archive.org - spinmaster - 2014-12-13 15:19

Will this add-on be updated to work with Kodi 14.x?

v2.1.0 crashes on Kodi 14.0. Sad


RE: Internet Archive - archive.org - bs0d - 2015-01-09 04:12

Is there a way to play the games on internet archive? https://archive.org/details/software


RE: Internet Archive - archive.org - spinmaster - 2015-02-21 18:16

(2014-12-13 15:19)spinmaster Wrote:  Will this add-on be updated to work with Kodi 14.x?

v2.1.0 crashes on Kodi 14.0. Sad

Since updating to Kodi 14.1, it seems to be working again. Smile


RE: Internet Archive - archive.org - Romeoshine - 2015-02-22 12:57

working again thanx fellas nice addon


RE: Internet Archive - archive.org - MoRbIdBoY - 2015-03-14 00:30

Script failed on Kodi 14.2 rc 1 Android and PC. Plug version 2.1.0


RE: Internet Archive - archive.org - xDetoursx - 2015-03-16 01:40

Script failed for me too. Win 7 Helix 14.0


RE: Internet Archive - archive.org - spinmaster - 2015-03-17 13:12

Yupp, same on OpenELEC 5.0.6 which uses the latest 14.2 build. Sad Script fails on add-on start.

Does somebody know what exactly changes in the codebase so that the script fails in 14.0, works fine in 14.1 and now fails again in 14.2?


RE: Internet Archive - archive.org - jcice - 2015-03-24 12:35

This is one of my favorite add-ons - has there been any progress in fixing the script failed error? I'm running Kodi 14.2 RC1.


RE: Internet Archive - archive.org - jcice - 2015-04-03 23:51

(2015-03-24 12:35)jcice Wrote:  This is one of my favorite add-ons - has there been any progress in fixing the script failed error? I'm running Kodi 14.2 RC1.

Still broken with the official 14.2 release - really hoping this add on can be repaired with the latest Kodi version.


RE: Internet Archive - archive.org - xiaNaix - 2015-04-08 20:54

Here's the error log.

Code:
14:50:37 T:724   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'NoneType' object has no attribute 'find'
                                            Traceback (most recent call last):
                                              File "C:\Users\xiaNaix\AppData\Roaming\Kodi\addons\plugin.audio.internet.archive\defau​lt.py", line 526, in <module>
                                                get_category_page(video_url, video_thumb)
                                              File "C:\Users\xiaNaix\AppData\Roaming\Kodi\addons\plugin.audio.internet.archive\defau​lt.py", line 97, in get_category_page
                                                collection_tag = soup.find('select', attrs={'name': 'mediatype'}).find('option', selected='selected')
                                            AttributeError: 'NoneType' object has no attribute 'find'
                                            -->End of Python script error report<--



RE: Internet Archive - archive.org - silvanet - 2015-04-11 19:27

(2015-04-08 20:54)xiaNaix Wrote:  Here's the error log.

Code:
14:50:37 T:724   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'NoneType' object has no attribute 'find'
                                            Traceback (most recent call last):
                                              File "C:\Users\xiaNaix\AppData\Roaming\Kodi\addons\plugin.audio.internet.archive\defau​lt.py", line 526, in <module>
                                                get_category_page(video_url, video_thumb)
                                              File "C:\Users\xiaNaix\AppData\Roaming\Kodi\addons\plugin.audio.internet.archive\defau​lt.py", line 97, in get_category_page
                                                collection_tag = soup.find('select', attrs={'name': 'mediatype'}).find('option', selected='selected')
                                            AttributeError: 'NoneType' object has no attribute 'find'
                                            -->End of Python script error report<--

Is anyone going to get around to fixing this? I don't understand why it keeps breaking. Librivox publishes its RSS feed. See, https://librivox.org/search?primary_key=0&search_category=author&search_page=1&search_form=get_results

In fact, here is a feed link for public domain audiobook titles. https://feedly.com/i/subscription/feed/https://librivox.org/feed/


RE: Internet Archive - archive.org - jcice - 2015-05-16 17:50

Well, over a month later and still no sign of a fix for the Internet Archive add on - I guess we can put this one in the "abandoned" category. Would any coders be willing to take over this project? There's so much great content on the internet archive that it seems a shame to let this die.


RE: Internet Archive - archive.org - xDetoursx - 2015-06-13 03:14

(2015-05-16 17:50)jcice Wrote:  Well, over a month later and still no sign of a fix for the Internet Archive add on - I guess we can put this one in the "abandoned" category. Would any coders be willing to take over this project? There's so much great content on the internet archive that it seems a shame to let this die.

I agree, but sadly it doesn't look like it's on anybody's to do list