Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - rbej - 2014-01-08

Jan 07 in system info is ok.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - deejayq - 2014-01-08

avoid_fix_ts=0 got lost in the new firmware?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-08

(2014-01-08, 18:35)deejayq Wrote: avoid_fix_ts=0 got lost in the new firmware?

Should be present. vcgencmd version?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - hero - 2014-01-08

Hey,

I have updated to Milhouse's last xbmc version. Awesome work and xbmc on the Pi getting better and better, but I cannot play m2ts-files.
In earlier releases, Frodo I think, it plays fine.
Thanks and greetz,
Chris


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-08

(2014-01-08, 19:07)hero Wrote: I have updated to Milhouse's last xbmc version. Awesome work and xbmc on the Pi getting better and better, but I cannot play m2ts-files.

xbmc.log?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - postdeath - 2014-01-08

I am seeing this error a lot with certain skins

Code:
17:31:33 258.198029 T:3034858576   ERROR: CAESinkPi:AddPackets Underrun (delay:0.00 frames:2205)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-08

(2014-01-08, 19:38)postdeath Wrote: I am seeing this error a lot with certain skins

Yes. Perhaps it shouldn't be an error as it's relatively harmless.
In means the sink hasn't been serviced in the last 50ms so has run empty, but typically it appears when outputting silence.

I can increase the 50ms, but that makes the gui sounds less responsive.

There is talk of having a special path for gui sounds in ActiveAE so we can increase the buffer for music (when you care more about underrun), but still have responsive key presses (which you don't care so much about underrunning). But have to wait for that upstream.


[split] missing subtitle stream - J├Ânke - 2014-01-08

Still sometime xbmc having trouble to show the subtitles in live-tv on Rpi with the builds from http://forum.xbmc.org/showthread.php?tid=169674&pid=1590227#pid1590227.
Sometimes it works but not always.

But xbmx always sees the subtitle (i can chose them in the meny) but they want show up on tv


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-01-08

(2014-01-08, 10:53)deejayq Wrote:
(2014-01-08, 02:01)MilhouseVH Wrote: [*]Includes these newclock3 commits (except for 919e1ef which I've replaced with a static spinner)
what do you mean by a static spinner?

The "Working" image isn't animated and doesn't rotate as this requires XBMC to expend vast amounts of CPU time (>65%) animating the image rather than using that CPU to accomplish the busy task more quickly.

There is a solution, which is to use a GIF image, but OpenELEC doesn't support binary patches so I've just dropped the GIF image. Hopefully a better solution will go upstream and this patch can be dropped completely.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-08

(2014-01-08, 21:49)MilhouseVH Wrote: The "Working" image isn't animated and doesn't rotate as this requires XBMC to expend vast amounts of CPU time (>65%) animating the image rather than using that CPU to accomplish the busy task more quickly.

There is a solution, which is to use a GIF image, but OpenELEC doesn't support binary patches so I've just dropped the GIF image. Hopefully a better solution will go upstream and this patch can be dropped completely.

The other solution is to use the Amber skin which uses a cheaper "Working..." spinner.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-01-08

Agreed, but it would also be nice if the stock "Confluence" skin - which is billed as being lightweight - didn't suck CPU so unnecessarily as it's the skin most people will use to start off with. I'll ping uNiversal and see what he thinks as it's a bit of a no-brainer really.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - postdeath - 2014-01-08

(2014-01-08, 21:00)popcornmix Wrote:
(2014-01-08, 19:38)postdeath Wrote: I am seeing this error a lot with certain skins

Yes. Perhaps it shouldn't be an error as it's relatively harmless.
In means the sink hasn't been serviced in the last 50ms so has run empty, but typically it appears when outputting silence.

I can increase the 50ms, but that makes the gui sounds less responsive.

There is talk of having a special path for gui sounds in ActiveAE so we can increase the buffer for music (when you care more about underrun), but still have responsive key presses (which you don't care so much about underrunning). But have to wait for that upstream.

Ahh, is it just coincidence that it's the last thing in the log before a system freeze, then? Will ignore that one from now on, then - cheers Smile


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - doveman2 - 2014-01-09

I'm still having some issues with XBMC freezing up completely whilst watching TV, even when not recording at the same time, although I can still SCP in so it seems that only XBMC has frozen and not the underlying OS.

I posted about it here http://forum.xbmc.org/showthread.php?tid=182517&pid=1594564#pid1594564 and as you can see, opdenkamp has queried some lines in the log. Would these be a result of the auto-amplitude adjustment feature or if not, any idea what they are?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-01-09

New OpenELEC Gotham build: #0109 (obsolete)

Code:
rpi512:~ # uname -a
Linux rpi512 3.12.6 #1 PREEMPT Thu Jan 9 04:58:17 GMT 2014 armv6l GNU/Linux
rpi512:~ # vcgencmd version
Jan  7 2014 22:04:19
Copyright (c) 2012 Broadcom
version 971028d3d656de279fcef4f502bc867b8a91cf22 (clean) (release)
rpi512:~ # lsb_release
OpenELEC_Gotham (Milhouse) - Version: devel-20140109044948-r16904-gd187532

Based on tip of XBMC master (df7398c, changelog) and tip of OpenELEC master (d187532, changelog) with the following modifications:
  • Includes these newclock3 commits (except for 919e1ef which I've replaced with a static spinner)
  • Excludes the OpenELEC fernetmenta patches (due to conflict with newclock3)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - deejayq - 2014-01-09

anybody else loosing ssh connectivity after doing a fresh install of the latest milhouse builds?
at first boot i can ssh, and if i run top i see xbmc eating up a lot of cpu and after a while ssh disconnects, and pinging the pi doesn't work either


This forum uses Lukasz Tkacz MyBB addons.