Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-01-24

Two observations about DVDplayer (with very little testing), aside from what is mentioned above.
* DVDplayer plays (some?) DIVX files that omxplayer does not play;
* EDL (and commercial skipping) in the mythTV plugin broke on Pi only in November. It works in DVDplayer.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - MrNice - 2014-01-24

Hey, I didn' t know that!

Many thanks.

So I set up the passthrough and reboot
=> no audio at all,
reboot again and still no audio at all

Delete guisetting.xml and reboot
setup passthrough
=> audio is back but multichannel files have very low level, only stereo and lot of drops


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - MrNice - 2014-01-24

I changed channels to 5.0 still passthrough

AVR displays "Multi in"
PAPlayer and DVDplayer mix up the channels (center in BL and BL in center)
PAPlayer plays with lot of drops and slowly
omxplayer plays properly


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - marcjero - 2014-01-24

Hello,

I'm not sure to understand what is happening with passthrought. In these releases It seems that DTS and dobly digital data are encapsulated in PCM stereo streams, is it correct ?

I'm interested with that because my TV is connected to an AVR throught TOSLINK and unfortunately the TV doesn't support AC3 or DTS passthrought from HDMI.
So the TV could receive the stereo PCM stream with embedded 5.1 and forward it as is to my receiver ?

How do receivers behave with this format ?

Thanks


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-24

(2014-01-24, 21:37)marcjero Wrote: I'm not sure to understand what is happening with passthrought. In these releases It seems that DTS and dobly digital data are encapsulated in PCM stereo streams, is it correct ?

I'm interested with that because my TV is connected to an AVR throught TOSLINK and unfortunately the TV doesn't support AC3 or DTS passthrought from HDMI.
So the TV could receive the stereo PCM stream with embedded 5.1 and forward it as is to my receiver ?

How do receivers behave with this format ?

If your TV doesn't support passthrough through the TOSLINK cable then nothing will help.
What goes over hdmi will be the same in both cases:
with omxplayer the encapsulation into the stereo stream is handled on the GPU
with dvdplayer the encapsulation into the strereo stream is handled by the ARM.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Trickname - 2014-01-24

don´t forget to reboot after changeing as.xml


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - craigbeat - 2014-01-25

Been using DVD player for a short while, but had to switch back for now. Observations so far:

When playing live TV from tvheadend, MPEG2 streams are fine, but h264 buffer for a while (takes longer to start playing), and then black screen and only sound.

I can't tell whether menus perform better over the top or not - timeline view is slow usually anyway, which I think is down to the amount of data that is being loaded.

DVDplayer still puts live TV to 1080p 25Hz when switching to best resolution - would be better either as 1080i, or better still 1080p 50Hz.

DVDplayer is MUCH faster at starting a MPEG2 video - even HD (BBC for example)


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - chicco - 2014-01-25

hi,
i updated from the last old rbej build of october 2013 to the latest milhouse build.
now the pi doesn't boot and it shows only a rainbow image.
i have a modified config.txt with overclock and use an usb storage for home dir.
how can i fix it?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - denz - 2014-01-25

Hi,

Did you copy the files into the update directory or did you follow the instructions and copy all of these files. I noticed that if I copy the files to the update directory on the next restart it doesn't copy them correctly.

copy target\KERNEL g:\kernel.img
copy target\SYSTEM g:\
copy 3rdparty\bootloader\*.* g:\
copy openelec.ico g:\
copy README.md g:\

http://wiki.xbmc.org/index.php?title=HOW-TO:Install_XBMC_on_Raspberry_Pi_with_USB_drive


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - denz - 2014-01-25

I did try the dvdplayer and unfortunately I had the same result as craigbeat. The dvdplayer definitely starts MPEG2 stream faster but then I switched to HD channel and it only displayed black screen with sound. So it needs more work but I will test future versions.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-25

(2014-01-25, 12:36)denz Wrote: I did try the dvdplayer and unfortunately I had the same result as craigbeat. The dvdplayer definitely starts MPEG2 stream faster but then I switched to HD channel and it only displayed black screen with sound. So it needs more work but I will test future versions.

If you have a 512M pi and are testing dvdplayer then make sure gpu_mem=256. I think you will get errors with gpu_mem=128 when playing hd videos.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-25

(2014-01-25, 12:06)chicco Wrote: hi,
i updated from the last old rbej build of october 2013 to the latest milhouse build.
now the pi doesn't boot and it shows only a rainbow image.
i have a modified config.txt with overclock and use an usb storage for home dir.
how can i fix it?

Put the sdcard in an sdcard reader in a PC and edit config.txt.
Removing the lines that end "_freq" will disable the overclock.
(You can remove a line by inserting a # at the beginning).


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - craigbeat - 2014-01-25

Hi popcornmix,

My Pi is already set with gpu_mem=256 I'm afraid.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-25

(2014-01-25, 13:07)craigbeat Wrote: My Pi is already set with gpu_mem=256 I'm afraid.

Can you play HD recordings with dvdplayer?
An debug xbmc.log file may have some clues.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - craigbeat - 2014-01-25

Just clearing my log and starting again - recordings do the same thing, even when playing file directly over NFS. Audio passthrough sounds like noise with partial 'real' sound. If I switch players back, passthrough is perfect.

Would you like a sample file and log dump? If so, where shall I put them?


This forum uses Lukasz Tkacz MyBB addons.