Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-26

Is there an open issue related to commercial skipping not working in the latest Gotham builds for RPi and OpenELEC? I was using Frodo 12.2 for quite some time and commercial skipping (with my .edl files) was working great up until I jumped over to start using Gotham nightly builds. It doesn't seem to acknowledge the commercials.

This is an issue in both r17121 from Jan 23 (and then I also upgraded to r17148 from Jan 25) and it's still an issue.

Thoughts?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Bullsei - 2014-01-26

Hallo Guys, i like to try some of this new builds and i want to buy an DAC for the Pi.
Is the Hifiberry DAC (Hifiberry working with the latest builds?
Or did somebody try it?
Thanks


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-01-26

(2014-01-26, 18:58)LehighBri Wrote: Is there an open issue related to commercial skipping not working in the latest Gotham builds for RPi and OpenELEC? I was using Frodo 12.2 for quite some time and commercial skipping (with my .edl files) was working great up until I jumped over to start using Gotham nightly builds. It doesn't seem to acknowledge the commercials.

This is an issue in both r17121 from Jan 23 (and then I also upgraded to r17148 from Jan 25) and it's still an issue.

Thoughts?
Which PVR?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-26

(2014-01-26, 19:13)allan87 Wrote:
(2014-01-26, 18:58)LehighBri Wrote: Is there an open issue related to commercial skipping not working in the latest Gotham builds for RPi and OpenELEC? I was using Frodo 12.2 for quite some time and commercial skipping (with my .edl files) was working great up until I jumped over to start using Gotham nightly builds. It doesn't seem to acknowledge the commercials.

This is an issue in both r17121 from Jan 23 (and then I also upgraded to r17148 from Jan 25) and it's still an issue.

Thoughts?
Which PVR?

None. Normal playback!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-01-26

It MAY be related to this: http://trac.xbmc.org/ticket/14842

I have only used EDL with myth.

Please try this build: http://xbmcnightlybuilds.com/openelec-rpi-arm-r16378-download/

It is the last build that worked with EDL in myth. If it works for you, it would indicate that the EDL issue is a broader one.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-26

(2014-01-26, 19:27)LehighBri Wrote: None. Normal playback!

So if you have a video file and an edl file in the same directory, and you play it from file browser does the edl file have an effect?
If that doesn't work can you post the edl file.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-26

(2014-01-26, 19:36)allan87 Wrote: It MAY be related to this: http://trac.xbmc.org/ticket/14842

I have only used EDL with myth.

Please try this build: http://xbmcnightlybuilds.com/openelec-rpi-arm-r16378-download/

It is the last build that worked with EDL in myth. If it works for you, it would indicate that the EDL issue is a broader one.

Could be. I can't seem to download the .tar file from that page. Does the download work for you?
http://openelec.xbmcnightlybuilds.com/RPi/OpenELEC-RPi.arm-devel-20131116015058-r16378.tar.bz2

(2014-01-26, 19:40)popcornmix Wrote:
(2014-01-26, 19:27)LehighBri Wrote: None. Normal playback!

So if you have a video file and an edl file in the same directory, and you play it from file browser does the edl file have an effect?
If that doesn't work can you post the edl file.

Same issue. See below for an example edl file (I can't figure out how to post an attachment).

3.47 29.96 3
453.00 647.71 3
1064.20 1258.92 3
1742.34 1978.38 3
2456.77 2677.41 3
3091.57 3282.48 3


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-26

(2014-01-26, 19:41)LehighBri Wrote: Same issue. See below for an example edl file (I can't figure out how to post an attachment).

I created a file with that content alongside an existing video file, and played it:
Code:
8:16:52 5172.506836 T:2824762464   DEBUG: ReadEditDecisionLists - Checking for edit decision lists (EDL) on local drive or remote share for: dell/temp/test/aspect/Sherlock.3x01.The.Empty.Hearse.HDTV.x264-FoV.mp4
18:16:52 5172.523926 T:2824762464   DEBUG: ReadEdl - Read 6 cuts and 0 scene markers in EDL file: dell/temp/test/aspect/Sherlock.3x01.The.Empty.Hearse.HDTV.x264-FoV.edl
18:16:52 5172.544434 T:2824762464   DEBUG: WriteMPlayerEdl - MPlayer EDL file written to: special://temp/xbmc.edl
And the video played for 3 seconds, then skipped to 30, and at about 7:30 jumped to 10:47.
So seems to be working for me. Do you get the edl messages in log?
I'm playing this with omxplayer.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-26

See below for the log file from the time I push play to when I seek to different points where there are commercials and nothing happens. I definitely have the edl file I mentioned and it works fine in Frodo. The log doesn't seem to detect the edl file at all.

http://pastebin.com/NLBbn9d1


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Loom - 2014-01-26

(2014-01-26, 16:27)[email protected] Wrote: Popcornmix I have a pi connected to tv using an hdmi to dvi cable for video and analogue cable for audio. using gotham build and omxplayer I must select 'dual audio output' no matter if 'audio output device' selected is analogue or hdmi otherwise I get no sound. With dvdplayer.i get no sound what ever configuration I choose.

I have experienced something similiar with the latest Milhouse build:

No matter if audio-out is set to "HDMI" or "Analogue", MP3-playback just uses HDMI.

Movie-Playback is behaving like it is set to.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-26

(2014-01-26, 21:03)LehighBri Wrote: See below for the log file from the time I push play to when I seek to different points where there are commercials and nothing happens. I definitely have the edl file I mentioned and it works fine in Frodo. The log doesn't seem to detect the edl file at all.

http://pastebin.com/NLBbn9d1

Note the test above is on my Rpi. I just tried the same test on my windows XBMC version and it works fine on the same media (that is stored on my NAS drive). For some reason Rpi doesn't seem to be recognizing the .edl file

15:26:46 T:1500 DEBUG: CEdl::ReadEdl - Read 6 cuts and 0 scene markers in EDL file: smb://localhost/SageTV Recordings/Nashville-S02E12-JustforWhatIAm-10648947-0.edl
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:00:03.470
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:00:29.960
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:07:33.000
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:10:47.710
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:17:44.200
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:20:58.920
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:29:02.340
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:32:58.380
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:40:56.770
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:44:37.410
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:51:31.570
15:26:46 T:1500 DEBUG: CEdl::AddSceneMarker - Inserting new scene marker: 00:54:42.480
15:26:46 T:1500 DEBUG: CEdl::WriteMPlayerEdl - MPlayer EDL file written to: special://temp/xbmc.edl


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-01-26

(2014-01-26, 19:41)LehighBri Wrote:
(2014-01-26, 19:36)allan87 Wrote: It MAY be related to this: http://trac.xbmc.org/ticket/14842

I have only used EDL with myth.

Please try this build: http://xbmcnightlybuilds.com/openelec-rpi-arm-r16378-download/

It is the last build that worked with EDL in myth. If it works for you, it would indicate that the EDL issue is a broader one.

Could be. I can't seem to download the .tar file from that page. Does the download work for you?
http://openelec.xbmcnightlybuilds.com/RPi/OpenELEC-RPi.arm-devel-20131116015058-r16378.tar.bz2
I can't download it either. See here for correct link: http://forum.xbmc.org/showthread.php?tid=169674&pid=1611541#pid1611541


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-26

(2014-01-26, 21:03)LehighBri Wrote: See below for the log file from the time I push play to when I seek to different points where there are commercials and nothing happens. I definitely have the edl file I mentioned and it works fine in Frodo. The log doesn't seem to detect the edl file at all.

This is the logic that determines if EDL file is opened:
Code:
/*
   * Only check for edit decision lists if the movie is on the local hard drive, or accessed over a
   * network share.
   */
  if ((URIUtils::IsHD(strMovie)  ||
       URIUtils::IsSmb(strMovie) ||
       URIUtils::IsNfs(strMovie) ||
       URIUtils::IsAfp(strMovie))         &&
      !URIUtils::IsPVRRecording(strMovie) &&
      !URIUtils::IsInternetStream(strMovie))
  {
    CLog::Log(LOGDEBUG, "%s - Checking for edit decision lists (EDL) on local drive or remote share for: %s",
              __FUNCTION__, strMovie.c_str());

I've added an extra debug log message to newclock3 to see if this code is rejecting the EDL check. IsSmb should be true for you and IsPVRRecording/IsInternetStream should be false.
Should be able to confirm that in a future build.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Leopold - 2014-01-26

(2014-01-26, 19:41)LehighBri Wrote: I can't seem to download the .tar file from that page. Does the download work for you?
http://openelec.xbmcnightlybuilds.com/RPi/OpenELEC-RPi.arm-devel-20131116015058-r16378.tar.bz2

This is the correct link http://mirrors.xbmcnightlybuilds.com/OpenELEC_DEV_BUILDS/RPi/OpenELEC-RPi.arm-devel-20131116015058-r16378.tar.bz2


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-01-26

(2014-01-26, 23:26)popcornmix Wrote:
Code:
* Only check for edit decision lists if the movie is on the local hard drive, or accessed over a
   * network share.
Would this logic also affect MythTV? With MythTV, the EDL is not in a file, but in a sql database.


This forum uses Lukasz Tkacz MyBB addons.