Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - theowiesengrund - 2014-01-27

I'm having the problem that XBMC doesn't wake up my server anymore. After selecting a movie XBMC becomes unresponsible. Debug log isn't very insightful:

Code:
00:51:20 661.986816 T:2939155536   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control pressed (44)
00:51:20 661.987061 T:2939155536   DEBUG: CecLogMessage - key pressed: select (0)
00:51:20 661.987244 T:2939155536   DEBUG: PushCecKeypress - received key  b duration 0
00:51:20 661.992188 T:3043868672   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
00:51:21 662.060303 T:2939155536   DEBUG: CecLogMessage - >> 04:8b:00
00:51:21 662.060608 T:2939155536   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): vendor remote button up (8B)
00:51:21 662.060791 T:2939155536   DEBUG: CecLogMessage - key released: select (0)
00:51:21 662.060974 T:2939155536   DEBUG: PushCecKeypress - received key  b duration 74
00:51:21 662.300598 T:3043868672   DEBUG: ------ Window Deinit (DialogContextMenu.xml) ------
00:51:21 662.765137 T:2805281872   DEBUG: Thread JobWorker 2805281872 terminating (autodelete)00:51:21 662.778076 T:2838836304   DEBUG: Thread JobWorker 2838836304 terminating (autodelete)00:52:21 722.455872 T:3033527376   DEBUG: CAESinkPi:Drain delay:66ms now:0ms

Anyone witnessed the same behaviour?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-27

(2014-01-26, 23:26)popcornmix Wrote: This is the logic that determines if EDL file is opened:
Code:
/*
   * Only check for edit decision lists if the movie is on the local hard drive, or accessed over a
   * network share.
   */
  if ((URIUtils::IsHD(strMovie)  ||
       URIUtils::IsSmb(strMovie) ||
       URIUtils::IsNfs(strMovie) ||
       URIUtils::IsAfp(strMovie))         &&
      !URIUtils::IsPVRRecording(strMovie) &&
      !URIUtils::IsInternetStream(strMovie))
  {
    CLog::Log(LOGDEBUG, "%s - Checking for edit decision lists (EDL) on local drive or remote share for: %s",
              __FUNCTION__, strMovie.c_str());

I've added an extra debug log message to newclock3 to see if this code is rejecting the EDL check. IsSmb should be true for you and IsPVRRecording/IsInternetStream should be false.
Should be able to confirm that in a future build.

Great, thanks. Keep me posted once a build comes out that includes this and I'll try it right away (EDL support is very important for me as I use SageTV to record TV, comskip to generate the .EDL files, and then I playback those SageTV with related .edl files in XBMC).


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-27

To recap my EDL issue, EDL support works fine on my Rpi's Frodo 12.2 build, but not with Gotham releases r17121 from Jan 23 (and then I also upgraded to r17148 from Jan 25) and it's still an issue. My video are stored on a NAS drive (mounted via SMB) and playback works fine when trying to playback the same video w/ EDL on my Windows XBMC Gotham machine.

So I just tried the r16378 build on my RPi below that allan87 had EDL working for him... and it DOES work for me too. Log is below. So looks like something broke at some point, but we'll see if the additional debugging in popcornmix's upcoming builds will help troubleshoot this.

http://mirrors.xbmcnightlybuilds.com/OpenELEC_DEV_BUILDS/RPi/OpenELEC-RPi.arm-devel-20131116015058-r16378.tar.bz2

20:21:42 T:2787099728 DEBUG: ReadEditDecisionLists - Checking for edit decision lists (EDL) on local drive or remote share for: smb://ERICA-PC/SageTV Recordings/Nashville-S02E12-JustforWhatIAm-10648947-0.mpg
20:21:42 T:2787099728 DEBUG: CSmbFile::Open - opened SageTV Recordings/Nashville-S02E12-JustforWhatIAm-10648947-0.edl, fd=10001
20:21:42 T:3044971024 DEBUG: COMXCoreComponent::Initialize OMX.broadcom.image_decode input port 320 output port 321 m_handle 0x34eabb8
20:21:42 T:3044971024 DEBUG: COMXCoreComponent::AllocInputBuffers component(OMX.broadcom.image_decode) - port(320), nBufferCountMin(2), nBufferCountActual(2), nBufferSize(81920), nBufferAlignmen(16)
20:21:42 T:2787099728 DEBUG: AddCut - Pushing new cut to back [00:00:11.470 - 00:00:29.960], 3
20:21:42 T:2787099728 DEBUG: AddCut - Pushing new cut to back [00:07:41.000 - 00:10:47.710], 3
20:21:42 T:2787099728 DEBUG: AddCut - Pushing new cut to back [00:17:52.200 - 00:20:58.920], 3
20:21:42 T:2787099728 DEBUG: AddCut - Pushing new cut to back [00:29:10.340 - 00:32:58.380], 3
20:21:42 T:2787099728 DEBUG: AddCut - Pushing new cut to back [00:41:04.770 - 00:44:37.410], 3
20:21:42 T:3044971024 DEBUG: COMXCoreComponent::Initialize OMX.broadcom.resize input port 60 output port 61 m_handle 0x365a788
20:21:42 T:3044971024 DEBUG: COMXCoreComponent::Initialize OMX.broadcom.egl_render input port 220 output port 221 m_handle 0x365b3f8
20:21:42 T:3044971024 DEBUG: COMXCoreComponent::UseEGLImage component(OMX.broadcom.egl_render) - port(221), nBufferCountMin(1), nBufferCountActual(1), nBufferSize(15360) nBufferAlignmen(16)
20:21:42 T:2787099728 DEBUG: AddCut - Pushing new cut to back [00:51:39.570 - 00:54:42.480], 3
20:21:42 T:2787099728 DEBUG: CSmbFile::Close closing fd 10001
20:21:42 T:2787099728 DEBUG: ReadEdl - Read 6 cuts and 0 scene markers in EDL file: smb://ERICA-PC/SageTV Recordings/Nashville-S02E12-JustforWhatIAm-10648947-0.edl
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:00:11.470
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:00:29.960
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:07:41.000
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:10:47.710
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:17:52.200
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:20:58.920
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:29:10.340
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:32:58.380
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:41:04.770
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:44:37.410
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:51:39.570
20:21:42 T:2787099728 DEBUG: AddSceneMarker - Inserting new scene marker: 00:54:42.480


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-01-27

(2014-01-27, 03:25)LehighBri Wrote: So I just tried the r16378 build on my RPi below that allan87 had EDL working for him... and it DOES work for me too. Log is below. So looks like something broke at some point, but we'll see if the additional debugging in popcornmix's upcoming builds will help troubleshoot this.
Since it now appears that the broken EDL is not restricted to MythTV, could you please describe your environment in the trac ticket? http://trac.xbmc.org/ticket/14842


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-27

(2014-01-27, 03:36)allan87 Wrote:
(2014-01-27, 03:25)LehighBri Wrote: So I just tried the r16378 build on my RPi below that allan87 had EDL working for him... and it DOES work for me too. Log is below. So looks like something broke at some point, but we'll see if the additional debugging in popcornmix's upcoming builds will help troubleshoot this.
Since it now appears that the broken EDL is not restricted to MythTV, could you please describe your environment in the trac ticket? http://trac.xbmc.org/ticket/14842

I'm trying to add to the post but I get "GIT backend not available"


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-01-27

The ticket has become corrupted!

$#%#^$&@^ trac!

Info about this issue that was posted to trac is now duplicated here: http://forum.xbmc.org/showthread.php?tid=182791


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-27

Screw trac. I've found many of my issues have been resolved via the forums (I know that's not always the case though). popcornmix seems like he might be on the case so we'll see what he can do!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-01-27

New OpenELEC Gotham build: #0127 (obsolete)
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.13.0 #1 PREEMPT Mon Jan 27 02:12:16 GMT 2014 armv6l GNU/Linux

# vcgencmd version
Jan 10 2014 16:54:51
Copyright (c) 2012 Broadcom
version efa116b5c8859c352322cb27e13baccbea583ef7 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140127020806-r17171-g113849c

Based on tip of XBMC master (b6d31a3, changelog) and tip of OpenELEC master (113849c, changelog) with the following modifications:
  • Includes newclock3 commits (except for 0a40d4d which I've replaced with a static spinner)
  • Includes PR4083: fix HLS variant selection
  • Excludes the OpenELEC fernetmenta patches (due to conflict with newclock3)
Notes:
  1. A few new fixes have landed in newclock3:
    • Fix for 3d resolution switching
    • Avoid choosing TrueHD as default audio stream (in omxplayer)
    • PR4091 appears to fix several issues relating to repositories and addons
  2. This build includes the extra EDL debug statement

Additional Testing Notes:
  1. Testers should try adding the following entry to their advancedsettings.xml:
    Code:
    <advancedsettings>
      <video>
        <defaultplayer>dvdplayer</defaultplayer>
        <defaultdvdplayer>dvdplayer</defaultdvdplayer>
      </video>
    </advancedsettings>
    and report if it is better/worse than omxplayer. You can still play files with omxplayer using the context-menu "Play using... OMXPlayer".

  2. For passthrough you also need (in config.txt):
    Code:
    no_hdmi_resample=1
    hdmi_stream_channels=1
    And make sure speaker layout is set to 2.0. You will still get 5.1 with AC3/DTS (see here for details).



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Mister XY - 2014-01-27

When i using the OMXplayer for DVD's (build r17048 or r17171) the DVD menu/movies studdert.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Leopold - 2014-01-27

(2014-01-27, 03:56)LehighBri Wrote: Screw trac. I've found many of my issues have been resolved via the forums (I know that's not always the case though).

It looks like this will be the replacement for the broken trac site http://issues.xbmc.org.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Koloss - 2014-01-27

(2014-01-27, 04:45)MilhouseVH Wrote: [*]Avoid choosing TrueHD as default audio stream (in omxplayer)

Running TrueHD passthrough now?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - delinend - 2014-01-27

Just tryed Milehouse new build r17171, and I see some strange thinks, when playing DVD/iso/mpeg2 and MP4 movies.
The screen is jumping, on playback http://netlir.dk/jumping_screen.mp4

I normaly set: Video->Playback->Adjust display refresh rate to match video = Always
I want my screen, to match the movie framerate, otherwise i get jutter in the playback. But now this setting gives me jumpy playback. XBMC menus, is not jumping.. Only playback.

But if i set: Video->Playback->Adjust display refresh rate to match video = Off
The screen is NOT jumping anymore, but I get jutter/frames, when watching 24p pulldown to 60p. Rolleyes

Any ideas?

Best regards


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - LehighBri - 2014-01-27

Popcornmix - I tried millhouse's latest build that includes the EDL debug log addition but I still don't see the new debug message in my log when playing back. See below for the full log file when trying to play that same episode.

http://pastebin.com/bDgdgAhN

PS. I haven't mucked with dvdplayer vs. omxplayer so I'm assuming I'm using the default omx player still? In looking at your commit in newclock3, looks like you touched the dvdplayer code and not the omxplayer code. Should I be using dvdplayer now all of a sudden?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-27

(2014-01-27, 13:48)LehighBri Wrote: PS. I haven't mucked with dvdplayer vs. omxplayer so I'm assuming I'm using the default omx player still? In looking at your commit in newclock3, looks like you touched the dvdplayer code and not the omxplayer code. Should I be using dvdplayer now all of a sudden?

That file is common to omxplayer and dvdplayer. Can you try using context-menu then "Play using dvdplayer" on this file and see if edl works?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-01-27

(2014-01-27, 13:48)LehighBri Wrote: Popcornmix - I tried millhouse's latest build that includes the EDL debug log addition but I still don't see the new debug message in my log when playing back. See below for the full log file when trying to play that same episode.

I think this is the key bit. ffmpeg complains at the start of the file, and can't determine the width/height:
Code:
06:41:26 609.991028 T:2899309648   ERROR: ffmpeg[ACCFF450]: [mpeg2video] 0x0 is invalid

This causes the video codec to not open:
Code:
06:41:27 610.439819 T:2899309648 WARNING: OpenVideoStream - Unsupported stream 0. Stream disabled.

which means we don't read the EDL
Code:
if (m_CurrentVideo.id >= 0 && m_CurrentVideo.hint.fpsrate > 0 && m_CurrentVideo.hint.fpsscale > 0)
  {
    float fFramesPerSecond = (float)m_CurrentVideo.hint.fpsrate / (float)m_CurrentVideo.hint.fpsscale;
    m_Edl.ReadEditDecisionLists(m_filename, fFramesPerSecond, m_CurrentVideo.hint.height);
  }

Now, because we have the "fast channel change patch" this is all fine, and when ffmpeg finally extracts the width/height, the codec gets opened a little later,
but by then it's too late for the EDL file to be opened.

So, two requests. Try with "Play using dvdplayer". I'd like to know if that suffers the same problem.
Can you upload a small recording that behaves this way that I can use for testing fixes?

Also, I believe if you place a "normal" file (mkv/mp4/avi) alongside your EDL file, I believe it will work correctly as ffmpeg will extract the width/height initially.
I also believe that a Gotham nightly (without the fast channel switch patch) wouldn't behave this way.


This forum uses Lukasz Tkacz MyBB addons.