Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - ajp2k14 - 2014-01-31

I don't know if this is the right place for it but is the podnapisi subtitle addon working for anybody? It finds the subs but when downloading I get "Script failed"...

Sorry if this is the wrong place to post but I only have my Pi with Millhouse build to try it on...


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - evanspae - 2014-01-31

(2014-01-31, 15:56)popcornmix Wrote:
(2014-01-31, 15:45)LehighBri Wrote: Thanks again popcornmix. Are there any plans to submit an official PR to XBMC to get this out of newclock3 and into the XBMC master branch? It's by no means critical, just curious.

Yes. Merge windows are first ten days of each month, so starts tomorrow. I'll go through newclock3 and submit PRs for any confirmed improvements.
Technically this EDL one is a bug fix, so could be accepted outside of a merge window. Should be submitted within new few days.

I can also confirm that on Milhouse build r17182 this is working using EDL format as described in http://forum.xbmc.org/showthread.php?tid=184866&pid=1612394#pid1612394..... thanks all for this fix...Big GrinBig Grin


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-01-31

With the recent builds (last couple of weeks?), when I watch a recording with the mythTV PVR plugin, I often have a crash/reboot when the program ends. It does not always happen, maybe 1 time in 4. Anyone else seeing this?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - evanspae - 2014-01-31

(2014-01-31, 21:11)allan87 Wrote: With the recent builds (last couple of weeks?), when I watch a recording with the mythTV PVR plugin, I often have a crash/reboot when the program ends. It does not always happen, maybe 1 time in 4. Anyone else seeing this?

Yes I have noticed the function enhancements and general improvements have made the RPI a a little more unstable. I often get crashes if I am previewing H264 .ts recordings, opening say the 4th recording often causes the system to crash. Unfortunately I am not at home and cannot forward logs.. but I have observed this effect. I rarely get a freeze or crash if I just select a file and play. In my system the Pi is power cycled daily.

I would add all this is to expected on a development system where we are continually pressing for improvements... so devs dont despair carry on good work these are just fed back observations.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-01-31

(2014-01-31, 21:11)allan87 Wrote: With the recent builds (last couple of weeks?), when I watch a recording with the mythTV PVR plugin, I often have a crash/reboot when the program ends. It does not always happen, maybe 1 time in 4. Anyone else seeing this?

Try running bcmstat.sh while watching your recordings - are you running out of GPU memory (maybe a leak of some kind)?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - TBCdevil - 2014-01-31

Just wanted to share that Milhouse's latest build dropped 4% in the filemanager test in did before.
From 18% to 14%. A massive drop in my perspective.
I did not change anything between these two builds.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - markius - 2014-02-01

(2014-01-31, 22:59)TBCdevil Wrote: Just wanted to share that Milhouse's latest build dropped 4% in the filemanager test in did before.

What is the filemanager test?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - TBCdevil - 2014-02-01

I just look at how the CPU idles/throttles when you are inside a certain environment in openelec. Point is to detect differences good or bad. When you are at the filemanager the CPU is at it's lowest in my findings. So it's nice to see it actually dropped.

here is a google doc spreadsheet I created, just a beginning http://goo.gl/r2ybNo


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-02-01

(2014-01-31, 22:02)MilhouseVH Wrote:
(2014-01-31, 21:11)allan87 Wrote: With the recent builds (last couple of weeks?), when I watch a recording with the mythTV PVR plugin, I often have a crash/reboot when the program ends. It does not always happen, maybe 1 time in 4. Anyone else seeing this?

Try running bcmstat.sh while watching your recordings - are you running out of GPU memory (maybe a leak of some kind)?
I'll try. I was wondering if anyone else sees this because I wouldn't want to call it a bug if it is just a symptom of something specific to my system (file corruption, etc.) To be clear, it is not while watching, it is always exactly when the show ends.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-02-01

New OpenELEC Gotham build: #0201
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.13.1 #1 PREEMPT Fri Jan 31 09:17:24 GMT 2014 armv6l GNU/Linux

# vcgencmd version
Jan 28 2014 18:56:53
Copyright (c) 2012 Broadcom
version 8966c433ecd9358a1cdab717d2a1b89999464b10 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140201031403-r17572-gf684ba9

Based on tip of XBMC master (a4342cf, changelog) and tip of OpenELEC master (f684ba9, changelog) with the following modifications:
  • Includes newclock3 commits (except for b0241e5 which I've replaced with a static spinner)
  • Excludes the OpenELEC fernetmenta patches (due to conflict with newclock3)
Build Higlights:
  1. "Show RSS news feeds" moved to "Basic" settings level (OpenELEC patch)
  2. "Show RSS news feeds" now disabled by default in my builds going forward - unlikely to be accepted upstream. Remove guisettings.xml for this change to have any effect.
  3. PR4119 included in XBMC master - this disables notifications during initial device scan, eg. CEC adaptor. Most welcome.

Additional Testing Notes:
  1. Testers should try adding the following entry to their advancedsettings.xml:
    Code:
    <advancedsettings>
      <video>
        <defaultplayer>dvdplayer</defaultplayer>
        <defaultdvdplayer>dvdplayer</defaultdvdplayer>
      </video>
    </advancedsettings>
    and report if it is better/worse than omxplayer. You can still play files with omxplayer using the context-menu "Play using... OMXPlayer".

  2. The following settings are no longer required in config.txt and should be removed:
    Code:
    no_hdmi_resample=1
    hdmi_stream_channels=1
    no_resample_audio is now a default, and hdmi_stream_channels is switched based on audio content. For the time being when using passthrough, 2.0 speaker layout should continue to be used (you will still get 5.1 with AC3/DTS).



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Koloss - 2014-02-01

In this build i can set dts-hd passthrought and true-hd passthrought! But i didnot run. Why can i set this option?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - corb06 - 2014-02-01

(2014-02-01, 05:30)MilhouseVH Wrote: New OpenELEC Gotham build: #0201
(Supercedes previous build)

Hello Milhouse!

I just noticed that Youtube Addon stopped working. Dont know from when, since its been a few weeks since I last used it. I am unable to Login to my account on YouTube. It says Remote network error all the time,.

When trying to open a video stream, nothing happens.


Re: RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Dimitriss - 2014-02-01

(2014-02-01, 12:31)corb06 Wrote:
(2014-02-01, 05:30)MilhouseVH Wrote: New OpenELEC Gotham build: #0201
(Supercedes previous build)

Hello Milhouse!

I just noticed that Youtube Addon stopped working. Dont know from when, since its been a few weeks since I last used it. I am unable to Login to my account on YouTube. It says Remote network error all the time,.

When trying to open a video stream, nothing happens.

This error is unrelated to the build, check the youtube addon thread.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - tdn135 - 2014-02-01

I am a fan of the builds produced here. I would like to report a "bug/missing feature". I am using the latest build of Millhouse #0201 (r17572), but I had the problem since a longer time.

I only use my Pi when I am watching a movie. When I am done with watching, I use the option shutdown in the Pi menu. A minute after that I use a switch to power down all devices (TV, AMP, external HDD, PI and subwoofer) using a power strip. After I press the shutdown option in the PI menu, my external harddisk remains online and spinning.

Is there a possibility to automaticly power down the HDD when shutting down the Pi?

The shutdown code is already found in the openelec options when iddling for xx minutes. My HDD is a Samsung Story Station 3 USB 3.0 harddisk formatted with EXT4.

Thanks!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - john.cord - 2014-02-01

Hi there... i dont know where i should ask this.

I am using the latest milhouse Build on my pi with the "wake remote server" Feature. Everything works except that the Pi is allways on and every hour there is a database access to the video DB which is causing the Pi to wake my Server. Is there anything i can turn off so that there is no Video DB access without a user input?

Nevermind, its the Skin i am using (Aeon Nox 5)...


This forum uses Lukasz Tkacz MyBB addons.