Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-02-15

New OpenELEC Gotham build: #0215
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.13.3 #1 PREEMPT Sat Feb 15 04:37:56 GMT 2014 armv6l GNU/Linux

# vcgencmd version
Feb 14 2014 19:22:36
Copyright (c) 2012 Broadcom
version 45d99f51ad03ec95e6bd087065de3bc825bfce33 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140215043649-r17714-gd8d9e0e

Based on tip of XBMC master (18cebf0, changelog) and tip of OpenELEC master (2376c15, changelog) with the following modifications:
  • Includes newclock3 commits (except for 6cd8357 which I've replaced with a static spinner)
  • Excludes the OpenELEC fernetmenta patches (due to conflict with newclock3)
  • "Show RSS Feed" default setting changed to disabled
  • Reverted ffmpeg commits in order to build XBMC master
Build Higlights:
  1. Firmware: Updated Feb 14 build.
    • Fix orientation of EGL images that originated from hardware video decode. Previously JPEGS and frames from software decoder were flipped compared to hardware decoded frame
  2. newclock3: 2 new commits.
    • Remove flip on video render with updated firmware this should fix upside down video
    • Reduce rate of clock change to reduce video stutters

Additional Testing Notes:
  1. Testers should try adding the following entry to their advancedsettings.xml:
    Code:
    <advancedsettings>
      <video>
        <defaultplayer>dvdplayer</defaultplayer>
        <defaultdvdplayer>dvdplayer</defaultdvdplayer>
      </video>
    </advancedsettings>
    and report if it is better/worse than omxplayer. You can still play files with omxplayer using the context-menu "Play using... OMXPlayer".

  2. The following settings are no longer required in config.txt and should be removed:
    Code:
    no_hdmi_resample=1
    hdmi_stream_channels=1
    no_resample_audio is now a default, and hdmi_stream_channels is switched based on audio content. For the time being when using passthrough, 2.0 speaker layout should continue to be used (you will still get 5.1 with AC3/DTS).



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - maratonomak - 2014-02-15

(2014-02-15, 05:39)MilhouseVH Wrote:
(2014-02-15, 02:25)maratonomak Wrote: Is there any way to have Milhouse build in a zipped file , ready to install to SDC thru windows ? Thanks

Eh? Are you asking for an SD card image - if so, just use an existing image (3.2.4, whatever) then upgrade it to the development build (extract the four target files from the tar file, and copy to the Update folder).

Once you're on Gotham, upgrading is as simple as copying the tar file to the Update folder and rebooting.

Great. Thank you !!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Mister XY - 2014-02-15

Ok, with the new build and active deinterlace, the dvdplayer get asynchron with DVD's.
with deactived deinterlace DVD'S get synchron.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Tar-Dingens - 2014-02-15

There are still some modules missing for the hifiberry. I dont know if it helps but you could look here for the module requirements:http://www.hifiberry.com/products/dac/hifiberry-dac-software/


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - xbs08 - 2014-02-15

Sorry if this brought before but DVDPlayer can't output dual audio.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - xpman - 2014-02-15

Testing the just posted Milhouse #0215 build, found two related problems on 3D movies. I say related cause both are from subtitles:

1.- Subtitles can't be disabled. No matter that you enable or disable. If you try to disable, the default one will be selected (it seems is based on audio language)
2.- Subtitles appear twice, as per the type of 3D video. If side-by-side, will appear on the same horizontal line but twice, and if the video is up-down, will appear twice, centered horizontally, but at two different heights. It seems to me like subtitles are rendered in a different surface than the video reproduction, and that surface is not "multiplexed" into the 3d video reproduction.

The two problems make the 3D movies viewing rather unwatchable. Quite a pity cause the switching to 3D mode works now like a charm, even working automatically on the TV without selecting 3D mode (LG TV).
Note that subs work fine (can be disabled) for non-3D movies.

The rest seems to work fine. Thanks for the release!

Regards


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - corb06 - 2014-02-15

I have some crackeling sound during movie playback. The sound is a bit distorted for a second or two every now and then.

I have set my speakers to 2.0, no downmix, no pass through, using HDMI, and then optical from tv to speakerset.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - k1lla1nvan1lla - 2014-02-16

#2015 build,

- With the new build i can't restart my Pi anymore. Shutdown words perfect, but when i choose to restart the Pi hangs up and i have to cut the power. Skin is Amber.

- My Speakerset is 2.0 with downmix via HDMI directly to my Onkyo 616. Sometimes my speakers are just screaming and my Receiver dont recognize that there is DD oder DTS coming. Then i must stop the movie 1-4 times and it will work.

Sry for my bad english, i'm from germany and its a long time ago i have to use english. Smile just want to help! Usually your images are perfect!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-02-16

(2014-02-15, 23:45)corb06 Wrote: I have some crackeling sound during movie playback. The sound is a bit distorted for a second or two every now and then.

I have set my speakers to 2.0, no downmix, no pass through, using HDMI, and then optical from tv to speakerset.

Does "no_hdmi_resample=0" in config.txt avoid the problem?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2014-02-16

(2014-02-16, 11:56)k1lla1nvan1lla Wrote: #2015 build,

- With the new build i can't restart my Pi anymore. Shutdown words perfect, but when i choose to restart the Pi hangs up and i have to cut the power. Skin is Amber.

- My Speakerset is 2.0 with downmix via HDMI directly to my Onkyo 616. Sometimes my speakers are just screaming and my Receiver dont recognize that there is DD oder DTS coming. Then i must stop the movie 1-4 times and it will work.

Sry for my bad english, i'm from germany and its a long time ago i have to use english. Smile just want to help! Usually your images are perfect!

Is this a new problem? Can you indicate the last build that worked correctly?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - k1lla1nvan1lla - 2014-02-16

Yes, this is a new problem. I think the last build i used was "OpenELEC-RPi.arm-Milhouse-20140207121316-r17666-g54d5888"


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-02-16

(2014-02-16, 11:56)k1lla1nvan1lla Wrote: #2015 build,

- With the new build i can't restart my Pi anymore. Shutdown words perfect, but when i choose to restart the Pi hangs up and i have to cut the power. Skin is Amber.

I can't reproduce this here with stock Confluence skin - can you try with stock Confluence?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - k1lla1nvan1lla - 2014-02-16

Tested this on my System with only SD-Card. Now i'm trying this by my other System using SD with USB-Stick. Have made this all completly new, at the moment i copy my videodatabes and do the cache with your tool. since yet restarting works fine, even with amber skin. i will edit when all thumbnails and fanarts are loaded.

Maybe there is another corrupt on my SD-Card System.

EDIT: Now restarting on this System also works fine. I'm really sure theres something going wrong on my other System. I will make this all new and hope than everyhting is ok.

The sound problem is still alive. Smile


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - botribun - 2014-02-16

It would be nice to exclude the swapfile from the OE-Backup.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-02-16

(2014-02-16, 14:11)botribun Wrote: It would be nice to exclude the swapfile from the OE-Backup.

Wouldn't that be a feature request for whatever tool you are using to create the backup (presumably this one?, I can't find any reference to OE-Backup). You can of course change the location of the swap file by editing the name in .config/swap.conf so maybe moving it to a location that isn't backed up would be one solution.


This forum uses Lukasz Tkacz MyBB addons.