Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2014-04-01

(2014-04-01, 19:56)lucki007 Wrote: mmh, the cat /flash/cmdline.txt and the cat /proc/cmdline shows that it booted with the settings, but the dmesg still shows that both FIQ things are enabled.
Try moving 'quiet' to the end of cmdline.txt.

Also,
- Are you sure your USB drive is sda2? What is sda1?
- Is there some reason you are posting pictures of your terminal output? Can't you just cut and paste into the message?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-04-01

New OpenELEC Gotham build: #0401
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.14.0 #1 PREEMPT Tue Apr 1 18:51:00 BST 2014 armv6l GNU/Linux

# vcgencmd version
Mar 30 2014 15:59:18
Copyright (c) 2012 Broadcom
version 8f13fa508997a043a3d78822e3f67ec044b4e7bf (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140401195740-r18074-gfa2d8e0

Based on tip of XBMC master (1790b03, changelog) and tip of OpenELEC master (fa2d8e0, changelog) with the following modifications:
  • Includes newclock3 commits (except for a702bbe, a patch to avoid hammering the GUI, which has been replaced with a static spinner)
  • Excludes the OpenELEC fernetmenta patches (due to conflict with newclock3)
  • Includes Python regex package for evaluation purposes. Initial benchmarking indicates generally positive (and in some cases, significant) performance gains. See this post for a description of how to test effectiveness of this package with addons.
  • Default setting for "Show RSS Feed" changed to disabled
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • ALSA is enabled and any suitable hardware should be available in XBMC Audio Settings
  • Includes newclock3: "More efficient infobool expression evaluator" (reverted in stock OpenELEC)
  • Includes newclock3: "Allow small audio packets to be concatenated to make better use of audio fifo" (reverted in stock OpenELEC)
Build Highlights:

New 3.14.0 kernel, including FIQ FSM patches. Updated sqlite, mysql, libnfs, RTL8192CU and other libraries.
  1. OpenELEC:
    • New kernel, 3.14.0
    • sqlite: update to sqlite-autoconf-3080402
    • mysql: update to mysql-5.1.73
    • libnfs: update to libnfs-1.9.3
    • ethtool: update to ethtool-3.13
    • RTL8192CU: update to RTL8192CU-v4.0.2_9000.20130911
    • file: update to file-5.18
    • flex: update to flex-2.5.39
    • curl: update to curl-7.35.0
    • flac: update to flac-1.3.0
    • libcdio: update to libcdio-0.92
    • libmodplug: update to libmodplug-0.8.8.5
    • libogg: update to libogg-1.3.1
    • libvorbis: update to libvorbis-1.3.4
    • taglib: update to taglib-1.9.1
    • glew: update to glew-1.10.0
    • nasm: update to nasm-2.11.02
    • libass: update to libass-0.11.1
  2. XBMC:
    • Various paplayer, airplay and videodb fixes

Additional Testing Notes:
  1. Testers should try adding the following entry to their advancedsettings.xml:
    Code:
    <advancedsettings>
      <video>
        <defaultplayer>dvdplayer</defaultplayer>
        <defaultdvdplayer>dvdplayer</defaultdvdplayer>
      </video>
    </advancedsettings>
    and report if it is better/worse than omxplayer. You can still play files with omxplayer using the context-menu "Play using... OMXPlayer".

  2. The following settings are no longer required in config.txt and should be removed:
    Code:
    no_hdmi_resample=1
    hdmi_stream_channels=1
    no_resample_audio is now a default, and hdmi_stream_channels is switched based on audio content. For the time being when using passthrough, 2.0 speaker layout should continue to be used (you will still get 5.1 with AC3/DTS).

  3. The FIQ_FSM patch is now enabled by default in OpenELEC master. See the FIQ_FSM announce thread for details.

    One new feature, currently disabled by default, is accelerated support of high-speed isochronous transactions (webcams, real time devices, etc.). There's a possibility this could be used by ALSA or DVB modules (although not always) which may affect some users (hopefully for the better). If you might benefit from this, enable by adding the following option to the end of the line in your /flash/cmdline.txt file:
    Code:
    dwc_otg.fiq_fsm_mask=0x7



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Koloss - 2014-04-01

Is dts-hd in work? See also true-hd - pcm 5.1!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - mildenhall - 2014-04-01

(2014-04-01, 19:34)MilhouseVH Wrote: Disabling FIQ FSM should restore the pre-FIQ FSM functionality and a working network. Confirm you have successfully disabled FIQ FSM with the dmesg output.

It looks like FIQ is also not disabled for me!

ifconfig
Code:
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

dmesg
Code:
[    1.649806] WARN::dwc_otg_hcd_init:1040: FIQ DMA bounce buffers: virt = 0xd8de6000 dma = 0x56fe0000 len=9024
[    1.649842] FIQ FSM acceleration enabled for :
[    1.649925] WARN::hcd_init:473: FIQ at 0xc04c58a4
[    1.649943] WARN::hcd_init:474: FIQ ASM at 0xc04c5b7c length 36
[    1.651947] dwc_otg: FIQ enabled
[    1.651977] dwc_otg: FIQ split-transaction FSM enabled

/flash/cmdline.txt
Code:
boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 dwc_otg.fiq_enable=0 quiet textmode

/proc/cmdline
Code:
dwc_otg.fiq_enable=1 dwc_otg.fiq_fsm_enable=1 dwc_otg.fiq_fsm_mask=0x3 root=/dev/ram0 rdinit=/init BOOT_IMAGE=/kernel.img dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=984 bcm2708.boardrev=0xf bcm2708.serial=0x9fb56012 smsc95xx.macaddr=B8:27:EB:B5:60:12 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 dwc_otg.fiq_enable=0 quiet textmode

So looking at /proc/cmdline dwc_otg.fiq_enable is enabled at the start of the line and then disabled at the end of the line?!

Does anyone have any ideas?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-04-01

(2014-04-01, 22:07)mildenhall Wrote: Does anyone have any ideas?

Try "dwc_otg.fiq_fsm_enable=0" in place of "dwc_otg.fiq_enable=0"


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - mildenhall - 2014-04-01

(2014-04-01, 22:15)MilhouseVH Wrote: Try "dwc_otg.fiq_fsm_enable=0" in place of "dwc_otg.fiq_enable=0"

Basically the same thing! Confused

Code:
dwc_otg.fiq_enable=1 dwc_otg.fiq_fsm_enable=1 dwc_otg.fiq_fsm_mask=0x3 root=/dev/ram0 rdinit=/init BOOT_IMAGE=/kernel.img dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=984 bcm2708.boardrev=0xf bcm2708.serial=0x9fb56012 smsc95xx.macaddr=B8:27:EB:B5:60:12 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 dwc_otg.fiq_fsm_enable=0 quiet textmode



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - bagofcrap24 - 2014-04-01

Issue with ass (lol) subtitles in 401 build. Only happened about 6-7 times in the last 30 minutes.
Best way to describe it from what I have seen.
Only seen it when 2 lines are displayed.
The first 2 characters of the last word on the first line appear normally.
The 3rd character is then stretched across the entire last word of the first line and the remaining parts of the word are not rendered.
This has happened all but once where it showed a black box instead of stretching the character


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-04-01

(2014-04-01, 22:27)bagofcrap24 Wrote: Issue with ass (lol) subtitles in 401 build. Only happened about 6-7 times in the last 30 minutes.
Best way to describe it from what I have seen.
Only seen it when 2 lines are displayed.
The first 2 characters of the last word on the first line appear normally.
The 3rd character is then stretched across the entire last word of the first line and the remaining parts of the word are not rendered.
This has happened all but once where it showed a black box instead of stretching the character

Does it happen with the #0330 build? The libass library has been updated in #0401, and that would seem the most likely reason for any change.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - bagofcrap24 - 2014-04-01

This entire series has been fine until updating this evening. Since updating all 3 episodes so far have the issue so I would say your right that it's an issue with the updated libass.
It's hard to reproduce because it doesn't happen every time. If it bugs. I skip back and watch again. It doesn't bug the next time.

EDIT: happening all over the place. sometimes repeatable. sometimes not.
for anyone else, this is what it looks like.

Image

Image


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-04-01

Best thing to do now would be confirm that it's a problem in an OpenELEC nightly based on the latest master, and if so open an issue on the OpenELEC github. libass 0.11.1 is the latest stable release however it dates from 19 Feb and there have been a number of commits on the libass github since then so who knows it may already be fixed (I may try including the very latest libass so you can test, but this will only be a one-off as it needs fixing upstream)


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Trixster - 2014-04-01

Youtube videos will not load with #0401, they ran perfectly with the previous build.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-04-01

@bagofcrap24: Try this build (#0401b) which includes all the recent commits on libass github (ie. these changes).

If it fixes the problem you should report this to the OpenELEC developers as I won't be including these libass changes in future builds, unless they're included in OpenELEC master of course. However if it doesn't fix the problem you should still report it to the OpenELEC developers after confirming the problem is in a stock nightly first - then it can hopefully be fixed upstream and included in a future update (or libass reverted back to 0.10.2).

(2014-04-01, 23:05)Trixster Wrote: Youtube videos will not load with #0401, they ran perfectly with the previous build.

debug log (wiki)?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - bagofcrap24 - 2014-04-01

(2014-04-01, 22:52)MilhouseVH Wrote: Best thing to do now would be confirm that it's a problem in an OpenELEC nightly based on the latest master, and if so open an issue on the OpenELEC github. libass 0.11.1 is the latest stable release however it dates from 19 Feb and there have been a number of commits on the libass github since then so who knows it may already be fixed (I may try including the very latest libass so you can test, but this will only be a one-off as it needs fixing upstream)

Do you know where to find a nightly based on the master
(sorry but i'm not all that familiar with all the labels)
previous build works fine
just tried this one
http://xbmcnightlybuilds.com/openelec-rpi-arm-r18067-g4244f63-download-2/
which also works fine but i think this is a gotham build. not master

EDIT: as your previous build works fine. and older gotham builds work fine. I think its pretty safe to say it will be to do with the latest update to libass so I have submitted an issue directly upstream


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - bagofcrap24 - 2014-04-01

(2014-04-01, 23:27)MilhouseVH Wrote: @bagofcrap24: Try this build (#0401b) which includes all the recent commits on libass github (ie. these changes).

If it fixes the problem you should report this to the OpenELEC developers as I won't be including these libass changes in future builds, unless they're included in OpenELEC master of course. However if it doesn't fix the problem you should still report it to the OpenELEC developers after confirming the problem is in a stock nightly first - then it can hopefully be fixed upstream and included in a future update (or libass reverted back to 0.10.2).

it did not fix the problem. but thank you for trying anyway


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2014-04-01

(2014-04-01, 23:28)bagofcrap24 Wrote: Do you know where to find a nightly based on the master
(sorry but i'm not all that familiar with all the labels)

OpenELEC Chimney is one source: http://openelec.thestateofme.com/

Master builds are in the dev_builds directory. The most recent 19:15 build includes all changes upto and including libnfs, so it includes the libass 0.11.1 change.

(2014-04-01, 23:28)bagofcrap24 Wrote: previous build works fine
just tried this one
http://xbmcnightlybuilds.com/openelec-rpi-arm-r18067-g4244f63-download-2/
which also works fine but i think this is a gotham build. not master

That /is/ a build from master, but it doesn't include the libass commit. Match the sha in the filename (4244f63) against the commits on the OpenELEC master branch to determine what the last commit is, in this case it's "nasm: update to nasm-2.11.02" which is the commit just before libass...

EDIT:
(2014-04-01, 23:40)bagofcrap24 Wrote: it did not fix the problem. but thank you for trying anyway

Oh well, then I guess the options are to hope for an upstream fix, or revert back to 0.10.2 assuming this is possible/desirable (there may have been a specific reason for updating to 0.11.1).


This forum uses Lukasz Tkacz MyBB addons.