Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2013-08-24

Testing further these traceback messages (post #406) and it's not the GPU "time" patch (or any other recent newlock3 patch) that is causing these messages as I see them even with a "stock" OE Gotham/master build (22 August, last commit 21d1ea08afed721cd48d87e5f51cfe28542f48a6) with no additional patches.

I've updated post #406 to add an additional vcgencmd loop as running multiple loops should make it easier to provoke the traceback messages. I'd expect them to appear in Rbej builds too.

Here's a pastebin extract of the traceback messages from "stock" Gotham, in case any information is different to that included in post #406.

Firmware details for this "stock" Gotham build:
Code:
rpi512 # vcgencmd version && uname -a
Aug  7 2013 16:19:51
Copyright (c) 2012 Broadcom
version 7c7b17433e2a63025f6f42adcb2b8766eff55e12 (clean) (release)
Linux rpi512 3.10.9 #1 PREEMPT Thu Aug 22 18:18:18 BST 2013 armv6l GNU/Linux

Even running the above "vcgencmd version" command kicks out a traceback message...


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - SSC_Jarod - 2013-08-24

Testing latest build (Aug 24), first impression Boot-Time a little longer since latest build (Aug 22). 3D Problem, that TV doesnt automatic switch to 3D (preferred mode = none) still there.

@popcornmix: in thread 175 i should use that specific build and it works. Did you do anything in the release there specificly and if so, could i do it myself in on of the latest builds (e.g. is there special "switch" to make) to make the xmbc nothing to do, and my TV switches automatic to 3D?

thx in advance for the info.


PS:After testing it seems to me, that all the switches (none, SBS, 2D) do nothing on the picture if i in 3D Mode manually, only affects the menu of xbmc. If i go to 2D the pictures stays in 3D an the Cursor is still on 3D SBS e.g.!

greetz,
J


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - doveman2 - 2013-08-24

(2013-08-24, 08:59)rbej Wrote: Updated Gotham Branch

- updated Xbmc Gotham

http://netlir.dk/rbej/builds/

http://lysin.me/rbej

Is the GUI calibration issue fixed in this?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - rbej - 2013-08-24

I dont think so.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2013-08-24

(2013-08-24, 11:07)MilhouseVH Wrote: Even running the above "vcgencmd version" command kicks out a traceback message...

See:
https://github.com/raspberrypi/linux/issues/361

3.10 kernel tree substantially changes the procfs API, and the procfs code (in vchiq and other out of tree drivers) has been commented out.
Looks like that is causing this issue. I've not investigated so far, but will try to have a look this weekend.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2013-08-24

(2013-08-24, 11:58)SSC_Jarod Wrote: 3D Problem, that TV doesnt automatic switch to 3D (preferred mode = none) still there.

I think that got broken by:
3099 (PR)

I did patch the 3D audo switching code after that went in, but didn't have a 3D tv to test it on. I'll try to investigate more this weekend.

Note: XBMC doesn't support automatically switching to 3D mode on any platform, so until this happens, it's going to be an unofficial hack, and is subject to breaking with other xbmc commits.

I did submit a PR to try to get 3D auto switching support into main XBMC, but the result is that it's complicated and there's no scheme that fits well with the current architecture.
3072 (PR)


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - doveman2 - 2013-08-24

(2013-08-24, 12:06)rbej Wrote: I dont think so.

Thanks for the info.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2013-08-24

(2013-08-24, 12:12)popcornmix Wrote: See:
https://github.com/raspberrypi/linux/issues/361

3.10 kernel tree substantially changes the procfs API, and the procfs code (in vchiq and other out of tree drivers) has been commented out.
Looks like that is causing this issue. I've not investigated so far, but will try to have a look this weekend.

OK many thanks, let me know when you think you have something and I'll thrash it. Smile


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2013-08-24

(2013-08-24, 12:27)MilhouseVH Wrote: OK many thanks, let me know when you think you have something and I'll thrash it. Smile

Check here. linux tree is updated.
https://github.com/raspberrypi/linux/issues/361


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - doveman2 - 2013-08-24

(2013-08-24, 10:30)MilhouseVH Wrote: Is nobody else seeing flaky XBMC NFS straight after booting a Gotham build? This is with a FreeNAS 8.3.x server that is working OK with Frodo (OE 3.1.6). Any attempt to connect with NFS will fail (taking about 2-3 minutes to fail) within the first minute or two after booting - it's fine after that.

I'm using XBMC NFS mounts with a PC running Hanewin Server and don't seem to have any problems playing video straight after boot, even with the EPG data still loading.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Milhouse - 2013-08-24

So, test with the addition of just this patch on top of OE Gotham master, or is there more?

Just popping out for the day, will be able to test tomorrow though.

(2013-08-24, 13:38)doveman2 Wrote: I'm using XBMC NFS mounts with a PC running Hanewin Server and don't seem to have any problems playing video straight after boot, even with the EPG data still loading.

It could be server specific, FreeNAS is based on FreeBSD. Wonder if it's kernel related, has been in the past. May go back to Frodo 12.2 (openelec-3.2 branch) with popcornmix's omx backports tomorrow as Gotham is a bit too cutting edge for my liking and NFS problems are always brushed off as user problems (even when patently not) so a pain to deal with.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2013-08-24

(2013-08-24, 13:44)MilhouseVH Wrote: So, test with the addition of just this patch on top of OE Gotham master, or is there more?

Just popping out for the day, will be able to test tomorrow though.

You need that patch instead of the previous "bcm2708 vchiq driver" patch. Only vchiq_proc.c and vchiq_arm.c changed, and the patch is the initial import of those files, so you can probably just grab the updated version of those two files.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - SSC_Jarod - 2013-08-24

(2013-08-24, 12:20)popcornmix Wrote:
(2013-08-24, 11:58)SSC_Jarod Wrote: 3D Problem, that TV doesnt automatic switch to 3D (preferred mode = none) still there.

I think that got broken by:
3099 (PR)

I did patch the 3D audo switching code after that went in, but didn't have a 3D tv to test it on. I'll try to investigate more this weekend.

Note: XBMC doesn't support automatically switching to 3D mode on any platform, so until this happens, it's going to be an unofficial hack, and is subject to breaking with other xbmc commits.

I did submit a PR to try to get 3D auto switching support into main XBMC, but the result is that it's complicated and there's no scheme that fits well with the current architecture.
3072 (PR)

Hi, thx for the Infos ... and for submit a PR!!! therefore i take the 3D like it is now Wink and didn't bother with this "little" Problem and wait if it is going to be in the following and hopefull upcoming first Beta and/or the final release of Gotham...

Your doin all a great Job, to make a good mediaplayer software also better that it is, too!!! thx for that Wink

happy WE ...

greetz
J.

PS: Evtl. a Tip for you: If you have a Pi, you can test if it works in the "none" Mode, cauas there on my 2nd Pi at my PC Room (connected to a 19" TFT) if the auto-detect works, the picture is automatic displayed as 2D. Cause of this and to not have every 3D Movie twice (3D and 2D) ,my girlfriend can watch on our 2nd TV in Bedroom also the 3D Movies in 2D on a normal Samsung 42".


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - evanspae - 2013-08-24

(2013-08-24, 12:01)doveman2 Wrote:
(2013-08-24, 08:59)rbej Wrote: Updated Gotham Branch

- updated Xbmc Gotham

http://netlir.dk/rbej/builds/

http://lysin.me/rbej

Is the GUI calibration issue fixed in this?
I checked and guisettings are overwritten after reboot as per previous versionSad


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - evanspae - 2013-08-24

(2013-08-24, 14:39)evanspae Wrote:
(2013-08-24, 12:01)doveman2 Wrote:
(2013-08-24, 08:59)rbej Wrote: Updated Gotham Branch

- updated Xbmc Gotham

http://netlir.dk/rbej/builds/

http://lysin.me/rbej

Is the GUI calibration issue fixed in this?
I checked and guisettings are overwritten after reboot as per previous versionSad

This is quite annoying if you alter any advanced settings which require a reboot then key guisettings are overwritten, particularly video calibration, pixel ratio and screen size which make testing some features awkward.... hope it can be fixed soon and that my system does not crash in the meatime Big Grin


This forum uses Lukasz Tkacz MyBB addons.