Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi Part 2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi Part 2 (/showthread.php?tid=184866)



OpenELEC Testbuilds for RaspberryPi Part 2 - kreeturez - 2013-09-11

(2013-09-11, 17:06)popcornmix Wrote: I've also added 3233 (PR) which gives a useful speedup when entering the movies library.
Might be worth a new build.

Aaah, so THAT explains why first-time opening is always so much faster than subsequent opens! Thanks!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - rbej - 2013-09-11

(2013-09-11, 17:06)popcornmix Wrote:
(2013-09-11, 16:00)Jönke Wrote: @rbej
thanks but no live tv!

Did you remove the patches like popcornmix suggested?
http://forum.xbmc.org/showthread.php?tid=169674&pid=1502053#pid1502053

I've managed to reproduce the issue, and it is the "Avoid audio codec when in passthrough modes" commit.
I've removed it from frodo_rbp_backports for now.

I've also added 3233 (PR) which gives a useful speedup when entering the movies library.
Might be worth a new build.

Updated.

Please download today build again.


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Jönke - 2013-09-11

Yes that fixed it ! Live tv with Tvheadend client is back Smile Thanks !

-Issues noticed in this latest Rbej Frodo build, (no problem in OE 3.17)

- Live tv stalls when pvr-menys is open; Timeline -epg, pvr home meny etc
- No subtitles in live-hdtv (same as in all Gotham rpi builds)


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2013-09-11

(2013-09-11, 19:08)Jönke Wrote: - No subtitles in live-hdtv (same as in all Gotham rpi builds)

Has this ever worked on Pi?
Is this teletext subtitles or something else?
Does it work with TV recordings?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Jönke - 2013-09-11

It´s working in rpi OE 3.1.7 (Frodo) but not in Gotham builds.
hdtv subtitles is dvb-sub and xbmc gui sees the subtitle and i can change and toogle language and so on.But xbmc never displays them on screen.
Yes, subtitles in hdtv recordings works


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - popcornmix - 2013-09-11

(2013-09-11, 19:29)Jönke Wrote: It´s working in rpi OE 3.1.7 (Frodo) but not in Gotham builds.

And it works on Gotham on other platforms?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - rbej - 2013-09-11

Gotham FFmpeg 1.2

OpenElec 3.1.7 Frodo and FFmpeg 0.10.7

I think FFmpeg causes this sub issue on Rpi.


OpenELEC Testbuilds for RaspberryPi Part 2 - kreeturez - 2013-09-11

(2013-09-11, 18:14)rbej Wrote:
(2013-09-11, 17:06)popcornmix Wrote: I've also added 3233 (PR) which gives a useful speedup when entering the movies library.
Might be worth a new build.

Updated.

Please download today build again.

Yup, performance when opening Movies list is now consistently faster. Awesome; thanks guys!

EDIT: TV Shows as well!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - Koloss - 2013-09-11

(2013-09-11, 17:06)popcornmix Wrote:
(2013-09-11, 16:00)Jönke Wrote: @rbej
thanks but no live tv!

Did you remove the patches like popcornmix suggested?
http://forum.xbmc.org/showthread.php?tid=169674&pid=1502053#pid1502053

I've managed to reproduce the issue, and it is the "Avoid audio codec when in passthrough modes" commit.
I've removed it from frodo_rbp_backports for now.

I've also added 3233 (PR) which gives a useful speedup when entering the movies library.
Might be worth a new build.

@rbej: make you a new gotham build with this feature?


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - rbej - 2013-09-11

Updated Gotham Branch

- updated Xbmc Gotham

- updated PVR add-on

- remove "Avoid audio codec when in passthrough modes" patch

- add "Speed improvement for opening the movies library" patch

http://netlir.dk/rbej/builds/

http://lysin.me/rbej


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - rtenklooster - 2013-09-12

YESS!!!
Live tv is working again (gotham!!!)
Great and lots of thanks!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - xbs08 - 2013-09-12

Great update, thanks guys!


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - stefan129 - 2013-09-12

(2013-09-11, 22:57)rbej Wrote: Updated Gotham Branch

- updated Xbmc Gotham

- updated PVR add-on

- remove "Avoid audio codec when in passthrough modes" patch

- add "Speed improvement for opening the movies library" patch

http://netlir.dk/rbej/builds/

http://lysin.me/rbej

rbej, any possibility this fix can be included in your next build (enable TLS/SSL support in ffmpeg)?
3193 (PR)


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - sraue - 2013-09-12

(2013-09-12, 14:52)stefan129 Wrote: rbej, any possibility this fix can be included in your next build (enable TLS/SSL support in ffmpeg)?
3193 (PR)

this should be included and supported since ages in the official OpenELEC builds (with external ffmpeg)


RE: OpenELEC Testbuilds for RaspberryPi Part 2 - allan87 - 2013-09-12

Skip/Seek on Myth (and presumably other PVR addons) is fixed!

I have not tested builds from earlier in September, so the fix may precede this build, but today's build is great.


This forum uses Lukasz Tkacz MyBB addons.