Kodi Community Forum
ROM Collector troubles - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=151)
+---- Thread: ROM Collector troubles (/showthread.php?tid=185676)



ROM Collector troubles - elmuziko - 2014-02-08

Hi fellas/ladies

I'm certain this has been done a million times over but I've spent two weeks scoring the internet and have yet to find definitive answers.

I can't for the life of me get yabause (Sega Saturn) or ePSXe/PSXC-R to run my ROM games in ROM Collector.

My SNES and N64 are working fine but Saturn and PS1 just won't work.

They each work as a stand alone. I can even get them working using batch files which emulate the script ROM Collector tries but alas, from within ROM I get a big bag of fail.

With yabause I get the Saturn main screen, it checks the disk but doesn't load.
With the PS1 I get an error about the BIOS.

If anyone is successfully running yabause, or any PS1 emulator would you please be as so kind as to paste their ROM collector config?

Here's mine

Code:
<RomCollection id="3" name="Sega Saturn">
      <useBuiltinEmulator>False</useBuiltinEmulator>
      <gameclient />
      <emulatorCmd>C:\Program Files (x86)\Emulators\Yabause 0.9.13\yabause.exe</emulatorCmd>
      <emulatorParams>-f -i "%ROM%"</emulatorParams>
      <romPath>smb://XBMC:[email protected]/Emulators/Saturn\*.bin</romPath>
      <saveStatePath />
      <saveStateParams />
      <mediaPath type="boxfront">smb://XBMC:[email protected]/Emulators/Artwork/Saturn/boxfront/%GAME%.*</mediaPath>
      <mediaPath type="boxback">smb://XBMC:[email protected]/Emulators/Artwork/Saturn/boxback/%GAME%.*</mediaPath>
      <mediaPath type="cartridge">smb://XBMC:[email protected]/Emulators/Artwork/Saturn/cartridge/%GAME%.*</mediaPath>
      <mediaPath type="screenshot">smb://XBMC:[email protected]/Emulators/Artwork/Saturn/screenshot/%GAME%.*</mediaPath>
      <mediaPath type="fanart">smb://XBMC:[email protected]/Emulators/Artwork/Saturn/fanart/%GAME%.*</mediaPath>
      <preCmd />
      <postCmd />
      <useEmuSolo>False</useEmuSolo>
      <usePopen>False</usePopen>
      <ignoreOnScan>False</ignoreOnScan>
      <allowUpdate>True</allowUpdate>
      <autoplayVideoMain>True</autoplayVideoMain>
      <autoplayVideoInfo>True</autoplayVideoInfo>
      <useFoldernameAsGamename>False</useFoldernameAsGamename>
      <maxFolderDepth>99</maxFolderDepth>
      <doNotExtractZipFiles>False</doNotExtractZipFiles>
      <diskPrefix>_Disk</diskPrefix>
      <imagePlacingMain>gameinfobig</imagePlacingMain>
      <imagePlacingInfo>gameinfosmall</imagePlacingInfo>
      <scraper name="thegamesdb.net" replaceKeyString="" replaceValueString="" />
      <scraper name="archive.vg" replaceKeyString="" replaceValueString="" />
      <scraper name="mobygames.com" replaceKeyString="" replaceValueString="" />
    </RomCollection>
    <RomCollection id="4" name="PlayStation">
      <useBuiltinEmulator>False</useBuiltinEmulator>
      <gameclient />
      <emulatorCmd>C:\Program Files (x86)\Emulators\ESPXe\New Text Document.bat</emulatorCmd>
      <emulatorParams>-nogui -loadbin "%ROM%"</emulatorParams>
      <romPath>smb://XBMC:[email protected]/Emulators/PS1/*.bin</romPath>
      <saveStatePath />
      <saveStateParams />
      <mediaPath type="boxfront">smb://XBMC:[email protected]/Emulators/ArtWork/PS1/boxfront/%GAME%.*</mediaPath>
      <mediaPath type="boxback">smb://XBMC:[email protected]/Emulators/ArtWork/PS1/boxback/%GAME%.*</mediaPath>
      <mediaPath type="cartridge">smb://XBMC:[email protected]/Emulators/ArtWork/PS1/cartridge/%GAME%.*</mediaPath>
      <mediaPath type="screenshot">smb://XBMC:[email protected]/Emulators/ArtWork/PS1/screenshot/%GAME%.*</mediaPath>
      <mediaPath type="fanart">smb://XBMC:[email protected]/Emulators/ArtWork/PS1/fanart/%GAME%.*</mediaPath>
      <preCmd />
      <postCmd />
      <useEmuSolo>False</useEmuSolo>
      <usePopen>False</usePopen>
      <ignoreOnScan>False</ignoreOnScan>
      <allowUpdate>True</allowUpdate>
      <autoplayVideoMain>True</autoplayVideoMain>
      <autoplayVideoInfo>True</autoplayVideoInfo>
      <useFoldernameAsGamename>False</useFoldernameAsGamename>
      <maxFolderDepth>99</maxFolderDepth>
      <doNotExtractZipFiles>False</doNotExtractZipFiles>
      <diskPrefix>_Disk</diskPrefix>
      <imagePlacingMain>gameinfobig</imagePlacingMain>
      <imagePlacingInfo>gameinfosmall</imagePlacingInfo>
      <scraper name="thegamesdb.net" replaceKeyString="" replaceValueString="" />
      <scraper name="archive.vg" replaceKeyString="" replaceValueString="" />
      <scraper name="mobygames.com" replaceKeyString="" replaceValueString="" />
    </RomCollection>



RE: ROM Collector troubles - elmuziko - 2014-02-12

Fixed this myself using mapped drives which in turn presented another problem in that using group policy to boot straight into XBMC meant the drives didn't get a chance to map.
Resolved by created a GP to remove then remap drives on boot-up.


This forum uses Lukasz Tkacz MyBB addons.