Kodi Community Forum
[Project] Dual Audio Output support (Krypton/Jarvis/Isengard/Helix/Gotham/Frodo) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Kodi Application (https://forum.kodi.tv/forumdisplay.php?fid=93)
--- Thread: [Project] Dual Audio Output support (Krypton/Jarvis/Isengard/Helix/Gotham/Frodo) (/showthread.php?tid=192480)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - sakos - 2015-01-03

(2015-01-02, 08:35)xhbl Wrote: Development for Helix 14.0 and OpenELEC 5.0.0 was done, enjoy!
Many thanks!
I had some issues during the configuration (no or discontinuous sound) but finally it works great. Exactly what I need. Thanks again.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ReMi - 2015-01-03

Unfortunately i can't compile it on Ubuntu Huh

Tried it as below:
Code:
apt-get build-dep xbmc
git clone https://github.com/xhbl/Kodi_dualaudio
./bootstrap
./configure --prefix=/usr
make -j4

But building stops with error:
Code:
AR      xbmc/pictures/pictures.a
AFPFile.cpp: In member function ‘virtual ssize_t XFILE::CAFPFile::Read(void*, size_t)’:
AFPFile.cpp:558:100: warning: format ‘%d’ expects argument of type ‘int’, but argument 4 has type ‘ssize_t {aka long int}’ [-Wformat=]
     CLog::Log(LOGERROR, "%s - Error( %d, %d, %s )", __FUNCTION__, bytesRead, errno, strerror(errno));
^
Any ideas ?





Update:
Possible the dependancies are not met ... ??
add-apt-repository ppa:team-xbmc/xbmc-ppa-build-depends
apt-get update :
W: Failed to fetch http://ppa.launchpad.net/team-xbmc/xbmc-ppa-build-depends/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found
(latest available is "raring")


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - methcat - 2015-01-03

My party is back on, thanks again


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - deletedpenguin - 2015-01-03

Working great here on Helix - thanks a bunch!


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - monobaco - 2015-01-04

Hello,

once compiled on kodibuntu (ubuntu+linux method on readme docs on github) results in no double audio...

System summary tells kodi 15.alpha1... but no double audio.

I dont compile in linux... so is possible my fault, but dont know where´s fail..

My english is so bad i hope you can understand me...

Thanks in advance.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ubuntu-xbmc - 2015-01-04

(2015-01-04, 03:18)monobaco Wrote: once compiled on kodibuntu (ubuntu+linux method on readme docs on github) results in no double audio...

System summary tells kodi 15.alpha1... but no double audio.

Did you select the Helix-DA branch with git? Here's what just worked for me:

Code:
(1) cd ~
(2) git clone https://github.com/xhbl/Kodi_dualaudio
(3) cd Kodi_dualaudio/
(4) git branch -v -a  [not required, but will show you what options (branches) are available]
(5) git branch -t remotes/origin/Helix-DA
(6) ./bootstrap
(7) ./configure [I use ' ./configure --enable-external-libraries ' for Ubuntu]
(8) make
(9) sudo make install

From what you describe, it sounds like you skipped step 5. You may be able to use ' git clean -xfd ' then proceed from step 5. If you get a cryptic git error, just erase the whole directory and start fresh.


Xhbl and DarkAngel and others involved,

Many thanks, I just compiled and am looking forward to setting it up.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - monobaco - 2015-01-04

Thank you very much, it works!!!


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ReMi - 2015-01-04

(2015-01-04, 08:05)ubuntu-xbmc Wrote: Did you select the Helix-DA branch with git? Here's what just worked for me:
Code:
(1) cd ~
(2) git clone https://github.com/xhbl/Kodi_dualaudio
(3) cd Kodi_dualaudio/
(4) git branch -v -a  [not required, but will show you what options (branches) are available]
(5) git branch -t remotes/origin/Helix-DA
(6) ./bootstrap
(7)  ./configure --prefix=/usr --enable-external-libraries
(8) make -j4
(9) sudo make install

From what you describe, it sounds like you skipped step 5.

Removed the folder and tried a fresh run .
But unfortunately after adding step 5 i get the same problem while building (step 8)

configure: WARNING: unrecognized options: --enable-external-libraries


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ubuntu-xbmc - 2015-01-04

ReMi,

You didn't quite give enough info for me to help, but the crux appear to be your version of Ubuntu is newer than the build dependencies PPA installed supports. Launchpad doesn't seem to support build dependencies for Ubuntu 14. So, you can try to add the build dependencies manually.

But without seeing more of your build log, I'm not sure what one you are missing (someone else might see the issue from experience though). Here is a list of dependencies that I've seen required before (but I can't vouch that they are still all required, but I doubt they would cause a problem).

Code:
sudo apt-get install automake autopoint bison build-essential ccache cmake curl cvs default-jre fp-compiler gawk gdc gettext git-core gperf libasound2-dev libass-dev libavcodec-dev libavfilter-dev libavformat-dev libavutil-dev libbluetooth-dev libbluray-dev libbluray1 libboost-dev libboost-thread-dev libbz2-dev libcap-dev libcdio-dev libcec-dev libcec1 libcrystalhd-dev libcrystalhd3 libcurl3 libcurl4-gnutls-dev libcwiid-dev libcwiid1 libdbus-1-dev libenca-dev libflac-dev libfontconfig-dev libfreetype6-dev libfribidi-dev libglew-dev libiso9660-dev libjasper-dev libjpeg-dev libltdl-dev liblzo2-dev libmad0-dev libmicrohttpd-dev libmodplug-dev libmp3lame-dev libmpeg2-4-dev libmpeg3-dev libmysqlclient-dev libnfs-dev libogg-dev libpcre3-dev libplist-dev libpng-dev libpostproc-dev libpulse-dev libsamplerate-dev libsdl-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libshairport-dev libsmbclient-dev libsqlite3-dev libssh-dev libssl-dev libswscale-dev libtiff-dev libtinyxml-dev libtool libudev-dev libusb-dev libva-dev libva-egl1 libva-tpi1 libvdpau-dev libvorbisenc2 libxml2-dev libxmu-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev libyajl-dev mesa-utils nasm pmount python-dev python-imaging python-sqlite swig unzip yasm zip zlib1g-dev -y

sudo apt-get install libtiff5-dev lGLEW freeglut3 freeglut3-dev libglew1.6 glew-utils libglew-dev

Then do

Code:
make clean

and try to compile again from step 5. I'd avoid the -j4 option at least for now.

If that doesn't work you should post:

- Did the ./configure step complete successfully?
- What are the lines (maybe 15) before your build error?
- did the apt-get lines above install software, or were all those present already?


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - monobaco - 2015-01-05

in my case, command make doesnt finish ok because of cec devices, before compilation i make a compilation of cec from github.


hope it helps in your case...


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ReMi - 2015-01-06

(2015-01-04, 21:27)ubuntu-xbmc Wrote: ReMi,

You didn't quite give enough info for me to help, but the crux appear to be your version of Ubuntu is newer than the build dependencies PPA installed supports. Launchpad doesn't seem to support build dependencies for Ubuntu 14. So, you can try to add the build dependencies manually.

Thanks for your input Big Grin

Installed the depandancies, but lGLEW is not found in my sources ...
Compiled and installed GLEW manually

Got same error after building DA branch..

Will try to use a fresh install of KodiBuntu (instead of updating XBMCbuntu)


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ReMi - 2015-01-06

- Installed Fresh KodiBuntu
- Dependancies as described above (iGLEW still not found)
- apt-get build-dep kodi (now installs dependancies)

After make got following error:
Code:
CPP     xbmc/peripherals/devices/PeripheralTuner.o
CPP     xbmc/peripherals/devices/PeripheralCecAdapter.o
PeripheralCecAdapter.cpp: In member function ‘void PERIPHERALS::CPeripheralCecAdapter::PushCecKeypress(const cec_keypress&)’:
PeripheralCecAdapter.cpp:865:8: error: ‘CEC_USER_CONTROL_CODE_TOP_MENU’ was not declared in this scope
   case CEC_USER_CONTROL_CODE_TOP_MENU:
        ^
PeripheralCecAdapter.cpp:869:8: error: ‘CEC_USER_CONTROL_CODE_DVD_MENU’ was not declared in this scope
   case CEC_USER_CONTROL_CODE_DVD_MENU:
        ^
PeripheralCecAdapter.cpp:1070:8: error: ‘CEC_USER_CONTROL_CODE_NUMBER_ENTRY_MODE’ was not declared in this scope
   case CEC_USER_CONTROL_CODE_NUMBER_ENTRY_MODE:
        ^
PeripheralCecAdapter.cpp:1071:8: error: ‘CEC_USER_CONTROL_CODE_NUMBER11’ was not declared in this scope
   case CEC_USER_CONTROL_CODE_NUMBER11:
        ^
PeripheralCecAdapter.cpp:1072:8: error: ‘CEC_USER_CONTROL_CODE_NUMBER12’ was not declared in this scope
   case CEC_USER_CONTROL_CODE_NUMBER12:
        ^
PeripheralCecAdapter.cpp:1073:8: error: ‘CEC_USER_CONTROL_CODE_SELECT_BROADCAST_TYPE’ was not declared in this scope
   case CEC_USER_CONTROL_CODE_SELECT_BROADCAST_TYPE:
        ^
PeripheralCecAdapter.cpp:1074:8: error: ‘CEC_USER_CONTROL_CODE_SELECT_SOUND_PRESENTATION’ was not declared in this scope
   case CEC_USER_CONTROL_CODE_SELECT_SOUND_PRESENTATION:
        ^
PeripheralCecAdapter.cpp: In member function ‘void PERIPHERALS::CPeripheralCecAdapter::SetConfigurationFromSettings()’:
PeripheralCecAdapter.cpp:1291:35: error: ‘CEC_CLIENT_VERSION_2_2_0’ was not declared in this scope
   m_configuration.clientVersion = CEC_CLIENT_VERSION_2_2_0;
                                   ^
In file included from /root/Kodi_dualaudio/xbmc/guilib/GUIControl.h:30:0,
                 from /root/Kodi_dualaudio/xbmc/guilib/GUIControlGroup.h:28,
                 from /root/Kodi_dualaudio/xbmc/guilib/GUIWindow.h:31,
                 from /root/Kodi_dualaudio/xbmc/guilib/GUIDialog.h:28,
                 from /root/Kodi_dualaudio/xbmc/dialogs/GUIDialogKaiToast.h:23,
                 from PeripheralCecAdapter.cpp:29:
/root/Kodi_dualaudio/xbmc/guilib/GraphicContext.h: At global scope:
/root/Kodi_dualaudio/xbmc/guilib/GraphicContext.h:288:150: warning: ‘g_graphicsContext’ defined but not used [-Wunused-variable]
XBMC_GLOBAL(CGraphicContext,g_graphicsContext);
                                                                                                                                                      ^
make[1]: *** [PeripheralCecAdapter.o] Error 1
make: *** [xbmc/peripherals/devices/peripheral-devices.a] Error 2



RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - Juno - 2015-01-06

(2015-01-02, 08:35)xhbl Wrote: Development for Helix 14.0 and OpenELEC 5.0.0 was done, enjoy!

Thank You!


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ReMi - 2015-01-06

(2015-01-05, 00:47)monobaco Wrote: in my case, command make doesnt finish ok because of cec devices, before compilation i make a compilation of cec from github.

hope it helps in your case...

I added libcec (apt-get install libcec)
what did you compile ?
is it this one ? https://github.com/Pulse-Eight/libcec


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - DianeDrews - 2015-01-07

(2015-01-04, 08:05)ubuntu-xbmc Wrote:
(2015-01-04, 03:18)monobaco Wrote: once compiled on kodibuntu (ubuntu+linux method on readme docs on github) results in no double audio...

System summary tells kodi 15.alpha1... but no double audio.

Did you select the Helix-DA branch with git? Here's what just worked for me:

Code:
(1) cd ~
(2) git clone https://github.com/xhbl/Kodi_dualaudio
(3) cd Kodi_dualaudio/
(4) git branch -v -a  [not required, but will show you what options (branches) are available]
(5) git branch -t remotes/origin/Helix-DA
(6) ./bootstrap
(7) ./configure [I use ' ./configure --enable-external-libraries ' for Ubuntu]
(8) make
(9) sudo make install

From what you describe, it sounds like you skipped step 5. You may be able to use ' git clean -xfd ' then proceed from step 5. If you get a cryptic git error, just erase the whole directory and start fresh.


Xhbl and DarkAngel and others involved,

Many thanks, I just compiled and am looking forward to setting it up.

Hey Guys

Many, many thanks to the developers!

I just tried to build this a couple of different ways on Ubuntu 14.04 but i keep getting this error:

Copying kodi binary to /usr/local/lib/kodi/
install: cannot stat ‘kodi-xrandr’: No such file or directory
make: *** [install-binaries] Error 1


Any thoughts?


Thanks


This forum uses Lukasz Tkacz MyBB addons.